aboutsummaryrefslogtreecommitdiff
path: root/sysutils/gnome-system-monitor
diff options
context:
space:
mode:
authorJoe Marcus Clarke <marcus@FreeBSD.org>2004-04-13 05:05:21 +0000
committerJoe Marcus Clarke <marcus@FreeBSD.org>2004-04-13 05:05:21 +0000
commit0428ca563d25bd1481beded5ad423350bdef9ed0 (patch)
treef9fd392db566b92d58cfa320646ee5ea5249cef0 /sysutils/gnome-system-monitor
parentcf618f0be158471f7780504664255127e450a257 (diff)
downloadports-0428ca563d25bd1481beded5ad423350bdef9ed0.tar.gz
ports-0428ca563d25bd1481beded5ad423350bdef9ed0.zip
Fix a potential crash when looking at the process list due to a missing
field name.
Notes
Notes: svn path=/head/; revision=106870
Diffstat (limited to 'sysutils/gnome-system-monitor')
-rw-r--r--sysutils/gnome-system-monitor/Makefile1
-rw-r--r--sysutils/gnome-system-monitor/files/patch-src::proctable.c30
2 files changed, 22 insertions, 9 deletions
diff --git a/sysutils/gnome-system-monitor/Makefile b/sysutils/gnome-system-monitor/Makefile
index ddf03c8cbaf9..bc7d76f751b2 100644
--- a/sysutils/gnome-system-monitor/Makefile
+++ b/sysutils/gnome-system-monitor/Makefile
@@ -7,6 +7,7 @@
PORTNAME= gnomesystemmonitor
PORTVERSION= 2.6.0
+PORTREVISION= 1
CATEGORIES= sysutils gnome
MASTER_SITES= ${MASTER_SITE_GNOME}
MASTER_SITE_SUBDIR= sources/gnome-system-monitor/2.6
diff --git a/sysutils/gnome-system-monitor/files/patch-src::proctable.c b/sysutils/gnome-system-monitor/files/patch-src::proctable.c
index 5cb348a5aabb..1d706de36701 100644
--- a/sysutils/gnome-system-monitor/files/patch-src::proctable.c
+++ b/sysutils/gnome-system-monitor/files/patch-src::proctable.c
@@ -1,6 +1,18 @@
---- src/proctable.c.orig Sat Jun 7 04:35:32 2003
-+++ src/proctable.c Thu Sep 4 16:29:18 2003
-@@ -539,6 +539,9 @@
+--- src/proctable.c.orig Sun Feb 8 10:06:08 2004
++++ src/proctable.c Tue Apr 13 01:01:51 2004
+@@ -147,8 +147,9 @@
+ G_TYPE_STRING, G_TYPE_STRING, G_TYPE_STRING,
+ G_TYPE_STRING, G_TYPE_STRING, G_TYPE_STRING,
+ G_TYPE_STRING, G_TYPE_STRING, G_TYPE_STRING,
+- G_TYPE_INT, G_TYPE_INT, G_TYPE_INT,
+- GDK_TYPE_PIXBUF, G_TYPE_POINTER);
++ G_TYPE_STRING, G_TYPE_INT, G_TYPE_INT,
++ G_TYPE_INT, GDK_TYPE_PIXBUF,
++ G_TYPE_POINTER);
+
+ proctree = gtk_tree_view_new_with_model (GTK_TREE_MODEL (model));
+ gtk_tree_view_set_rules_hint (GTK_TREE_VIEW (proctree), TRUE);
+@@ -547,6 +548,9 @@
glibtop_get_proc_uid (&procuid, pid);
glibtop_get_proc_time (&proctime, pid);
newcputime = proctime.utime + proctime.stime;
@@ -9,8 +21,8 @@
+ }
model = gtk_tree_view_get_model (GTK_TREE_VIEW (procdata->tree));
- info->mem = procmem.size;
-@@ -620,6 +623,9 @@
+ wnck_pid_read_resource_usage (gdk_screen_get_display (gdk_screen_get_default ()),
+@@ -651,6 +655,9 @@
glibtop_get_proc_uid (&procuid, pid);
glibtop_get_proc_time (&proctime, pid);
newcputime = proctime.utime + proctime.stime;
@@ -18,9 +30,9 @@
+ newcputime /= (proctime.frequency/100);
+ }
- arguments = glibtop_get_proc_args (&procargs, pid, 0);
- get_process_name (procdata, info, procstate.cmd, arguments);
-@@ -709,12 +715,20 @@
+ wnck_pid_read_resource_usage (gdk_screen_get_display (gdk_screen_get_default ()),
+ pid,
+@@ -751,12 +758,20 @@
return NULL;
}
@@ -41,7 +53,7 @@
while (i < n)
{
-@@ -812,6 +826,9 @@
+@@ -848,6 +863,9 @@
** should probably have a total_time_last gint in the ProcInfo structure */
glibtop_get_cpu (&cpu);
total_time = cpu.total - total_time_last;