aboutsummaryrefslogtreecommitdiff
path: root/sysutils/gnomecontrolcenter
diff options
context:
space:
mode:
authorAde Lovett <ade@FreeBSD.org>2000-08-04 01:17:03 +0000
committerAde Lovett <ade@FreeBSD.org>2000-08-04 01:17:03 +0000
commit1a811e09896f1d6f3d4eeeec42326d7155b35cb5 (patch)
treea38dd93b46e44e92f2b7514aac6e866c06534a89 /sysutils/gnomecontrolcenter
parent1e22de094022b9b6c70098694edb2a3f4ba01e8b (diff)
downloadports-1a811e09896f1d6f3d4eeeec42326d7155b35cb5.tar.gz
ports-1a811e09896f1d6f3d4eeeec42326d7155b35cb5.zip
Update to 1.2.1
Notes
Notes: svn path=/head/; revision=31285
Diffstat (limited to 'sysutils/gnomecontrolcenter')
-rw-r--r--sysutils/gnomecontrolcenter/Makefile15
-rw-r--r--sysutils/gnomecontrolcenter/distinfo2
-rw-r--r--sysutils/gnomecontrolcenter/files/patch-bn33
-rw-r--r--sysutils/gnomecontrolcenter/pkg-plist22
4 files changed, 38 insertions, 34 deletions
diff --git a/sysutils/gnomecontrolcenter/Makefile b/sysutils/gnomecontrolcenter/Makefile
index b436bf414a24..bad62d52c0f6 100644
--- a/sysutils/gnomecontrolcenter/Makefile
+++ b/sysutils/gnomecontrolcenter/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= gnomecontrolcenter
-PORTVERSION= 1.2.0
+PORTVERSION= 1.2.1
CATEGORIES= sysutils gnome
MASTER_SITES= ${MASTER_SITE_GNOME}
MASTER_SITE_SUBDIR= stable/sources/control-center
@@ -14,7 +14,8 @@ DISTNAME= control-center-${PORTVERSION}
MAINTAINER= vanilla@FreeBSD.org
-LIB_DEPENDS= gnome.4:${PORTSDIR}/x11/gnomelibs
+LIB_DEPENDS= gnome.4:${PORTSDIR}/x11/gnomelibs \
+ gdk_pixbuf.2:${PORTSDIR}/graphics/gdk-pixbuf
GTK_CONFIG?= ${X11BASE}/bin/gtk12-config
@@ -23,10 +24,16 @@ USE_GMAKE= yes
USE_LIBTOOL= yes
INSTALLS_SHLIB= yes
CONFIGURE_ARGS= --localstatedir=${PREFIX}/share/gnome \
- --datadir=${PREFIX}/share/gnome \
- --with-gnome=${PREFIX}
+ --datadir=${PREFIX}/share/gnome
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
GTK_CONFIG="${GTK_CONFIG}" \
LIBS="-L${LOCALBASE}/lib"
+post-extract:
+ @${PERL} -pi -e 's|-lpthread|-pthread|g ; \
+ s|DATADIRNAME=lib|DATADIRNAME=share|g' ${WRKSRC}/configure
+ @find ${WRKSRC} -name "Makefile.in" | xargs ${PERL} -pi -e \
+ 's|\$\(datadir\)/gnome/|\$\(datadir\)/|g ; \
+ s|\$\(datadir\)/locale|\$\(prefix\)/share/locale|g'
+
.include <bsd.port.mk>
diff --git a/sysutils/gnomecontrolcenter/distinfo b/sysutils/gnomecontrolcenter/distinfo
index 986850c6ce1d..ff55d368f09c 100644
--- a/sysutils/gnomecontrolcenter/distinfo
+++ b/sysutils/gnomecontrolcenter/distinfo
@@ -1 +1 @@
-MD5 (control-center-1.2.0.tar.gz) = c846abe32f63f409fb803b2960b7ba2e
+MD5 (control-center-1.2.1.tar.gz) = dff1aad70637e59919f3ec57ff1bfae6
diff --git a/sysutils/gnomecontrolcenter/files/patch-bn b/sysutils/gnomecontrolcenter/files/patch-bn
index da5233b16277..96c34a77aa91 100644
--- a/sysutils/gnomecontrolcenter/files/patch-bn
+++ b/sysutils/gnomecontrolcenter/files/patch-bn
@@ -1,39 +1,16 @@
---- control-center/Makefile.in.orig Tue Oct 5 16:45:56 1999
-+++ control-center/Makefile.in Wed Feb 23 13:42:28 2000
-@@ -131,7 +131,7 @@
- cxxflags_set = @cxxflags_set@
- l = @l@
-
--INCLUDES = -DGNOMELOCALEDIR=\""$(datadir)/locale"\" -I$(top_srcdir)/intl -I$(top_builddir)/intl -I$(includedir) $(GNOME_INCLUDEDIR) -DVERSION=\""$(VERSION)"\"
-+INCLUDES = -DGNOMELOCALEDIR=\""$(prefix)/share/locale"\" -I$(top_srcdir)/intl -I$(top_builddir)/intl -I$(includedir) $(GNOME_INCLUDEDIR) -DVERSION=\""$(VERSION)"\"
-
-
- bin_PROGRAMS = gnomecc
-@@ -154,16 +154,16 @@
-
- EXTRA_DIST = gnomecc.desktop cappletConf.sh.in $(appicon_DATA)
-
--sysdir = $(datadir)/gnome/apps/Settings
-+sysdir = $(datadir)/apps/Settings
- sys_DATA = gnomecc.desktop
+--- control-center/Makefile.in.orig Tue Aug 1 22:42:01 2000
++++ control-center/Makefile.in Tue Aug 1 22:45:47 2000
+@@ -162,3 +162,3 @@
-confexecdir = $(libdir)
+confexecdir = $(sysconfdir)
confexec_DATA = cappletConf.sh
-
- libcapplet_la_SOURCES = capplet-widget.c capplet-widget-libs.c capplet-widget-libs.h $(CORBA_SRCLIST)
-
+@@ -168,3 +168,3 @@
-libcapplet_la_LDFLAGS = -version-info 0:0:0 -rpath $(libdir)
+libcapplet_la_LDFLAGS = -version-info 4:0:0
libcapplet_la_LIBADD = $(ORB_LIBS) -lm $(DL_LIB) $(GNORBA_LIBS)
-
- include_HEADERS = capplet-widget.h
-@@ -561,6 +561,7 @@
- -e 's?\@GNOMEUI_LIBS\@?$(GNOMEUI_LIBS)?g' \
- -e 's?\@GNOME_INCLUDEDIR\@?$(GNOME_INCLUDEDIR)?g' \
+@@ -590,2 +590,3 @@
-e 's?\@ORB_LIBS\@?$(ORB_LIBS)?g' \
+ -e 's?\@VERSION\@?$(VERSION)?g' \
< $(srcdir)/cappletConf.sh.in > cappletConf.tmp \
- && mv cappletConf.tmp cappletConf.sh
-
diff --git a/sysutils/gnomecontrolcenter/pkg-plist b/sysutils/gnomecontrolcenter/pkg-plist
index 390499d53bac..0df676c9f894 100644
--- a/sysutils/gnomecontrolcenter/pkg-plist
+++ b/sysutils/gnomecontrolcenter/pkg-plist
@@ -188,6 +188,9 @@ share/gnome/control-center/UIOptions/.directory
share/gnome/control-center/UIOptions/application.desktop
share/gnome/control-center/UIOptions/dialogs.desktop
share/gnome/control-center/UIOptions/mdi.desktop
+share/gnome/help/control-center/C/desktop-intro.html
+share/gnome/help/control-center/C/doc-handlers.html
+share/gnome/help/control-center/C/docbook.css
share/gnome/help/control-center/C/figs/bg-capplet.png
share/gnome/help/control-center/C/figs/gccappdef.png
share/gnome/help/control-center/C/figs/gccdialog.png
@@ -206,15 +209,32 @@ share/gnome/help/control-center/C/figs/mouse-capplet.png
share/gnome/help/control-center/C/figs/screensave-capplet.png
share/gnome/help/control-center/C/figs/theme-select.png
share/gnome/help/control-center/C/figs/wm-main.png
+share/gnome/help/control-center/C/gccui.html
share/gnome/help/control-center/C/index.html
+share/gnome/help/control-center/C/ln7.html
+share/gnome/help/control-center/C/multimedia-intro.html
+share/gnome/help/control-center/C/peripherals.html
+share/gnome/help/control-center/C/session.html
+share/gnome/help/control-center/C/stylesheet-images/caution.gif
+share/gnome/help/control-center/C/stylesheet-images/home.gif
+share/gnome/help/control-center/C/stylesheet-images/important.gif
+share/gnome/help/control-center/C/stylesheet-images/next.gif
+share/gnome/help/control-center/C/stylesheet-images/note.gif
+share/gnome/help/control-center/C/stylesheet-images/prev.gif
+share/gnome/help/control-center/C/stylesheet-images/tip.gif
+share/gnome/help/control-center/C/stylesheet-images/toc-blank.gif
+share/gnome/help/control-center/C/stylesheet-images/toc-minus.gif
+share/gnome/help/control-center/C/stylesheet-images/toc-plus.gif
+share/gnome/help/control-center/C/stylesheet-images/up.gif
+share/gnome/help/control-center/C/stylesheet-images/warning.gif
share/gnome/help/control-center/C/topic.dat
share/gnome/idl/control-center.idl
share/gnome/pixmaps/ccsplash.png
share/gnome/pixmaps/control-center.png
share/gnome/wm-properties/Enlightenment.desktop
share/gnome/wm-properties/IceWM.desktop
-share/gnome/wm-properties/WindowMaker.desktop
share/gnome/wm-properties/Scwm.desktop
+share/gnome/wm-properties/WindowMaker.desktop
share/gnome/wm-properties/twm.desktop
share/locale/ca/LC_MESSAGES/control-center.mo
share/locale/cs/LC_MESSAGES/control-center.mo