aboutsummaryrefslogtreecommitdiff
path: root/sysutils/gtk-imonc/Makefile
diff options
context:
space:
mode:
authorOliver Braun <obraun@FreeBSD.org>2002-10-26 20:07:44 +0000
committerOliver Braun <obraun@FreeBSD.org>2002-10-26 20:07:44 +0000
commit45a14fbe34f407606c959c0f1a5bd0e6ed131307 (patch)
treeeea9560d6c77d128a877088cfde179a6401f1e88 /sysutils/gtk-imonc/Makefile
parentec23fdf17fe204acf4ebd3bb3d43d899c27f9eb9 (diff)
downloadports-45a14fbe34f407606c959c0f1a5bd0e6ed131307.tar.gz
ports-45a14fbe34f407606c959c0f1a5bd0e6ed131307.zip
Add gtk-imonc, a gtk based client to control an one disc fli4l router.
PR: 44503 Submitted by: Steffen Vogelreuter <steffen@vogelreuter.de>
Notes
Notes: svn path=/head/; revision=68888
Diffstat (limited to 'sysutils/gtk-imonc/Makefile')
-rw-r--r--sysutils/gtk-imonc/Makefile29
1 files changed, 29 insertions, 0 deletions
diff --git a/sysutils/gtk-imonc/Makefile b/sysutils/gtk-imonc/Makefile
new file mode 100644
index 000000000000..b225213d2c0d
--- /dev/null
+++ b/sysutils/gtk-imonc/Makefile
@@ -0,0 +1,29 @@
+# New ports collection makefile for: gtk-imonc
+# Date Created: 26. October 2002
+# Whom: Steffen Vogelreuter
+#
+# $FreeBSD$
+#
+
+PORTNAME= gtk-imonc
+PORTVERSION= 0.3a
+CATEGORIES= sysutils
+MASTER_SITES= http://userpage.fu-berlin.de/~zeank/gtk-imonc/download/
+
+MAINTAINER= steffen@vogelreuter.de
+
+WRKSRC= ${WRKDIR}/${DISTNAME:S/_/-/}
+ALL_TARGET= #empty
+HAS_CONFIGURE= yes
+USE_GMAKE= yes
+USE_GNOME= gtk12
+USE_GNOMENG= yes
+USE_REINPLACE= yes
+USE_X_PREFIX= yes
+
+post-patch:
+ @${REINPLACE_CMD} -e 's|gtk-config|gtk12-config|g ; \
+ s|/usr/local|${X11BASE}|g' \
+ ${WRKSRC}/configure
+
+.include <bsd.port.mk>