aboutsummaryrefslogtreecommitdiff
path: root/sysutils/hal
diff options
context:
space:
mode:
authorJoe Marcus Clarke <marcus@FreeBSD.org>2009-03-31 02:19:58 +0000
committerJoe Marcus Clarke <marcus@FreeBSD.org>2009-03-31 02:19:58 +0000
commitfa11efae6905b5eade15a8ed3c71746a2ade80c9 (patch)
treebf170853f52107bad73cb1b04dbffcb01fe9a906 /sysutils/hal
parent1c468c4d48848f9a46d98b2fbd4d30a1b1857fcd (diff)
downloadports-fa11efae6905b5eade15a8ed3c71746a2ade80c9.tar.gz
ports-fa11efae6905b5eade15a8ed3c71746a2ade80c9.zip
One more fix for hal and PolicyKit. Apparently haldaemon requires
org.freedesktop.policykit.read privilege to read the PK config. It's great they document this so well. This, plus the last PK fix should fix the various mounting problems some people have been seeing.
Notes
Notes: svn path=/head/; revision=231338
Diffstat (limited to 'sysutils/hal')
-rw-r--r--sysutils/hal/Makefile2
-rw-r--r--sysutils/hal/files/pkg-deinstall.in5
-rw-r--r--sysutils/hal/files/pkg-install.in2
3 files changed, 8 insertions, 1 deletions
diff --git a/sysutils/hal/Makefile b/sysutils/hal/Makefile
index f642ab27210d..4baa4b8fa56f 100644
--- a/sysutils/hal/Makefile
+++ b/sysutils/hal/Makefile
@@ -8,7 +8,7 @@
PORTNAME= hal
DISTVERSION= 0.5.11
-PORTREVISION= 21
+PORTREVISION= 22
CATEGORIES= sysutils
MASTER_SITES= http://hal.freedesktop.org/releases/
diff --git a/sysutils/hal/files/pkg-deinstall.in b/sysutils/hal/files/pkg-deinstall.in
index 96f8e9f91977..4650d60fe08b 100644
--- a/sysutils/hal/files/pkg-deinstall.in
+++ b/sysutils/hal/files/pkg-deinstall.in
@@ -2,6 +2,11 @@
[ "$2" != DEINSTALL ] && exit 0
+USER=haldaemon
+
+%%LOCALBASE%%/bin/polkit-auth --user ${USER} --revoke \
+ org.freedesktop.policykit.read
+
for pair in %%RC_FILES%%; do
file=`echo $pair | cut -f 1 -d :`
destdir=`echo $pair | cut -f 2 -d :`
diff --git a/sysutils/hal/files/pkg-install.in b/sysutils/hal/files/pkg-install.in
index 0935c06e157a..59505fc30505 100644
--- a/sysutils/hal/files/pkg-install.in
+++ b/sysutils/hal/files/pkg-install.in
@@ -35,6 +35,8 @@ POST-INSTALL)
/usr/bin/install -d -o ${USER} -g ${GROUP} /var/run/hald
/usr/bin/install -d -o ${USER} -g ${GROUP} /var/cache/hald
/usr/bin/install -d -o ${USER} -g ${GROUP} /var/lib/hal
+ %%LOCALBASE%%/bin/polkit-auth --user ${USER} --grant \
+ org.freedesktop.policykit.read
for pair in %%RC_FILES%%; do
file=`echo $pair | cut -f 1 -d :`