aboutsummaryrefslogtreecommitdiff
path: root/sysutils/hal
diff options
context:
space:
mode:
authorJoe Marcus Clarke <marcus@FreeBSD.org>2012-01-02 19:01:19 +0000
committerJoe Marcus Clarke <marcus@FreeBSD.org>2012-01-02 19:01:19 +0000
commitf19562d64c5b3caecefe1556e06e7a6e3c3090c9 (patch)
treeebae405c1eaed823d7297beca3d0997560f3f545 /sysutils/hal
parentde5b8d2ed29d12a2b4751ac040a2496396c8eaf0 (diff)
downloadports-f19562d64c5b3caecefe1556e06e7a6e3c3090c9.tar.gz
ports-f19562d64c5b3caecefe1556e06e7a6e3c3090c9.zip
Correctly populate usb_device.device_revision_bcd.
PR: 163726 Submitted by: Stephen Hurd <shurd@sasktel.net> Reviewed by: hps
Notes
Notes: svn path=/head/; revision=288431
Diffstat (limited to 'sysutils/hal')
-rw-r--r--sysutils/hal/Makefile2
-rw-r--r--sysutils/hal/files/patch-hald_freebsd_probe-usb2-device.c13
2 files changed, 12 insertions, 3 deletions
diff --git a/sysutils/hal/Makefile b/sysutils/hal/Makefile
index 1ebf885644c4..346b795a62dc 100644
--- a/sysutils/hal/Makefile
+++ b/sysutils/hal/Makefile
@@ -8,7 +8,7 @@
PORTNAME= hal
DISTVERSION= 0.5.14
-PORTREVISION= 17
+PORTREVISION= 18
CATEGORIES= sysutils
MASTER_SITES= http://hal.freedesktop.org/releases/
diff --git a/sysutils/hal/files/patch-hald_freebsd_probe-usb2-device.c b/sysutils/hal/files/patch-hald_freebsd_probe-usb2-device.c
index 35a8690095d8..41ed8936a07e 100644
--- a/sysutils/hal/files/patch-hald_freebsd_probe-usb2-device.c
+++ b/sysutils/hal/files/patch-hald_freebsd_probe-usb2-device.c
@@ -1,5 +1,5 @@
---- hald/freebsd/probing/probe-usb2-device.c.orig 2011-06-30 13:46:55.000000000 +0200
-+++ hald/freebsd/probing/probe-usb2-device.c 2011-06-30 13:49:19.000000000 +0200
+--- hald/freebsd/probing/probe-usb2-device.c.orig 2009-08-24 05:42:29.000000000 -0700
++++ hald/freebsd/probing/probe-usb2-device.c 2011-12-30 17:20:52.000000000 -0800
@@ -148,15 +148,16 @@
bcdspeed = 0x01200;
break;
@@ -30,3 +30,12 @@
case UD_USB_3_0:
version = 3.0;
break;
+@@ -184,7 +188,7 @@
+ libhal_device_set_property_int(hfp_ctx, hfp_udi,
+ "usb_device.vendor_id", di.udi_vendorNo, &hfp_error);
+ libhal_device_set_property_int(hfp_ctx, hfp_udi,
+- "usb_device.device_revision_bcd", ddesc->bcdUSB, &hfp_error);
++ "usb_device.device_revision_bcd", ddesc->bcdDevice, &hfp_error);
+ libhal_device_set_property_string(hfp_ctx, hfp_udi,
+ "usb_device.serial", di.udi_serial, &hfp_error);
+ libhal_device_set_property_string(hfp_ctx, hfp_udi, \ No newline at end of file