aboutsummaryrefslogtreecommitdiff
path: root/sysutils/jvmtop
diff options
context:
space:
mode:
authorJason Helfman <jgh@FreeBSD.org>2016-01-23 21:25:57 +0000
committerJason Helfman <jgh@FreeBSD.org>2016-01-23 21:25:57 +0000
commit972b23b4b010b34c52eca2db628e61880d618acc (patch)
tree28607a54ed6f0d4a755a790c5e88fd6e1673956b /sysutils/jvmtop
parentc590f0bad986c1ea6ac196f20c88448e75de1a6e (diff)
downloadports-972b23b4b010b34c52eca2db628e61880d618acc.tar.gz
ports-972b23b4b010b34c52eca2db628e61880d618acc.zip
- update port to build via source
- moved to github - bump portrevision (license)
Notes
Notes: svn path=/head/; revision=407059
Diffstat (limited to 'sysutils/jvmtop')
-rw-r--r--sysutils/jvmtop/Makefile12
-rw-r--r--sysutils/jvmtop/distinfo4
-rw-r--r--sysutils/jvmtop/pkg-descr2
3 files changed, 11 insertions, 7 deletions
diff --git a/sysutils/jvmtop/Makefile b/sysutils/jvmtop/Makefile
index 4500568c3676..141b1e127a3f 100644
--- a/sysutils/jvmtop/Makefile
+++ b/sysutils/jvmtop/Makefile
@@ -3,26 +3,30 @@
PORTNAME= jvmtop
PORTVERSION= 0.8.0
+PORTREVISION= 1
CATEGORIES= sysutils java
-MASTER_SITES= GOOGLE_CODE
MAINTAINER= jgh@FreeBSD.org
COMMENT= Lightweight console application to monitor running jvms
-LICENSE= GPLv3
+LICENSE= GPLv2
USE_JAVA= yes
JAVA_VERSION= 1.6+
+USE_ANT= yes
PLIST_FILES= %%JAVAJARDIR%%/${PORTNAME}.jar \
bin/${PORTNAME}
SUB_LIST= JAVA_HOME=${JAVA_HOME}
SUB_FILES= ${PORTNAME}.sh
-NO_BUILD= yes
+
+GH_ACCOUNT= patric-r
+GH_TAG= 3d6978c
+USE_GITHUB= YES
do-install:
@${MKDIR} ${STAGEDIR}${JAVAJARDIR}
- ${INSTALL_DATA} ${WRKDIR}/${PORTNAME}.jar ${STAGEDIR}${JAVAJARDIR}
+ ${INSTALL_DATA} ${WRKSRC}/dist/${PORTNAME}.jar ${STAGEDIR}${JAVAJARDIR}
${INSTALL_SCRIPT} ${WRKDIR}/${PORTNAME}.sh ${STAGEDIR}${PREFIX}/bin/${PORTNAME}
.include <bsd.port.mk>
diff --git a/sysutils/jvmtop/distinfo b/sysutils/jvmtop/distinfo
index f6da2b7631a8..00a5a4f182da 100644
--- a/sysutils/jvmtop/distinfo
+++ b/sysutils/jvmtop/distinfo
@@ -1,2 +1,2 @@
-SHA256 (jvmtop-0.8.0.tar.gz) = f9de8159240b400a51b196520b4c4f0ddbcaa8e587fab1f0a59be8a00dc128c4
-SIZE (jvmtop-0.8.0.tar.gz) = 93680
+SHA256 (patric-r-jvmtop-0.8.0_GH0.tar.gz) = 4a11f3ffaa91c40cc8147adc5c7a78b488969a7671943418e16789df418ea0d7
+SIZE (patric-r-jvmtop-0.8.0_GH0.tar.gz) = 98878
diff --git a/sysutils/jvmtop/pkg-descr b/sysutils/jvmtop/pkg-descr
index a80c64ab3e71..2c82bc4e569e 100644
--- a/sysutils/jvmtop/pkg-descr
+++ b/sysutils/jvmtop/pkg-descr
@@ -6,4 +6,4 @@ It's tested with different releases of Oracle JDK, IBM JDK and OpenJDK on
FreeBSD, Linux, Solaris and Windows hosts. Jvmtop requires a JDK - a JRE
will not suffice.
-WWW: http://code.google.com/p/jvmtop/
+WWW: https://github.com/patric-r/jvmtop