aboutsummaryrefslogtreecommitdiff
path: root/sysutils/lavaps
diff options
context:
space:
mode:
authorStanislav Sedov <stas@FreeBSD.org>2006-11-24 22:13:33 +0000
committerStanislav Sedov <stas@FreeBSD.org>2006-11-24 22:13:33 +0000
commit32f9be060cb462dd2e47814fcb2d7edbfcbd1b21 (patch)
tree5879f1be5919d71a05c501cc3fc0183fba54f066 /sysutils/lavaps
parent411a036b94ac4af20b11850e2f3ebb54ffe978ad (diff)
downloadports-32f9be060cb462dd2e47814fcb2d7edbfcbd1b21.tar.gz
ports-32f9be060cb462dd2e47814fcb2d7edbfcbd1b21.zip
- Allow to select frontend type via options
- Respect X11BASE Reported by: kris
Notes
Notes: svn path=/head/; revision=177986
Diffstat (limited to 'sysutils/lavaps')
-rw-r--r--sysutils/lavaps/Makefile19
1 files changed, 12 insertions, 7 deletions
diff --git a/sysutils/lavaps/Makefile b/sysutils/lavaps/Makefile
index f6d474105e21..60f3f167d0d3 100644
--- a/sysutils/lavaps/Makefile
+++ b/sysutils/lavaps/Makefile
@@ -11,27 +11,32 @@ PORTREVISION= 1
CATEGORIES= sysutils
MASTER_SITES= http://www.isi.edu/~johnh/SOFTWARE/LAVAPS/
-MAINTAINER= ssedov@mbsd.msk.ru
+MAINTAINER= stas@FreeBSD.org
COMMENT= A lava lamp of currently running processes
-WANT_GNOME= yes
+GNU_CONFIGURE= yes
USE_GNOME= gnometarget
+CONFIGURE_ENV= CFLAGS="${CFLAGS}" CPPFLAGS="${CPPFLAGS}" LDFLAGS="${LDFLAGS}"
+CONFIGURE_ARGS= -x-includes="${X11BASE}/include" -x-libraries="${X11BASE}/lib"
USE_PERL5_BUILD= yes
-GNU_CONFIGURE= yes
-CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS}" LDFLAGS="${LDFLAGS}"
MAN1= lavaps.1
TCL_VER?= 8.4
-CPPFLAGS= -I${LOCALBASE}/include/tcl${TCL_VER} \
+CPPFLAGS+= -I${LOCALBASE}/include/tcl${TCL_VER} \
-I${LOCALBASE}/include/tk${TCL_VER} \
-I${LOCALBASE}/include
-LDFLAGS= -L${LOCALBASE}/lib
+CFLAGS+= -I${LOCALBASE}/include/tcl${TCL_VER} \
+ -I${LOCALBASE}/include/tk${TCL_VER} \
+ -I${LOCALBASE}/include
+LDFLAGS+= -L${LOCALBASE}/lib
+
+OPTIONS= GTK "Build with GTK frontend instead of the default TK" off
.include <bsd.port.pre.mk>
-.if ${HAVE_GNOME:Mgtk20}!=""
+.if defined(WITH_GTK)
PKGNAMESUFFIX= -gtk2
USE_GNOME+= gtk20
USE_GETTEXT= yes