aboutsummaryrefslogtreecommitdiff
path: root/sysutils/less
diff options
context:
space:
mode:
authorEdwin Groothuis <edwin@FreeBSD.org>2003-04-04 12:40:04 +0000
committerEdwin Groothuis <edwin@FreeBSD.org>2003-04-04 12:40:04 +0000
commit3819707a203d69f19631895651495e37245002de (patch)
treec1917ed66777493de44ff63be77ae751a450b5ff /sysutils/less
parent2d3446586aa86a1ff98b009d6a2cd724757bdbb6 (diff)
downloadports-3819707a203d69f19631895651495e37245002de.tar.gz
ports-3819707a203d69f19631895651495e37245002de.zip
[maintainer-update] ports/misc/less 374 -> 378
revive the port - it improperly suffered repo-death - and apply the patch below. PR: ports/47577 Submitted by: Jason Harris <jharris@widomaker.com>
Notes
Notes: svn path=/head/; revision=78174
Diffstat (limited to 'sysutils/less')
-rw-r--r--sysutils/less/Makefile30
-rw-r--r--sysutils/less/distinfo1
-rw-r--r--sysutils/less/files/patch-aa11
-rw-r--r--sysutils/less/files/patch-ab41
-rw-r--r--sysutils/less/pkg-descr4
-rw-r--r--sysutils/less/pkg-plist3
6 files changed, 90 insertions, 0 deletions
diff --git a/sysutils/less/Makefile b/sysutils/less/Makefile
new file mode 100644
index 000000000000..a1f69af43d73
--- /dev/null
+++ b/sysutils/less/Makefile
@@ -0,0 +1,30 @@
+# New ports collection makefile for: less
+# Date created: 8 Nov 1994
+# Whom: ache
+#
+# $FreeBSD$
+#
+
+PORTNAME= less
+PORTVERSION= 378
+CATEGORIES= misc
+MASTER_SITES= http://www.greenwoodsoftware.com/%SUBDIR%/ \
+ ${MASTER_SITE_GNU}
+MASTER_SITE_SUBDIR= less
+
+MAINTAINER= jharris@widomaker.com
+COMMENT= A better pager utility
+
+.include <bsd.port.pre.mk>
+
+GNU_CONFIGURE= yes
+MAN1= less.1 lesskey.1
+
+.if defined(COLOUR_LESS) || defined(COLOR_LESS)
+MAKE_ENV= CPPFLAGS="-DCOLOUR_LESS"
+
+pre-fetch:
+ @${ECHO_MSG} "Making a colour version of less."
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/sysutils/less/distinfo b/sysutils/less/distinfo
new file mode 100644
index 000000000000..6c4783574873
--- /dev/null
+++ b/sysutils/less/distinfo
@@ -0,0 +1 @@
+MD5 (less-378.tar.gz) = db73e39a2d1a68eafa949f80be5a28c8
diff --git a/sysutils/less/files/patch-aa b/sysutils/less/files/patch-aa
new file mode 100644
index 000000000000..092ecbe95fb9
--- /dev/null
+++ b/sysutils/less/files/patch-aa
@@ -0,0 +1,11 @@
+--- Makefile.in.orig Fri Apr 9 20:02:59 1999
++++ Makefile.in Thu Apr 15 23:09:36 1999
+@@ -15,7 +15,7 @@
+ LDFLAGS = @LDFLAGS@
+ O=o
+
+-LIBS = @LIBS@
++LIBS = -ltermcap
+
+ prefix = @prefix@
+ exec_prefix = @exec_prefix@
diff --git a/sysutils/less/files/patch-ab b/sysutils/less/files/patch-ab
new file mode 100644
index 000000000000..fb9dcb946beb
--- /dev/null
+++ b/sysutils/less/files/patch-ab
@@ -0,0 +1,41 @@
+--- charset.c.orig Thu Mar 23 05:36:33 2000
++++ charset.c Mon Jun 19 22:33:43 2000
+@@ -267,6 +267,10 @@
+ control_char(c)
+ int c;
+ {
++#ifdef COLOR_LESS
++ if (c == ESC)
++ return 0;
++#endif
+ c &= 0377;
+ return (chardef[c] & IS_CONTROL_CHAR);
+ }
+@@ -281,6 +285,20 @@
+ {
+ static char buf[8];
+
++#ifdef COLOR_LESS
++ if(c == ESC)
++ sprintf(buf, "%c", ESC);
++ else
++ {
++ c &= 0377;
++ if (!control_char(c))
++ sprintf(buf, "%c", c);
++ else if (!control_char(c ^ 0100))
++ sprintf(buf, "^%c", c ^ 0100);
++ else
++ sprintf(buf, binfmt, c);
++ }
++#else
+ c &= 0377;
+ if (!control_char(c))
+ sprintf(buf, "%c", c);
+@@ -290,5 +308,6 @@
+ sprintf(buf, "^%c", c ^ 0100);
+ else
+ sprintf(buf, binfmt, c);
++#endif
+ return (buf);
+ }
diff --git a/sysutils/less/pkg-descr b/sysutils/less/pkg-descr
new file mode 100644
index 000000000000..bfa94d911c7e
--- /dev/null
+++ b/sysutils/less/pkg-descr
@@ -0,0 +1,4 @@
+This is the distribution of "less", a paginator similar to "more" or "pg",
+but much more powerful.
+
+WWW: http://www.greenwoodsoftware.com/less/
diff --git a/sysutils/less/pkg-plist b/sysutils/less/pkg-plist
new file mode 100644
index 000000000000..f85e8a92e7ff
--- /dev/null
+++ b/sysutils/less/pkg-plist
@@ -0,0 +1,3 @@
+bin/less
+bin/lesskey
+bin/lessecho