aboutsummaryrefslogtreecommitdiff
path: root/sysutils/lire
diff options
context:
space:
mode:
authorKevin Lo <kevlo@FreeBSD.org>2002-08-21 02:38:33 +0000
committerKevin Lo <kevlo@FreeBSD.org>2002-08-21 02:38:33 +0000
commitc90a3e8c50abc807857e27dbef0920b6fff91be5 (patch)
tree5bffd9a61200caf609ba3caba8ebed0f977a1a00 /sysutils/lire
parent6aa02c012e83cd990d788a65da28a622a222ec8d (diff)
downloadports-c90a3e8c50abc807857e27dbef0920b6fff91be5.tar.gz
ports-c90a3e8c50abc807857e27dbef0920b6fff91be5.zip
Initial import of lire 1.1.
Lire is a logfile analyse toolkit for multiple applications. PR: 41813 Submitted by: Edwin Groothuis <edwin@mavetju.org>
Notes
Notes: svn path=/head/; revision=64729
Diffstat (limited to 'sysutils/lire')
-rw-r--r--sysutils/lire/Makefile106
-rw-r--r--sysutils/lire/distinfo1
-rw-r--r--sysutils/lire/pkg-comment1
-rw-r--r--sysutils/lire/pkg-descr22
-rw-r--r--sysutils/lire/pkg-message1
-rw-r--r--sysutils/lire/pkg-plist661
6 files changed, 792 insertions, 0 deletions
diff --git a/sysutils/lire/Makefile b/sysutils/lire/Makefile
new file mode 100644
index 000000000000..27ed9c862031
--- /dev/null
+++ b/sysutils/lire/Makefile
@@ -0,0 +1,106 @@
+# New ports collection makefile for: lire
+# Date Created: 26 june 2002
+# Whom: Edwin Groothuis <edwin@mavetju.org>
+#
+# $FreeBSD$
+#
+
+#
+# Remark regarding the errors during pkg_delete: These directories not
+# there if you install from the package. They are generated when
+# you install lire from the ports-collection.
+#
+
+PORTNAME= lire
+PORTVERSION= 1.1
+CATEGORIES= sysutils
+MASTER_SITES= http://logreport.org/pub/
+
+MAINTAINER= edwin@mavetju.org
+
+LIB_DEPENDS= \
+ expat.3:${PORTSDIR}/textproc/expat2 \
+ xml2.5:${PORTSDIR}/textproc/libxml2 \
+ xslt.1:${PORTSDIR}/textproc/libxslt
+BUILD_DEPENDS= \
+ ${LOCALBASE}/share/sgml/docbook/4.1/docbook.dtd:${PORTSDIR}/textproc/docbook-410 \
+ ${LOCALBASE}/share/sgml/docbook/dsssl/modular/catalog:${PORTSDIR}/textproc/dsssl-docbook-modular \
+ ${LOCALBASE}/share/xsl/docbook/fo/docbook.xsl:${PORTSDIR}/textproc/docbook-xsl \
+ ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/${PERL_ARCH}/XML/Parser.pm:${PORTSDIR}/textproc/p5-XML-Parser \
+ ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/Spreadsheet/WriteExcel.pm:${PORTSDIR}/textproc/p5-Spreadsheet-WriteExcel \
+ ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/Time/Timezone.pm:${PORTSDIR}/devel/p5-Time \
+ ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/MIME/Entity.pm:${PORTSDIR}/mail/p5-MIME-Tools \
+ ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/GD/Graph.pm:${PORTSDIR}/graphics/p5-GD-Graph
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+USE_PERL5= yes
+USE_GMAKE= yes
+GNU_CONFIGURE= yes
+
+MAN1= \
+ lr_archive_log.1 lr_check_errlines.1 \
+ lr_check_prereq.1 lr_config.1 lr_cron.1 \
+ lr_db_fetch.1 lr_db_purge.1 lr_db_store.1 \
+ lr_desyslog.1 lr_processmail.1 lr_rawmail2mail.1 \
+ lr_run.1 lr_spool.1 lr_tag.1 \
+ lr_xml2html.1 lr_xml2pdf.1 lr_xml2rtf.1 \
+ lr_xml2logml.1 lr_xml2report.1 lr_xml2dbx.1 \
+ lr_xml2xhtml.1 lr_xml2mail.1 lr_xslt.1 \
+ lr_anondump.1 lr_anonymize.1 lr_check_service.1 \
+ lr_check_superservice.1 lr_deanonymize.1 \
+ lr_dlf_analyze.1 lr_dlf2xml.1 lr_dlf2sql.1 \
+ lr_getbody.1 lr_inflate.1 lr_log2mail.1 \
+ lr_log2report.1 lr_log2xml.1 lr_mail.1 \
+ lr_prof_report.1 lr_spoold.1 lr_sql2dlf.1 \
+ lr_sql2report.1 lr_xml2ascii.1 lr_xml_merge.1 \
+ lr_xml2png.1 lr_xml2xls.1 bind8_query2dlf.1 \
+ bind9_query2dlf.1 bind8_named2dlf.1 mysql2dlf.1 \
+ pgsql2dlf.1 isdnlog2dlf.1 postfix2dlf.1 \
+ argomail2dlf.1 exim2dlf.1 nms2dlf.1 \
+ postfix2dlf_main.1 postfix2dlf_pre.1 qmail2dlf.1 \
+ sendmail2dlf.1 cisco_ios2dlf.1 ipfilter2dlf.1 \
+ ipchains2dlf.1 iptables2dlf.1 pix2dlf.1 \
+ watchguard2dlf.1 welf2dlf.1 xferlog2dlf.1 \
+ iis_ftp2dlf.1 nmsmmp2dlf.1 nmsstore2dlf.1 \
+ cups_pagelog2dlf.1 lprng_account2dlf.1 \
+ ms_isa2dlf.1 squid_access2dlf.1 welf_proxy2dlf.1 \
+ syslog2dlf.1 combined2dlf.1 common2dlf.1 \
+ modgzip2dlf.1 referer2dlf.1 w3c_extended2dlf.1
+
+MAN3= \
+ Lire::ReportParser::AsciiWriter.3pm \
+ Lire::ReportParser::ChartWriter.3pm \
+ Lire::ReportParser::DocBookFormatter.3pm \
+ Lire::AsciiDlf::DlfInfo.3pm \
+ Lire::AsciiDlf::Group.3pm Lire::Report::Entry.3pm \
+ Lire::Report::Group.3pm Lire::Report::Image.3pm \
+ Lire::Report::Section.3pm \
+ Lire::Report::Subreport.3pm \
+ Lire::ReportParser::ExcelWriter.3pm \
+ Lire::ReportParser::ReportBuilder.3pm \
+ Lire::Field.3pm Lire::Report.3pm \
+ Lire::W3CExtendedLog.3pm Lire::WELF.3pm \
+ Lire::XMLUtils.3pm Lire::Syslog.3pm \
+ Lire::WWW::URL.3pm Lire::WWW::UserAgent.3pm \
+ Lire::WWW::Domain.3pm Lire::WWW::Filename.3pm \
+ Lire::Time.3pm Lire::Email.3pm \
+ Lire::DlfSchema.3pm Lire::Apache.3pm \
+ Lire::DataTypes.3pm Lire::Program.3pm \
+ Lire::ReportParser.3pm Lire::Firewall.3pm
+
+pre-configure:
+ @${ECHO} "PDF output is not enabled by default."
+ @${ECHO} "Run 'make pdf' to see how to enable it."
+
+pdf:
+ @${ECHO} "If you want to have PDF output, install print/teTeX first."
+ @${ECHO} "Then, symlink ${LOCALBASE}/bin/pdftex to ${LOCALBASE}/bin/pdfjadetex:"
+ @${ECHO} " ln -fs ${LOCALBASE}/bin/pdftex ${LOCALBASE}/bin/pdfjadetex"
+ @${ECHO} "As last, in ${LOCALBASE}/share/texmf/web2c/texmf.cnf,"
+ @${ECHO} "increase the poolsize of pdfjadetex:"
+ @${ECHO} " pool_size.pdfjadetex = 500000"
+
+post-install:
+ @${CAT} pkg-message
+
+.include <bsd.port.mk>
diff --git a/sysutils/lire/distinfo b/sysutils/lire/distinfo
new file mode 100644
index 000000000000..c22e392333cd
--- /dev/null
+++ b/sysutils/lire/distinfo
@@ -0,0 +1 @@
+MD5 (lire-1.1.tar.gz) = cf8366320c161207f613ff2b5b6caf8e
diff --git a/sysutils/lire/pkg-comment b/sysutils/lire/pkg-comment
new file mode 100644
index 000000000000..f9b94cb68166
--- /dev/null
+++ b/sysutils/lire/pkg-comment
@@ -0,0 +1 @@
+Logfile analyse toolkit for multiple applications
diff --git a/sysutils/lire/pkg-descr b/sysutils/lire/pkg-descr
new file mode 100644
index 000000000000..b073bddd0860
--- /dev/null
+++ b/sysutils/lire/pkg-descr
@@ -0,0 +1,22 @@
+Lire, the french word for `to read', is a toolset of logfile analysers.
+
+The Lire package is targeted at automatically generating useful
+reports from raw log files from various services. Currently, Lire
+can generate reports for a variety of email, web, dns, ftp, print
+servers and firewalls, and supports multiple output formats.
+
+Lire is built around the concept of a superservice. A superservice
+is a class of applications which share the same reports. Lire
+supports 6 superservices: dns, email, firewall, ftp, print and www.
+This means that log files for all supported email servers (service
+in Lire's parlance) will get similar reports. This is important for
+heterogeneous environments where you could have e.g. Sendmail and
+Postfix mail servers running. You will get similar reports which
+you can compare.
+
+Notes:
+- PDF output can be enabled if you follow the instructions coming
+ with "make pdf"
+- Excel output only works if you have Perl 5.6.1
+
+WWW: www.logreport.org
diff --git a/sysutils/lire/pkg-message b/sysutils/lire/pkg-message
new file mode 100644
index 000000000000..f785291b61c5
--- /dev/null
+++ b/sysutils/lire/pkg-message
@@ -0,0 +1 @@
+After installing Lire, run lr_config to change your system settings.
diff --git a/sysutils/lire/pkg-plist b/sysutils/lire/pkg-plist
new file mode 100644
index 000000000000..951ffd46f16e
--- /dev/null
+++ b/sysutils/lire/pkg-plist
@@ -0,0 +1,661 @@
+bin/lr_anondump
+bin/lr_anonymize
+bin/lr_check_service
+bin/lr_config
+bin/lr_cron
+bin/lr_deanonymize
+bin/lr_desyslog
+bin/lr_log2mail
+bin/lr_log2report
+bin/lr_rawmail2mail
+bin/lr_run
+bin/lr_spoold
+bin/lr_sql2report
+bin/lr_xml2mail
+bin/lr_xml2report
+etc/lire/address.cf
+etc/lire/database.cfg
+etc/lire/defaults
+etc/lire/dialup.cfg
+etc/lire/disclaimer
+etc/lire/dns.cfg
+etc/lire/dnszone.cfg
+etc/lire/email.cfg
+etc/lire/explanation
+etc/lire/firewall.cfg
+etc/lire/ftp.cfg
+etc/lire/msgstore.cfg
+etc/lire/print.cfg
+etc/lire/profile_lean
+etc/lire/proxy.cfg
+etc/lire/signature
+etc/lire/syslog.cfg
+etc/lire/service_aliases.cf
+etc/lire/www.cfg
+@dirrm etc/lire
+
+libexec/lire/lr_check_superservice
+libexec/lire/lr_dlf2sql
+libexec/lire/lr_sql2dlf
+libexec/lire/convertors/bind8_query2dlf
+libexec/lire/convertors/bind9_query2dlf
+libexec/lire/convertors/bind8_named2dlf
+libexec/lire/convertors/mysql2dlf
+libexec/lire/convertors/pgsql2dlf
+libexec/lire/convertors/isdnlog2dlf
+libexec/lire/convertors/argomail2dlf
+libexec/lire/convertors/exim2dlf
+libexec/lire/convertors/nms2dlf
+libexec/lire/convertors/postfix2dlf
+libexec/lire/convertors/postfix2dlf_main
+libexec/lire/convertors/postfix2dlf_pre
+libexec/lire/convertors/qmail2dlf
+libexec/lire/convertors/sendmail2dlf
+libexec/lire/convertors/cisco_ios2dlf
+libexec/lire/convertors/ipfilter2dlf
+libexec/lire/convertors/ipchains2dlf
+libexec/lire/convertors/iptables2dlf
+libexec/lire/convertors/pix2dlf
+libexec/lire/convertors/watchguard2dlf
+libexec/lire/convertors/welf2dlf
+libexec/lire/convertors/xferlog2dlf
+libexec/lire/convertors/iis_ftp2dlf
+libexec/lire/convertors/nmsmmp2dlf
+libexec/lire/convertors/nmsstore2dlf
+libexec/lire/convertors/cups_pagelog2dlf
+libexec/lire/convertors/lprng_account2dlf
+libexec/lire/convertors/ms_isa2dlf
+libexec/lire/convertors/squid_access2dlf
+libexec/lire/convertors/welf_proxy2dlf
+libexec/lire/convertors/syslog2dlf
+libexec/lire/convertors/combined2dlf
+libexec/lire/convertors/common2dlf
+libexec/lire/convertors/modgzip2dlf
+libexec/lire/convertors/referer2dlf
+libexec/lire/convertors/w3c_extended2dlf
+libexec/lire/lr_archive_log
+libexec/lire/lr_check_errlines
+libexec/lire/lr_check_prereq
+libexec/lire/lr_db_fetch
+libexec/lire/lr_db_purge
+libexec/lire/lr_db_store
+libexec/lire/lr_dlf_analyze
+libexec/lire/lr_dlf2xml
+libexec/lire/lr_getbody
+libexec/lire/lr_inflate
+libexec/lire/lr_log2xml
+libexec/lire/lr_mail
+libexec/lire/lr_processmail
+libexec/lire/lr_prof_report
+libexec/lire/lr_spool
+libexec/lire/lr_tag
+libexec/lire/lr_xml2ascii
+libexec/lire/lr_xml2dbx
+libexec/lire/lr_xml2html
+libexec/lire/lr_xml2logml
+libexec/lire/lr_xml2pdf
+libexec/lire/lr_xml2png
+libexec/lire/lr_xml2rtf
+libexec/lire/lr_xml2xhtml
+libexec/lire/lr_xml2xls
+libexec/lire/lr_xml_merge
+libexec/lire/lr_xslt
+@dirrm libexec/lire/convertors
+@dirrm libexec/lire
+
+share/doc/lire/user-manual.pdf
+share/doc/lire/user-manual.txt
+share/doc/lire/dev-manual.pdf
+share/doc/lire/dev-manual.txt
+share/doc/lire/faq.pdf
+share/doc/lire/faq.txt
+share/doc/lire/roadmap.pdf
+share/doc/lire/roadmap.txt
+share/doc/lire/user-manual/ch01.html
+share/doc/lire/user-manual/pt02.html
+share/doc/lire/user-manual/pt01.html
+share/doc/lire/user-manual/pr01s04.html
+share/doc/lire/user-manual/pr01s03.html
+share/doc/lire/user-manual/pr01s02.html
+share/doc/lire/user-manual/pr01.html
+share/doc/lire/user-manual/index.html
+share/doc/lire/user-manual/ch21.html
+share/doc/lire/user-manual/ch20s02.html
+share/doc/lire/user-manual/ch20.html
+share/doc/lire/user-manual/ch19s04.html
+share/doc/lire/user-manual/ch19s03.html
+share/doc/lire/user-manual/ch19s02.html
+share/doc/lire/user-manual/ch19.html
+share/doc/lire/user-manual/ch18s02.html
+share/doc/lire/user-manual/ch18.html
+share/doc/lire/user-manual/ch17s04.html
+share/doc/lire/user-manual/ch17s03.html
+share/doc/lire/user-manual/ch17s02.html
+share/doc/lire/user-manual/ch17.html
+share/doc/lire/user-manual/ch16s03.html
+share/doc/lire/user-manual/ch16s02.html
+share/doc/lire/user-manual/ch16.html
+share/doc/lire/user-manual/ch15s03.html
+share/doc/lire/user-manual/ch15s02.html
+share/doc/lire/user-manual/ch15.html
+share/doc/lire/user-manual/ch14s03.html
+share/doc/lire/user-manual/ch14s02.html
+share/doc/lire/user-manual/ch14.html
+share/doc/lire/user-manual/ch13s03.html
+share/doc/lire/user-manual/ch13s02.html
+share/doc/lire/user-manual/ch13.html
+share/doc/lire/user-manual/ch12s03.html
+share/doc/lire/user-manual/ch12s02.html
+share/doc/lire/user-manual/ch12.html
+share/doc/lire/user-manual/ch11s03.html
+share/doc/lire/user-manual/ch11s02.html
+share/doc/lire/user-manual/ch11.html
+share/doc/lire/user-manual/ch10s03.html
+share/doc/lire/user-manual/ch10s02.html
+share/doc/lire/user-manual/ch10.html
+share/doc/lire/user-manual/ch09s03.html
+share/doc/lire/user-manual/ch09s02.html
+share/doc/lire/user-manual/ch09.html
+share/doc/lire/user-manual/ch08s03.html
+share/doc/lire/user-manual/ch08s02.html
+share/doc/lire/user-manual/ch08.html
+share/doc/lire/user-manual/ch07.html
+share/doc/lire/user-manual/ch06s03.html
+share/doc/lire/user-manual/ch06s02.html
+share/doc/lire/user-manual/ch06.html
+share/doc/lire/user-manual/ch05s05.html
+share/doc/lire/user-manual/ch05s04.html
+share/doc/lire/user-manual/ch05s03.html
+share/doc/lire/user-manual/ch05s02.html
+share/doc/lire/user-manual/ch05.html
+share/doc/lire/user-manual/ch04s03.html
+share/doc/lire/user-manual/ch04s02.html
+share/doc/lire/user-manual/ch04.html
+share/doc/lire/user-manual/ch03s05.html
+share/doc/lire/user-manual/ch03s04.html
+share/doc/lire/user-manual/ch03s03.html
+share/doc/lire/user-manual/ch03s02.html
+share/doc/lire/user-manual/ch03.html
+share/doc/lire/user-manual/ch02s05.html
+share/doc/lire/user-manual/ch02s04.html
+share/doc/lire/user-manual/ch02s03.html
+share/doc/lire/user-manual/ch02s02.html
+share/doc/lire/user-manual/ch02.html
+share/doc/lire/user-manual/ch01s05.html
+share/doc/lire/user-manual/ch01s04.html
+share/doc/lire/user-manual/ch01s03.html
+share/doc/lire/user-manual/ch01s02.html
+share/doc/lire/user-manual/pt03.html
+share/doc/lire/dev-manual/ch01.html
+share/doc/lire/dev-manual/pt04.html
+share/doc/lire/dev-manual/pt03.html
+share/doc/lire/dev-manual/pt02.html
+share/doc/lire/dev-manual/pt01.html
+share/doc/lire/dev-manual/pr01s04.html
+share/doc/lire/dev-manual/pr01s03.html
+share/doc/lire/dev-manual/pr01s02.html
+share/doc/lire/dev-manual/pr01.html
+share/doc/lire/dev-manual/index.html
+share/doc/lire/dev-manual/go01.html
+share/doc/lire/dev-manual/ch17.html
+share/doc/lire/dev-manual/ch16.html
+share/doc/lire/dev-manual/ch15.html
+share/doc/lire/dev-manual/ch14s04.html
+share/doc/lire/dev-manual/ch14s03.html
+share/doc/lire/dev-manual/ch14s02.html
+share/doc/lire/dev-manual/ch14.html
+share/doc/lire/dev-manual/ch13.html
+share/doc/lire/dev-manual/ch12s08.html
+share/doc/lire/dev-manual/ch12s07.html
+share/doc/lire/dev-manual/ch12s06.html
+share/doc/lire/dev-manual/ch12s05.html
+share/doc/lire/dev-manual/ch12s04.html
+share/doc/lire/dev-manual/ch12s03.html
+share/doc/lire/dev-manual/ch12s02.html
+share/doc/lire/dev-manual/ch12.html
+share/doc/lire/dev-manual/ch11.html
+share/doc/lire/dev-manual/ch10.html
+share/doc/lire/dev-manual/ch09s02.html
+share/doc/lire/dev-manual/ch09.html
+share/doc/lire/dev-manual/ch08s04.html
+share/doc/lire/dev-manual/ch08s03.html
+share/doc/lire/dev-manual/ch08s02.html
+share/doc/lire/dev-manual/ch08.html
+share/doc/lire/dev-manual/ch07.html
+share/doc/lire/dev-manual/ch06s12.html
+share/doc/lire/dev-manual/ch06s11.html
+share/doc/lire/dev-manual/ch06s10.html
+share/doc/lire/dev-manual/ch06s09.html
+share/doc/lire/dev-manual/ch06s08.html
+share/doc/lire/dev-manual/ch06s07.html
+share/doc/lire/dev-manual/ch06s06.html
+share/doc/lire/dev-manual/ch06s05.html
+share/doc/lire/dev-manual/ch06s04.html
+share/doc/lire/dev-manual/ch06s03.html
+share/doc/lire/dev-manual/ch06s02.html
+share/doc/lire/dev-manual/ch06.html
+share/doc/lire/dev-manual/ch05s02.html
+share/doc/lire/dev-manual/ch05.html
+share/doc/lire/dev-manual/ch04s04.html
+share/doc/lire/dev-manual/ch04s03.html
+share/doc/lire/dev-manual/ch04s02.html
+share/doc/lire/dev-manual/ch04.html
+share/doc/lire/dev-manual/ch03s02.html
+share/doc/lire/dev-manual/ch03.html
+share/doc/lire/dev-manual/ch02s02.html
+share/doc/lire/dev-manual/ch02.html
+share/doc/lire/dev-manual/ch01s06.html
+share/doc/lire/dev-manual/ch01s05.html
+share/doc/lire/dev-manual/ch01s04.html
+share/doc/lire/dev-manual/ch01s03.html
+share/doc/lire/dev-manual/ch01s02.html
+share/doc/lire/dev-manual/pt05.html
+share/doc/lire/faq/index.html
+share/doc/lire/roadmap/index.html
+share/doc/lire/roadmap/ar01s04.html
+share/doc/lire/roadmap/ar01s03.html
+share/doc/lire/roadmap/ar01s02.html
+@dirrm share/doc/lire/dev-manual
+@dirrm share/doc/lire/faq
+@dirrm share/doc/lire/roadmap
+@dirrm share/doc/lire/user-manual
+@dirrm share/doc/lire
+
+share/lire/filters/dns/select-resolver.xml
+share/lire/filters/dnszone/axfr-approved-only.xml
+share/lire/filters/dnszone/axfr-axfr-only.xml
+share/lire/filters/dnszone/axfr-denied-only.xml
+share/lire/filters/dnszone/dyndns-only.xml
+share/lire/filters/dnszone/loaded-only.xml
+share/lire/filters/email/select-client-ip.xml
+share/lire/filters/firewall/select-action.xml
+share/lire/filters/msgstore/select-client-host.xml
+share/lire/filters/proxy/select-cache_result.xml
+share/lire/filters/syslog/exclude-message.xml
+share/lire/filters/syslog/exclude-priority.xml
+share/lire/filters/syslog/exclude-process.xml
+share/lire/filters/syslog/select-host.xml
+share/lire/filters/syslog/select-message.xml
+share/lire/filters/syslog/select-priority.xml
+share/lire/filters/syslog/select-process.xml
+share/lire/filters/www/exclude-client_host.xml
+share/lire/filters/www/exclude-referer.xml
+share/lire/filters/www/exclude-sessions-by-page.xml
+share/lire/filters/www/exclude-url.xml
+share/lire/filters/www/select-client_host.xml
+share/lire/filters/www/select-sessions-by-page.xml
+share/lire/filters/www/select-url.xml
+@dirrm share/lire/filters/www
+@dirrm share/lire/filters/syslog
+@dirrm share/lire/filters/proxy
+@dirrm share/lire/filters/print
+@dirrm share/lire/filters/msgstore
+@dirrm share/lire/filters/ftp
+@dirrm share/lire/filters/firewall
+@dirrm share/lire/filters/email
+@dirrm share/lire/filters/dnszone
+@dirrm share/lire/filters/dns
+@dirrm share/lire/filters/database
+@dirrm share/lire/filters
+
+share/lire/reports/database/actions-by-period.xml
+share/lire/reports/database/top-databases.xml
+share/lire/reports/database/top-querytypes.xml
+share/lire/reports/database/top-users.xml
+share/lire/reports/dialup/connection-time-by-period.xml
+share/lire/reports/dialup/connections-by-connect-status.xml
+share/lire/reports/dialup/connections-by-connection-time.xml
+share/lire/reports/dialup/connections-by-hangup-status.xml
+share/lire/reports/dialup/connections-by-period.xml
+share/lire/reports/dialup/connections-by-type.xml
+share/lire/reports/dialup/cost-by-period.xml
+share/lire/reports/dialup/cost-by-telephone-number.xml
+share/lire/reports/dialup/top-telephone-number-from.xml
+share/lire/reports/dialup/top-telephone-number.xml
+share/lire/reports/dns/req-by-period-by-method.xml
+share/lire/reports/dns/req-by-timeslot-by-method.xml
+share/lire/reports/dns/requests-by-period-by-method.xml
+share/lire/reports/dns/requests-by-period.xml
+share/lire/reports/dns/requests-by-timeslot.xml
+share/lire/reports/dns/requests-summary-by-method.xml
+share/lire/reports/dns/requests-summary.xml
+share/lire/reports/dns/requesttype-by-method.xml
+share/lire/reports/dns/requesttype-distribution-by-method.xml
+share/lire/reports/dns/requesttype-distribution.xml
+share/lire/reports/dns/top-requested-names-by-method.xml
+share/lire/reports/dns/top-requested-names.xml
+share/lire/reports/dns/top-requesting-hosts-by-method.xml
+share/lire/reports/dns/top-requesting-hosts.xml
+share/lire/reports/dnszone/server-summary.xml
+share/lire/reports/dnszone/top-axfr-host.xml
+share/lire/reports/dnszone/top-axfr-zone.xml
+share/lire/reports/dnszone/top-axfr.xml
+share/lire/reports/dnszone/top-denied-axfr.xml
+share/lire/reports/dnszone/top-dynamicdenied.xml
+share/lire/reports/dnszone/top-loadedzone.xml
+share/lire/reports/email/deliveries-by-delay.xml
+share/lire/reports/email/deliveries-by-period-by-status.xml
+share/lire/reports/email/deliveries-by-period.xml
+share/lire/reports/email/deliveries-by-size.xml
+share/lire/reports/email/errors-by-to-relay.xml
+share/lire/reports/email/from_domain-by-period.xml
+share/lire/reports/email/from_user-from-domain-by-period.xml
+share/lire/reports/email/summary.xml
+share/lire/reports/email/to_domain-by-period.xml
+share/lire/reports/email/to_user-from-domain-by-period.xml
+share/lire/reports/email/top-avg-delay-by-to-relay-and-to-domain.xml
+share/lire/reports/email/top-deliveries-btw-relays.xml
+share/lire/reports/email/top-from-domain.xml
+share/lire/reports/email/top-from-email-by-domain.xml
+share/lire/reports/email/top-from-relay.xml
+share/lire/reports/email/top-largest-email-exchange-per-relay.xml
+share/lire/reports/email/top-largest-email-exchange.xml
+share/lire/reports/email/top-status-by-domain.xml
+share/lire/reports/email/top-to-domain.xml
+share/lire/reports/email/top-to-email-by-domain.xml
+share/lire/reports/email/top-to-relay.xml
+share/lire/reports/email/top-volume-from-domain.xml
+share/lire/reports/email/top-volume-to-domain.xml
+share/lire/reports/email/tracked-recipients.xml
+share/lire/reports/email/tracked-senders.xml
+share/lire/reports/email/volume-by-period.xml
+share/lire/reports/firewall/bytes-by-period.xml
+share/lire/reports/firewall/bytes-by-rule.xml
+share/lire/reports/firewall/bytes-by-timeslot.xml
+share/lire/reports/firewall/bytesperfrom.xml
+share/lire/reports/firewall/bytesperfromperport.xml
+share/lire/reports/firewall/bytesperto.xml
+share/lire/reports/firewall/bytespertoperport.xml
+share/lire/reports/firewall/deniedtcpperport.xml
+share/lire/reports/firewall/pkt-by-period.xml
+share/lire/reports/firewall/pkt-by-rule.xml
+share/lire/reports/firewall/pkt-by-timeslot.xml
+share/lire/reports/firewall/pkt-summary.xml
+share/lire/reports/firewall/top-bytes-dst-by-src.xml
+share/lire/reports/firewall/top-bytes-src-by-dst.xml
+share/lire/reports/firewall/top-dst-by-msg.xml
+share/lire/reports/firewall/top-msg.xml
+share/lire/reports/firewall/top-pkt-by-dst.xml
+share/lire/reports/firewall/top-pkt-by-src.xml
+share/lire/reports/firewall/top-pkt-dst-by-src.xml
+share/lire/reports/firewall/top-pkt-src-by-dst.xml
+share/lire/reports/firewall/top-src-by-msg.xml
+share/lire/reports/firewall/vol-summary.xml
+share/lire/reports/ftp/bytes-by-dir-by-user-by-period.xml
+share/lire/reports/ftp/bytes-by-period-by-user.xml
+share/lire/reports/ftp/bytes-by-period.xml
+share/lire/reports/ftp/bytes-by-user-by-period.xml
+share/lire/reports/ftp/top-files-in.xml
+share/lire/reports/ftp/top-files-out.xml
+share/lire/reports/ftp/top-files.xml
+share/lire/reports/ftp/top-remote-host.xml
+share/lire/reports/ftp/top-users-bytes.xml
+share/lire/reports/ftp/top-users.xml
+share/lire/reports/ftp/tracked-files.xml
+share/lire/reports/ftp/tracked-users.xml
+share/lire/reports/ftp/transfers-by-direction.xml
+share/lire/reports/ftp/transfers-by-type.xml
+share/lire/reports/msgstore/badlogin-by-period.xml
+share/lire/reports/msgstore/close-by-period.xml
+share/lire/reports/msgstore/events-by-protocol.xml
+share/lire/reports/msgstore/login-by-period.xml
+share/lire/reports/msgstore/top-user-login.xml
+share/lire/reports/msgstore/top-user-select.xml
+share/lire/reports/msgstore/unique-user.xml
+share/lire/reports/print/billing-per-printer.xml
+share/lire/reports/print/billing.xml
+share/lire/reports/print/jobs-per-period.xml
+share/lire/reports/print/jobs-per-printer-per-period.xml
+share/lire/reports/print/jobs-per-printer.xml
+share/lire/reports/print/jobs-per-sheets.xml
+share/lire/reports/print/jobs-per-user-per-period.xml
+share/lire/reports/print/sheets-per-period.xml
+share/lire/reports/print/sheets-per-user-per-period.xml
+share/lire/reports/print/sheets-per-user.xml
+share/lire/reports/print/top-users.xml
+share/lire/reports/proxy/bytes-by-cache_result.xml
+share/lire/reports/proxy/bytes-by-period.xml
+share/lire/reports/proxy/bytes-by-result_src_code.xml
+share/lire/reports/proxy/bytes-by-timeslot.xml
+share/lire/reports/proxy/client_hosts-summary.xml
+share/lire/reports/proxy/requests-by-cache_result.xml
+share/lire/reports/proxy/requests-by-period.xml
+share/lire/reports/proxy/requests-by-size.xml
+share/lire/reports/proxy/requests-by-time.xml
+share/lire/reports/proxy/requests-by-timeslot.xml
+share/lire/reports/proxy/requests-summary.xml
+share/lire/reports/proxy/top-clients-by-destinations.xml
+share/lire/reports/proxy/top-destinations-by-bytes.xml
+share/lire/reports/proxy/top-destinations-by-clients.xml
+share/lire/reports/proxy/top-destinations-by-users.xml
+share/lire/reports/proxy/top-destinations.xml
+share/lire/reports/proxy/top-types-by-bytes.xml
+share/lire/reports/proxy/top-urls-by-users.xml
+share/lire/reports/proxy/top-users-by-bytes.xml
+share/lire/reports/proxy/top-users-by-destinations.xml
+share/lire/reports/proxy/users-summary.xml
+share/lire/reports/syslog/messages-by-facility.xml
+share/lire/reports/syslog/messages-by-level.xml
+share/lire/reports/syslog/messages-by-period.xml
+share/lire/reports/syslog/syslog-summary.xml
+share/lire/reports/syslog/top-hosts.xml
+share/lire/reports/syslog/top-messages-by-period.xml
+share/lire/reports/syslog/top-messages-by-process.xml
+share/lire/reports/syslog/top-messages.xml
+share/lire/reports/syslog/top-processes-by-period.xml
+share/lire/reports/syslog/top-processes.xml
+share/lire/reports/www/bytes-by-dir.xml
+share/lire/reports/www/bytes-by-period.xml
+share/lire/reports/www/bytes-by-result-by-period.xml
+share/lire/reports/www/bytes-by-result.xml
+share/lire/reports/www/clienthost-by-period.xml
+share/lire/reports/www/keywords-by-search_engine.xml
+share/lire/reports/www/requests-by-attack.xml
+share/lire/reports/www/requests-by-browser.xml
+share/lire/reports/www/requests-by-country.xml
+share/lire/reports/www/requests-by-gzip_result.xml
+share/lire/reports/www/requests-by-keywords.xml
+share/lire/reports/www/requests-by-lang.xml
+share/lire/reports/www/requests-by-method.xml
+share/lire/reports/www/requests-by-os.xml
+share/lire/reports/www/requests-by-period.xml
+share/lire/reports/www/requests-by-result-by-period.xml
+share/lire/reports/www/requests-by-result.xml
+share/lire/reports/www/requests-by-robot.xml
+share/lire/reports/www/requests-by-search_engine.xml
+share/lire/reports/www/requests-by-size.xml
+share/lire/reports/www/requests-by-timeslot.xml
+share/lire/reports/www/requests-by-useragent.xml
+share/lire/reports/www/requests-by-version.xml
+share/lire/reports/www/requests-summary.xml
+share/lire/reports/www/top-avg-compression-by-file-type.xml
+share/lire/reports/www/top-avg-compression-by-url.xml
+share/lire/reports/www/top-client_host-by-result.xml
+share/lire/reports/www/top-client_host.xml
+share/lire/reports/www/top-first_page.xml
+share/lire/reports/www/top-last_page.xml
+share/lire/reports/www/top-pages-by-client_host.xml
+share/lire/reports/www/top-referer-page-connections.xml
+share/lire/reports/www/top-referers-by-page.xml
+share/lire/reports/www/top-referers.xml
+share/lire/reports/www/top-referring_sites.xml
+share/lire/reports/www/top-requested-page.xml
+share/lire/reports/www/top-tracked_pages-by-client_host.xml
+share/lire/reports/www/top-traversals.xml
+share/lire/reports/www/top-urls-by-client_host.xml
+share/lire/reports/www/top-urls-by-result.xml
+share/lire/reports/www/tracked_pages-by-period.xml
+share/lire/reports/www/user_session-finished.xml
+share/lire/reports/www/user_session-page_counts.xml
+share/lire/reports/www/user_session-summary.xml
+share/lire/reports/www/user_session-visit-times.xml
+share/lire/reports/www/user_session-visit_number.xml
+share/lire/reports/www/user_sessions-by-period.xml
+@dirrm share/lire/reports/www
+@dirrm share/lire/reports/syslog
+@dirrm share/lire/reports/proxy
+@dirrm share/lire/reports/print
+@dirrm share/lire/reports/msgstore
+@dirrm share/lire/reports/ftp
+@dirrm share/lire/reports/firewall
+@dirrm share/lire/reports/email
+@dirrm share/lire/reports/dnszone
+@dirrm share/lire/reports/dns
+@dirrm share/lire/reports/dialup
+@dirrm share/lire/reports/database
+@dirrm share/lire/reports
+
+share/lire/schemas/database-querytype.xml
+share/lire/schemas/database.xml
+share/lire/schemas/dialup.xml
+share/lire/schemas/dns.xml
+share/lire/schemas/dnszone.xml
+share/lire/schemas/email-email.xml
+share/lire/schemas/email.xml
+share/lire/schemas/firewall.xml
+share/lire/schemas/ftp.xml
+share/lire/schemas/msgstore.xml
+share/lire/schemas/print-sheets.xml
+share/lire/schemas/print.xml
+share/lire/schemas/proxy.xml
+share/lire/schemas/syslog.xml
+share/lire/schemas/www-attack.xml
+share/lire/schemas/www-domain.xml
+share/lire/schemas/www-robot.xml
+share/lire/schemas/www-search.xml
+share/lire/schemas/www-url.xml
+share/lire/schemas/www-user_agent.xml
+share/lire/schemas/www-user_session.xml
+share/lire/schemas/www.xml
+@dirrm share/lire/schemas
+
+share/lire/sgml/xml.dcl
+@dirrm share/lire/sgml
+
+share/lire/xml/dtd/catalog
+share/lire/xml/dtd/catalog.xml
+share/lire/xml/dtd/ldsml.dtd
+share/lire/xml/dtd/lire-desc.mod
+share/lire/xml/dtd/lire-types.mod
+share/lire/xml/dtd/lire.dtd
+share/lire/xml/dtd/lrsml.dtd
+share/lire/xml/stylesheet/xsl/config.xsl
+share/lire/xml/stylesheet/xsl/docbook.xsl
+share/lire/xml/stylesheet/xsl/lire-lib.xsl
+share/lire/xml/stylesheet/xsl/logml-email.xsl
+share/lire/xml/stylesheet/xsl/logml-www.xsl
+share/lire/xml/stylesheet/xsl/logml.xsl
+@dirrm share/lire/xml/stylesheet/xsl
+@dirrm share/lire/xml/stylesheet
+@dirrm share/lire/xml/dtd
+@dirrm share/lire/xml
+
+share/perl5/Lire/Aggregator.pm
+share/perl5/Lire/Apache.pm
+share/perl5/Lire/AsciiDlf/Aggregator.pm
+share/perl5/Lire/AsciiDlf/AsciiDlfFactory.pm
+share/perl5/Lire/AsciiDlf/DerivedRecordsCreator.pm
+share/perl5/Lire/AsciiDlf/DlfInfo.pm
+share/perl5/Lire/AsciiDlf/ExtendedFieldsCreator.pm
+share/perl5/Lire/AsciiDlf/FilterExpr.pm
+share/perl5/Lire/AsciiDlf/Group.pm
+share/perl5/Lire/AsciiDlf/GroupOp.pm
+share/perl5/Lire/AsciiDlf/NestableAggregator.pm
+share/perl5/Lire/AsciiDlf/Rangegroup.pm
+share/perl5/Lire/AsciiDlf/Records.pm
+share/perl5/Lire/AsciiDlf/ReportSpec.pm
+share/perl5/Lire/AsciiDlf/Summary.pm
+share/perl5/Lire/AsciiDlf/Timegroup.pm
+share/perl5/Lire/AsciiDlf/Timeslot.pm
+share/perl5/Lire/Config.pm
+share/perl5/Lire/DataTypes.pm
+share/perl5/Lire/DerivedSchema.pm
+share/perl5/Lire/DlfSchema.pm
+share/perl5/Lire/Email.pm
+share/perl5/Lire/ExtendedSchema.pm
+share/perl5/Lire/Extension.pm
+share/perl5/Lire/Extensions/Database/DatabaseSchema.pm
+share/perl5/Lire/Extensions/Email/EmailSchema.pm
+share/perl5/Lire/Extensions/Print/PrintSchema.pm
+share/perl5/Lire/Extensions/WWW/AttackSchema.pm
+share/perl5/Lire/Extensions/WWW/DomainSchema.pm
+share/perl5/Lire/Extensions/WWW/RobotSchema.pm
+share/perl5/Lire/Extensions/WWW/SearchSchema.pm
+share/perl5/Lire/Extensions/WWW/URLSchema.pm
+share/perl5/Lire/Extensions/WWW/UserAgentSchema.pm
+share/perl5/Lire/Extensions/WWW/UserSessionSchema.pm
+share/perl5/Lire/Field.pm
+share/perl5/Lire/FilterExpr.pm
+share/perl5/Lire/FilterSpec.pm
+share/perl5/Lire/Firewall.pm
+share/perl5/Lire/Group.pm
+share/perl5/Lire/GroupField.pm
+share/perl5/Lire/GroupOp.pm
+share/perl5/Lire/Param.pm
+share/perl5/Lire/Program.pm
+share/perl5/Lire/Rangegroup.pm
+share/perl5/Lire/Merge/Aggregator.pm
+share/perl5/Lire/Merge/Group.pm
+share/perl5/Lire/Merge/GroupOp.pm
+share/perl5/Lire/Merge/MergeFactory.pm
+share/perl5/Lire/Merge/NestableAggregator.pm
+share/perl5/Lire/Merge/Rangegroup.pm
+share/perl5/Lire/Merge/Records.pm
+share/perl5/Lire/Merge/ReportSpec.pm
+share/perl5/Lire/Merge/Summary.pm
+share/perl5/Lire/Merge/Timegroup.pm
+share/perl5/Lire/Merge/Timeslot.pm
+share/perl5/Lire/Report/Entry.pm
+share/perl5/Lire/Report/Group.pm
+share/perl5/Lire/Report/Image.pm
+share/perl5/Lire/Report/Section.pm
+share/perl5/Lire/Report/Subreport.pm
+share/perl5/Lire/NestableAggregator.pm
+share/perl5/Lire/Records.pm
+share/perl5/Lire/Report.pm
+share/perl5/Lire/ReportConfig.pm
+share/perl5/Lire/ReportParser.pm
+share/perl5/Lire/ReportParser/AsciiWriter.pm
+share/perl5/Lire/ReportParser/ChartWriter.pm
+share/perl5/Lire/ReportParser/DocBookFormatter.pm
+share/perl5/Lire/ReportParser/ExcelWriter.pm
+share/perl5/Lire/ReportParser/ReportBuilder.pm
+share/perl5/Lire/ReportSection.pm
+share/perl5/Lire/ReportSpec.pm
+share/perl5/Lire/ReportSpecFactory.pm
+share/perl5/Lire/Summary.pm
+share/perl5/Lire/Syslog.pm
+share/perl5/Lire/Time.pm
+share/perl5/Lire/Timegroup.pm
+share/perl5/Lire/Timeslot.pm
+share/perl5/Lire/W3CExtendedLog.pm
+share/perl5/Lire/WELF.pm
+share/perl5/Lire/WWW/Domain.pm
+share/perl5/Lire/WWW/Domain/Country.pm
+share/perl5/Lire/WWW/Domain/Robot.pm
+share/perl5/Lire/WWW/Filename.pm
+share/perl5/Lire/WWW/Filename/Attack.pm
+share/perl5/Lire/WWW/URL.pm
+share/perl5/Lire/WWW/UserAgent.pm
+share/perl5/Lire/WWW/UserAgent/Browser.pm
+share/perl5/Lire/WWW/UserAgent/Language.pm
+share/perl5/Lire/WWW/UserAgent/OS.pm
+share/perl5/Lire/WWW/UserAgent/Robot.pm
+share/perl5/Lire/XMLSpecContainer.pm
+share/perl5/Lire/XMLUtils.pm
+@dirrm share/perl5/Lire/WWW/UserAgent
+@dirrm share/perl5/Lire/WWW/Filename
+@dirrm share/perl5/Lire/WWW/Domain
+@dirrm share/perl5/Lire/WWW
+@dirrm share/perl5/Lire/ReportParser
+@dirrm share/perl5/Lire/Report
+@dirrm share/perl5/Lire/Merge
+@dirrm share/perl5/Lire/Extensions/WWW
+@dirrm share/perl5/Lire/Extensions/Print
+@dirrm share/perl5/Lire/Extensions/Email
+@dirrm share/perl5/Lire/Extensions/Database
+@dirrm share/perl5/Lire/Extensions
+@dirrm share/perl5/Lire/AsciiDlf
+@dirrm share/perl5/Lire
+
+@dirrm share/lire