aboutsummaryrefslogtreecommitdiff
path: root/sysutils/lookupd
diff options
context:
space:
mode:
authorOliver Eikemeier <eik@FreeBSD.org>2004-07-24 17:27:36 +0000
committerOliver Eikemeier <eik@FreeBSD.org>2004-07-24 17:27:36 +0000
commit84e6916181d98568a9ab55f1c1b38682d4528fbe (patch)
treeac8049a0817598f7522ef649e2a20b95d6311e8f /sysutils/lookupd
parent2a466feafc82fb86693d412bdaf8276cb1308a55 (diff)
downloadports-84e6916181d98568a9ab55f1c1b38682d4528fbe.tar.gz
ports-84e6916181d98568a9ab55f1c1b38682d4528fbe.zip
add lookupd, a name service lookup daemon, and lookupd_ldap, an LDAP plugin
PR: 68811, 68810 Submitted by: Michael Bushkov <bushman@rsu.ru>
Notes
Notes: svn path=/head/; revision=114581
Diffstat (limited to 'sysutils/lookupd')
-rw-r--r--sysutils/lookupd/Makefile33
-rw-r--r--sysutils/lookupd/distinfo2
-rw-r--r--sysutils/lookupd/files/lookupd.sh31
-rw-r--r--sysutils/lookupd/pkg-descr16
-rw-r--r--sysutils/lookupd/pkg-message11
-rw-r--r--sysutils/lookupd/pkg-plist14
6 files changed, 107 insertions, 0 deletions
diff --git a/sysutils/lookupd/Makefile b/sysutils/lookupd/Makefile
new file mode 100644
index 000000000000..e56be9bd2e61
--- /dev/null
+++ b/sysutils/lookupd/Makefile
@@ -0,0 +1,33 @@
+# New ports collection makefile for: lookupd
+# Date created: 3 July 2004
+# Whom: Michael Bushkov <bushman@rsu.ru>
+#
+# $FreeBSD$
+
+PORTNAME= lookupd
+PORTVERSION= 0.3.a
+CATEGORIES= sysutils
+MASTER_SITES= http://www.rsu.ru/~bushman/lookupd/downloads/
+
+MAINTAINER= bushman@rsu.ru
+COMMENT= Lookupd daemon - IPC nsswitch implementation with system-wide caching
+
+INSTALLS_SHLIB= yes
+USE_RC_SUBR= yes
+
+PKGMESSAGE= ${WRKDIR}/pkg-message
+STARTUPSCRIPT= ${WRKDIR}/lookupd.sh
+
+post-install:
+ @${SED} -e 's|%%PREFIX%%|${PREFIX}|g' ${FILESDIR}/lookupd.sh > ${STARTUPSCRIPT}
+ ${INSTALL_SCRIPT} ${STARTUPSCRIPT} ${PREFIX}/etc/rc.d/lookupd.sh
+ @${SED} -e "s|%%PREFIX%%|${PREFIX}|g" ${.CURDIR}/pkg-message > ${PKGMESSAGE}
+ @${CAT} ${PKGMESSAGE}
+
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} < 500112
+IGNORE= This version of lookupd is only supported on FreeBSD 5.1 or later
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/sysutils/lookupd/distinfo b/sysutils/lookupd/distinfo
new file mode 100644
index 000000000000..c9e30faaed6e
--- /dev/null
+++ b/sysutils/lookupd/distinfo
@@ -0,0 +1,2 @@
+MD5 (lookupd-0.3.a.tar.gz) = 8e65893bfc21e497fc32cd9a6b35461a
+SIZE (lookupd-0.3.a.tar.gz) = 109810
diff --git a/sysutils/lookupd/files/lookupd.sh b/sysutils/lookupd/files/lookupd.sh
new file mode 100644
index 000000000000..3fcd580aa8e3
--- /dev/null
+++ b/sysutils/lookupd/files/lookupd.sh
@@ -0,0 +1,31 @@
+#!/bin/sh
+#
+# $FreeBSD$
+#
+
+# PROVIDE: lookupd
+# REQUIRE: mountcritlocal
+# BEFORE: LOGIN
+# KEYWORD: FreeBSD
+
+#
+# Add the following lines to /etc/rc.conf to enable lookupd:
+#
+# lookupd_enable="YES"
+#
+# See lookupd(8) for flags
+#
+
+. /etc/rc.subr
+
+name=lookupd
+rcvar=`set_rcvar`
+
+command=%%PREFIX%%/sbin/lookupd
+
+lookupd_enable=${lookupd_enable:-"NO"}
+lookupd_pidfile=${lookupd_pidfile:-"/var/run/lookupd.pid"}
+lookupd_flags=${lookupd_flags:-""}
+
+load_rc_config $name
+run_rc_command "$1"
diff --git a/sysutils/lookupd/pkg-descr b/sysutils/lookupd/pkg-descr
new file mode 100644
index 000000000000..66a369f271e9
--- /dev/null
+++ b/sysutils/lookupd/pkg-descr
@@ -0,0 +1,16 @@
+This is an implementation of lookupd - name service switch daemon.
+It gives an ability to use IPC model for different lookup operations
+(just like nsswitch, but all requests are processed by lookupd daemon),
+which in turn makes system-wide caching possible. Besides, unlike
+the nsswitch lookupd can use persistent connections and different
+other optimizations.
+
+As current nsswitch implementation, lookupd is also based on plugins,
+which are a bit different from standard nss_* plugins such as nss_ldap,
+but they are easy to port. Files and dns plugins are installed by
+default and lookupd_ldap module can be found in ports.
+
+Lookupd should be plugged into the current FreeBSD
+nsswitch implementation using a standard module - nss_lookupd.so.
+
+WWW: http://www.rsu.ru/~bushman/lookupd
diff --git a/sysutils/lookupd/pkg-message b/sysutils/lookupd/pkg-message
new file mode 100644
index 000000000000..f6316a861cb7
--- /dev/null
+++ b/sysutils/lookupd/pkg-message
@@ -0,0 +1,11 @@
+***************************************************
+Configuration file for lookupd should be named lookupd.conf
+and must be placed in %%PREFIX%%/etc.
+To make lookupd working, you should plug it into the nsswitch.
+You must tune %%PREFIX%%/etc/nsswitch.conf, by adding lookupd
+keyword to the appropriate lines.
+
+Startup script lookupd.sh was placed in %%PREFIX%%/etc/rc.d.
+
+Examples of both of these files were installed into the examples folder.
+***************************************************
diff --git a/sysutils/lookupd/pkg-plist b/sysutils/lookupd/pkg-plist
new file mode 100644
index 000000000000..ff9325089b7e
--- /dev/null
+++ b/sysutils/lookupd/pkg-plist
@@ -0,0 +1,14 @@
+sbin/lookupd
+etc/rc.d/lookupd.sh
+lib/lkpd_files.so
+lib/lkpd_files.so.1
+lib/lkpd_dns.so
+lib/lkpd_dns.so.1
+include/lookupd/passwd_defs.h
+include/lookupd/group_defs.h
+include/lookupd/host_defs.h
+include/lookupd/lookupd_defs.h
+@dirrm include/lookupd
+%%EXAMPLESDIR%%/nsswitch.conf.sample
+%%EXAMPLESDIR%%/lookupd.conf.sample
+@dirrm %%EXAMPLESDIR%%