aboutsummaryrefslogtreecommitdiff
path: root/sysutils/lsof
diff options
context:
space:
mode:
authorWesley Shields <wxs@FreeBSD.org>2008-11-02 20:06:43 +0000
committerWesley Shields <wxs@FreeBSD.org>2008-11-02 20:06:43 +0000
commit23131ae2f65b903d194e30df63602a5cfb5b7016 (patch)
tree723f794192db9fcd5762f14749e1b9e353795c78 /sysutils/lsof
parent749cd85c1a6ac23ce171eebe90eb56d838867711 (diff)
downloadports-23131ae2f65b903d194e30df63602a5cfb5b7016.tar.gz
ports-23131ae2f65b903d194e30df63602a5cfb5b7016.zip
Apply a vendor patch that corrects over-zealous rejection of open file
listing when no options are specificed to lsof and lsof security options are enabled. PR: ports/128538 Submitted by: Larry Rosenman <ler@lerctr.org> (maintainer)
Notes
Notes: svn path=/head/; revision=222336
Diffstat (limited to 'sysutils/lsof')
-rw-r--r--sysutils/lsof/Makefile1
-rw-r--r--sysutils/lsof/files/patch-proc.c19
2 files changed, 20 insertions, 0 deletions
diff --git a/sysutils/lsof/Makefile b/sysutils/lsof/Makefile
index 1b65be0b11ed..cc373f29607f 100644
--- a/sysutils/lsof/Makefile
+++ b/sysutils/lsof/Makefile
@@ -8,6 +8,7 @@
PORTNAME= lsof
PORTVERSION= 4.81
+PORTREVISION= 1
PORTEPOCH= 3
CATEGORIES= sysutils
MASTER_SITES= http://ftp.cerias.purdue.edu/pub/tools/unix/sysutils/lsof/ \
diff --git a/sysutils/lsof/files/patch-proc.c b/sysutils/lsof/files/patch-proc.c
new file mode 100644
index 000000000000..998a446f6c5c
--- /dev/null
+++ b/sysutils/lsof/files/patch-proc.c
@@ -0,0 +1,19 @@
+*** /tmp/T0fSaqTh Sun Nov 2 07:48:14 2008
+--- proc.c Sun Nov 2 07:44:24 2008
+***************
+*** 841,847 ****
+ {
+ if (Lf->sf & SELEXCLF)
+ return;
+! if (((Selflags & SELNET) == SELNET) && !(Lf->sf & SELNET))
+ return;
+ Lp->pss |= PS_SEC;
+ if (Plf)
+--- 841,847 ----
+ {
+ if (Lf->sf & SELEXCLF)
+ return;
+! if ((Selflags == SELNET) && !(Lf->sf & SELNET))
+ return;
+ Lp->pss |= PS_SEC;
+ if (Plf)