aboutsummaryrefslogtreecommitdiff
path: root/sysutils/mbmon
diff options
context:
space:
mode:
authorJean-Yves Lefort <jylefort@FreeBSD.org>2006-05-03 19:46:55 +0000
committerJean-Yves Lefort <jylefort@FreeBSD.org>2006-05-03 19:46:55 +0000
commitb5bf6c927d53a635556bf9b00112cc303eaa00cf (patch)
treed27a714b36a73eee7d1f2866300ae0b7cb4755b4 /sysutils/mbmon
parent08f03c80c5fa49bf02eea542727f83db63ba269a (diff)
downloadports-b5bf6c927d53a635556bf9b00112cc303eaa00cf.tar.gz
ports-b5bf6c927d53a635556bf9b00112cc303eaa00cf.zip
Call fflush() after printing sensor values. This allows to use mbmon
in scripts, etc.
Notes
Notes: svn path=/head/; revision=161291
Diffstat (limited to 'sysutils/mbmon')
-rw-r--r--sysutils/mbmon/Makefile2
-rw-r--r--sysutils/mbmon/files/patch-mbmon.c14
2 files changed, 11 insertions, 5 deletions
diff --git a/sysutils/mbmon/Makefile b/sysutils/mbmon/Makefile
index e5847ff9d41e..89e8a20282c3 100644
--- a/sysutils/mbmon/Makefile
+++ b/sysutils/mbmon/Makefile
@@ -7,7 +7,7 @@
PORTNAME?= mbmon
PORTVERSION= 205
-PORTREVISION?= 2
+PORTREVISION?= 3
CATEGORIES= sysutils
MASTER_SITES= http://www.nt.phys.kyushu-u.ac.jp/shimizu/download/xmbmon/
DISTNAME= xmbmon${PORTVERSION}
diff --git a/sysutils/mbmon/files/patch-mbmon.c b/sysutils/mbmon/files/patch-mbmon.c
index 5eca1d5b8d37..dbb1be28f0ed 100644
--- a/sysutils/mbmon/files/patch-mbmon.c
+++ b/sysutils/mbmon/files/patch-mbmon.c
@@ -1,7 +1,5 @@
-$FreeBSD$
-
---- mbmon.c Fri Aug 13 10:23:32 2004
-+++ mbmon.c Tue Dec 27 16:59:48 2005
+--- mbmon.c.orig Fri Aug 13 09:23:32 2004
++++ mbmon.c Wed May 3 21:32:44 2006
@@ -315,7 +315,7 @@
name = argv[0];
@@ -11,3 +9,11 @@ $FreeBSD$
#else
while ((ch = getopt(argc,argv,"VSIAfdDYe:p:c:T:F:tunNirhP:")) != -1) {
#endif
+@@ -640,6 +640,7 @@
+ else if (fanspeed == 7)
+ fprintf(out, "%4d\n%4d\n%4d\n", rot1, rot2, rot3);
+ }
++ fflush(out);
+ if (port) {
+ #ifdef LOGGING
+ if (nfd)