aboutsummaryrefslogtreecommitdiff
path: root/sysutils/mcelog
diff options
context:
space:
mode:
authorJohn Marino <marino@FreeBSD.org>2014-11-05 23:47:04 +0000
committerJohn Marino <marino@FreeBSD.org>2014-11-05 23:47:04 +0000
commit0e5aee23751118ee9b022efbf4cb50d711d1b2ff (patch)
treebc80e90fca2255f9b314d3cf39eaaf9d882688d1 /sysutils/mcelog
parent8ed1b2cd624ef94bf211824e0cf37c80d6f97170 (diff)
downloadports-0e5aee23751118ee9b022efbf4cb50d711d1b2ff.tar.gz
ports-0e5aee23751118ee9b022efbf4cb50d711d1b2ff.zip
sysutils/mcelog: Fix DF build by respecting CFLAGS and USE+=alias
PR: 194825 Submitted by: ftigeot Approved by: maintainer (Jeremy Chadwick)
Notes
Notes: svn path=/head/; revision=372212
Diffstat (limited to 'sysutils/mcelog')
-rw-r--r--sysutils/mcelog/Makefile2
-rw-r--r--sysutils/mcelog/files/patch-Makefile14
2 files changed, 8 insertions, 8 deletions
diff --git a/sysutils/mcelog/Makefile b/sysutils/mcelog/Makefile
index 39f0a9bbe10c..b37ba426153f 100644
--- a/sysutils/mcelog/Makefile
+++ b/sysutils/mcelog/Makefile
@@ -21,7 +21,7 @@ ONLY_FOR_ARCHS= amd64 i386 ia64
PATCH_STRIP= -p1
-USES= gmake
+USES= alias gmake
MAKE_ENV+= FREEBSD=1
LDFLAGS= -lkvm
diff --git a/sysutils/mcelog/files/patch-Makefile b/sysutils/mcelog/files/patch-Makefile
index 619bc29bd757..d7ece21bc368 100644
--- a/sysutils/mcelog/files/patch-Makefile
+++ b/sysutils/mcelog/files/patch-Makefile
@@ -1,13 +1,13 @@
---- Makefile.orig 2010-01-20 18:36:52.000000000 -0800
-+++ Makefile 2012-09-22 01:50:21.019688386 -0700
-@@ -1,5 +1,5 @@
- CFLAGS := -g -Os
+--- Makefile.orig 2010-01-21 02:36:52 UTC
++++ Makefile
+@@ -1,5 +1,4 @@
+-CFLAGS := -g -Os
-prefix := /usr
+prefix := /usr/local
etcprefix :=
# Define appropiately for your distribution
# DOCDIR := /usr/share/doc/packages/mcelog
-@@ -28,11 +28,18 @@
+@@ -28,11 +27,18 @@ all: mcelog
.PHONY: install clean depend
@@ -29,7 +29,7 @@
DISKDB_OBJ := diskdb.o dimm.o db.o
CLEAN := mcelog dmi tsc dbquery .depend .depend.X dbquery.o ${DISKDB_OBJ}
DOC := mce.pdf
-@@ -48,7 +55,7 @@
+@@ -48,7 +54,7 @@ endif
SRC := $(OBJ:.o=.c)
@@ -38,7 +38,7 @@
# dbquery intentionally not installed by default
install: mcelog
-@@ -82,8 +89,6 @@
+@@ -82,8 +88,6 @@ depend: .depend
.depend: ${SRC}
${CC} -MM -I. ${SRC} > .depend.X && mv .depend.X .depend