aboutsummaryrefslogtreecommitdiff
path: root/sysutils/monitord
diff options
context:
space:
mode:
authorWill Andrews <will@FreeBSD.org>2000-06-09 21:51:09 +0000
committerWill Andrews <will@FreeBSD.org>2000-06-09 21:51:09 +0000
commitf11dbca392399a4c3ba8cae7e1b5e5cc709ff657 (patch)
tree61649ff3cbb369003aa6b23086dcfed0f637ab28 /sysutils/monitord
parentfa423ab8601775bda61af01fcbf4084261bb0a5d (diff)
downloadports-f11dbca392399a4c3ba8cae7e1b5e5cc709ff657.tar.gz
ports-f11dbca392399a4c3ba8cae7e1b5e5cc709ff657.zip
Add monitord, a simple service monitoring daemon that restarts a service
should it go down (gee, does this sound like cron or what?). PR: 19011 Submitted by: Walt M. Shandruk <walt@erudition.net>
Notes
Notes: svn path=/head/; revision=29475
Diffstat (limited to 'sysutils/monitord')
-rw-r--r--sysutils/monitord/Makefile17
-rw-r--r--sysutils/monitord/distinfo1
-rw-r--r--sysutils/monitord/files/patch-aa17
-rw-r--r--sysutils/monitord/pkg-comment1
-rw-r--r--sysutils/monitord/pkg-descr6
-rw-r--r--sysutils/monitord/pkg-plist2
6 files changed, 44 insertions, 0 deletions
diff --git a/sysutils/monitord/Makefile b/sysutils/monitord/Makefile
new file mode 100644
index 000000000000..af4757215f61
--- /dev/null
+++ b/sysutils/monitord/Makefile
@@ -0,0 +1,17 @@
+# New ports collection makefile for: monitord
+# Date created: June 5, 2000
+# Whom: walt
+#
+# $FreeBSD$
+#
+
+PORTNAME= monitord
+PORTVERSION= 0.1.0
+CATEGORIES= sysutils
+MASTER_SITES= ftp://ftp.erudition.net/pub/monitord/
+
+MAINTAINER= walt@erudition.net
+
+MAN8= monitord.8
+
+.include <bsd.port.mk>
diff --git a/sysutils/monitord/distinfo b/sysutils/monitord/distinfo
new file mode 100644
index 000000000000..722078271030
--- /dev/null
+++ b/sysutils/monitord/distinfo
@@ -0,0 +1 @@
+MD5 (monitord-0.1.0.tar.gz) = 4c02100f5be1cb68527bd6af63360ec8
diff --git a/sysutils/monitord/files/patch-aa b/sysutils/monitord/files/patch-aa
new file mode 100644
index 000000000000..503db3503920
--- /dev/null
+++ b/sysutils/monitord/files/patch-aa
@@ -0,0 +1,17 @@
+--- Makefile Mon Jun 5 01:37:50 2000
++++ Makefile.new Fri Jun 9 17:48:47 2000
+@@ -1,4 +1,4 @@
+-CC = gcc
++CC ?= gcc
+ INSTALL = install
+
+ SOURCES = monitord.c
+@@ -13,7 +13,7 @@
+
+ .c.o:
+
+- $(CC) -O3 -c -pipe -Wall $<
++ $(CC) $(CFLAGS) -c -pipe -Wall $<
+
+ $(TARGET): $(OBJECTS)
+ $(CC) $(OBJECTS) -o $(TARGET)
diff --git a/sysutils/monitord/pkg-comment b/sysutils/monitord/pkg-comment
new file mode 100644
index 000000000000..6c9c08cd7172
--- /dev/null
+++ b/sysutils/monitord/pkg-comment
@@ -0,0 +1 @@
+Service that restarts other standalone services if they terminate
diff --git a/sysutils/monitord/pkg-descr b/sysutils/monitord/pkg-descr
new file mode 100644
index 000000000000..10c4b9195a9f
--- /dev/null
+++ b/sysutils/monitord/pkg-descr
@@ -0,0 +1,6 @@
+This port allows one to monitor other standalone services and automatically
+restart them if they are accidentally and unwittingly terminated, or crash
+either because of instability or a DoS attack.
+
+- Walt
+walt@erudition.net
diff --git a/sysutils/monitord/pkg-plist b/sysutils/monitord/pkg-plist
new file mode 100644
index 000000000000..6926e2af1dd8
--- /dev/null
+++ b/sysutils/monitord/pkg-plist
@@ -0,0 +1,2 @@
+etc/monitord.conf
+bin/monitord