aboutsummaryrefslogtreecommitdiff
path: root/sysutils/monitorix
diff options
context:
space:
mode:
authorWen Heping <wen@FreeBSD.org>2011-03-29 02:40:12 +0000
committerWen Heping <wen@FreeBSD.org>2011-03-29 02:40:12 +0000
commit1b1d533353e695356f21e9d78bb1ef634b744df0 (patch)
treeefe02fa801a66b9001c5bb0008aacc88edd4b91e /sysutils/monitorix
parent5939826f079639db851b8fc19acde7faa4ffa5d4 (diff)
downloadports-1b1d533353e695356f21e9d78bb1ef634b744df0.tar.gz
ports-1b1d533353e695356f21e9d78bb1ef634b744df0.zip
- Remove hardcoded /usr/local from rc script [1]
- Add trailing slashes to config file defaults [2] - Add missing PLIST_SUB expressions PR: ports/156008 Submitted by: sahil@ [1] Rick Chisholm<rchisholm_at_cyphersystems.com> [2] Chris Rees <utisoft@gmail.com> (maintainer)
Notes
Notes: svn path=/head/; revision=271960
Diffstat (limited to 'sysutils/monitorix')
-rw-r--r--sysutils/monitorix/Makefile11
-rw-r--r--sysutils/monitorix/files/monitorix.in2
2 files changed, 8 insertions, 5 deletions
diff --git a/sysutils/monitorix/Makefile b/sysutils/monitorix/Makefile
index b7b374742f4b..0a5c5a78a19f 100644
--- a/sysutils/monitorix/Makefile
+++ b/sysutils/monitorix/Makefile
@@ -7,6 +7,7 @@
PORTNAME= monitorix
PORTVERSION= 2.1.0
+PORTREVISION= 1
CATEGORIES= sysutils
MASTER_SITES= http://www.monitorix.org/ \
http://www.bayofrum.net/dist/${PORTNAME}/
@@ -42,7 +43,9 @@ WWWROOT= ${WWWDIR:S,/${PORTNAME}$,,}
SUB_FILES= pkg-message
SUB_LIST= PERL=${PERL}
-PLIST_SUB+= CGIDIR=${CGIDIR:C,^${PREFIX}/,,}
+PLIST_SUB+= CGIDIR=${CGIDIR:C,^${PREFIX}/,,} \
+ WWW_OWNER=${WWW_OWNER} \
+ WWW_GROUP=${WWW_GROUP}
WWW_FILES= logo_top.png \
logo_bot.png \
@@ -79,9 +82,9 @@ post-patch:
.endfor
# eth0 doesn't exist in FreeBSD! Also let's set our own paths.
@${REINPLACE_CMD} \
- -e 's|\($$BASE_DIR = "\)[^"]*|\1${WWWDIR}|' \
- -e 's|\($$BASE_LIB = "\)[^"]*|\1${DATADIR}|' \
- -e 's|\($$BASE_CGI = "\)[^"]*|\1${CGIPATH}|' \
+ -e 's|\($$BASE_DIR = "\)[^"]*|\1${WWWDIR}/|' \
+ -e 's|\($$BASE_LIB = "\)[^"]*|\1${DATADIR}/|' \
+ -e 's|\($$BASE_CGI = "\)[^"]*|\1${CGIPATH}/|' \
-e "s|/var/lib/milter-greylist/db/|/var/milter-greylist/|" \
-e "s|eth0|lo0|g" \
${WRKSRC}/monitorix.conf
diff --git a/sysutils/monitorix/files/monitorix.in b/sysutils/monitorix/files/monitorix.in
index b7fbfdb2b8e8..6b5ee44b9a42 100644
--- a/sysutils/monitorix/files/monitorix.in
+++ b/sysutils/monitorix/files/monitorix.in
@@ -20,7 +20,7 @@ start_cmd="${name}_start"
pidfile="/var/run/${name}.pid"
command_interpreter="."
-procname="/usr/local/sbin/${name}"
+procname="%%PREFIX%%/sbin/${name}"
monitorix_start()
{