aboutsummaryrefslogtreecommitdiff
path: root/sysutils/mpiexec/Makefile
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2006-11-18 23:03:16 +0000
committerMartin Wilke <miwi@FreeBSD.org>2006-11-18 23:03:16 +0000
commit80fe6dc4a620c655f7d315728f7dee251cb2f27a (patch)
tree1deafd1c2cfda3022350d8761057b0c89ff49cfc /sysutils/mpiexec/Makefile
parenta65271d4c4fb666f8b2d6edab58e7ce09e59d293 (diff)
downloadports-80fe6dc4a620c655f7d315728f7dee251cb2f27a.tar.gz
ports-80fe6dc4a620c655f7d315728f7dee251cb2f27a.zip
Mpiexec is a replacement program for the script mpirun, which is
part of the MPICH package. It is used to initialize a parallel job from within a PBS batch or interactive environment. Mpiexec uses the task manager library of PBS to spawn copies of the executable on the nodes in a PBS allocation. WWW: http://www.osc.edu/~pw/mpiexec/index.php PR: ports/105650 Submitted by: trasz <trasz at pin.if.uz.zgora.pl>
Notes
Notes: svn path=/head/; revision=177538
Diffstat (limited to 'sysutils/mpiexec/Makefile')
-rw-r--r--sysutils/mpiexec/Makefile25
1 files changed, 25 insertions, 0 deletions
diff --git a/sysutils/mpiexec/Makefile b/sysutils/mpiexec/Makefile
new file mode 100644
index 000000000000..be967beb260b
--- /dev/null
+++ b/sysutils/mpiexec/Makefile
@@ -0,0 +1,25 @@
+# New ports collection makefile for: mpiexec
+# Date created: 2006-11-16
+# Whom: trasz <trasz@pin.if.uz.zgora.pl>
+#
+# $FreeBSD$
+#
+
+PORTNAME= mpiexec
+PORTVERSION= 0.81
+CATEGORIES= sysutils parallel
+MASTER_SITES= http://www.osc.edu/~pw/mpiexec/
+EXTRACT_SUFX= .tgz
+
+MAINTAINER= trasz@pin.if.uz.zgora.pl
+COMMENT= A tool to run a parallel job from within a PBS environment
+
+LIB_DEPENDS= torque.0:${PORTSDIR}/sysutils/torque
+
+GNU_CONFIGURE= yes
+USE_GMAKE= yes
+
+PLIST_FILES= bin/mpiexec
+MAN1= mpiexec.1
+
+.include <bsd.port.mk>