aboutsummaryrefslogtreecommitdiff
path: root/sysutils/munin-node
diff options
context:
space:
mode:
authorDag-Erling Smørgrav <des@FreeBSD.org>2010-02-23 13:55:00 +0000
committerDag-Erling Smørgrav <des@FreeBSD.org>2010-02-23 13:55:00 +0000
commit6f830b33ee46bafffcffc04a7f4dc24eecd40f8e (patch)
treebccdd75ce1d3d1c9c0141cfaf6475ff63356abe5 /sysutils/munin-node
parent57a370406dee64a0b3f0a8836a7a7bdad33563a3 (diff)
downloadports-6f830b33ee46bafffcffc04a7f4dc24eecd40f8e.tar.gz
ports-6f830b33ee46bafffcffc04a7f4dc24eecd40f8e.zip
Upgrade Munin to 1.4.3. Thanks to Sean Rees <sean@rees.us> for providing
the initial patches and getting me started with this. Note that munin-main has been renamed to munin-master (see MOVED). Approved by: portmgr (erwin) Feature safe: yes
Notes
Notes: svn path=/head/; revision=250230
Diffstat (limited to 'sysutils/munin-node')
-rw-r--r--sysutils/munin-node/Makefile93
-rw-r--r--sysutils/munin-node/distinfo6
-rw-r--r--sysutils/munin-node/files/patch-Makefile14
-rw-r--r--sysutils/munin-node/files/patch-Makefile.config53
-rw-r--r--sysutils/munin-node/files/patch-munin-node.conf.in12
-rw-r--r--sysutils/munin-node/files/patch-netstat.in18
-rw-r--r--sysutils/munin-node/files/patch-ntp_offset.in4
-rw-r--r--sysutils/munin-node/files/pkg-message.in6
-rw-r--r--sysutils/munin-node/pkg-plist160
9 files changed, 244 insertions, 122 deletions
diff --git a/sysutils/munin-node/Makefile b/sysutils/munin-node/Makefile
index 7bb066d9feaf..9a8a9e2ae31b 100644
--- a/sysutils/munin-node/Makefile
+++ b/sysutils/munin-node/Makefile
@@ -6,51 +6,96 @@
#
PORTNAME= munin
-PORTVERSION= 1.2.6
-PORTREVISION= 1
+PORTVERSION= 1.4.3
CATEGORIES= sysutils perl5
MASTER_SITES= SF/${PORTNAME}/${PORTNAME}%20stable/${PORTVERSION}
PKGNAMESUFFIX= -node
-DISTNAME= ${PORTNAME}_${PORTVERSION:S/.r/rc/}
MAINTAINER= des@FreeBSD.org
COMMENT= Node-specific part of Munin
-USE_PERL5= yes
-
-RUN_DEPENDS= ${SITE_PERL}/Net/Server/Fork.pm:${PORTSDIR}/net/p5-Net-Server
-BUILD_DEPENDS= ${RUN_DEPENDS}
+BUILD_DEPENDS= ${SITE_PERL}/Module/Build.pm:${PORTSDIR}/devel/p5-Module-Build \
+ ${SITE_PERL}/DateTime/HiRes.pm:${PORTSDIR}/devel/p5-DateTime-HiRes \
+ ${SITE_PERL}/Munin/Common/Defaults.pm:${PORTSDIR}/sysutils/munin-common \
+ ${SITE_PERL}/Net/Server.pm:${PORTSDIR}/net/p5-Net-Server \
+ ${SITE_PERL}/Net/SNMP.pm:${PORTSDIR}/net-mgmt/p5-Net-SNMP \
+ bash:${PORTSDIR}/shells/bash
+RUN_DEPENDS= ${SITE_PERL}/DateTime/HiRes.pm:${PORTSDIR}/devel/p5-DateTime-HiRes \
+ ${SITE_PERL}/Munin/Common/Defaults.pm:${PORTSDIR}/sysutils/munin-common \
+ ${SITE_PERL}/Net/Server.pm:${PORTSDIR}/net/p5-Net-Server \
+ ${SITE_PERL}/Net/SNMP.pm:${PORTSDIR}/net-mgmt/p5-Net-SNMP \
+ bash:${PORTSDIR}/shells/bash
+USE_PERL5= yes
USE_GMAKE= yes
+PATCH_STRIP= -p0
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION:S/.r/rc/}
PKGMESSAGE= ${WRKDIR}/pkg-message
-ALL_TARGET= WWWDIR=${WWWDIR} DATADIR=${DATADIR} PERL=${PERL} build build-man
-INSTALL_TARGET= WWWDIR=${WWWDIR} DATADIR=${DATADIR} PERL=${PERL} SITE_PERL_REL=$(SITE_PERL_REL) install-node install-node-plugins
-MAKE_ENV= LANG=C
+MAKE_ARGS= LIBDIR=${DATADIR} CONFDIR=${ETCDIR} \
+ PERL=${PERL} SITE_PERL_REL=${SITE_PERL_REL}
+ALL_TARGET= build-node build-plugins
+INSTALL_TARGET= install-node-prime install-plugins-prime
+
+MAN1= munin-node-configure.1 \
+ munin-node.1 \
+ munin-run.1 \
+ munindoc.1
+MAN3_NODE= Munin::Node::Config.3 \
+ Munin::Node::Configure::Debug.3 \
+ Munin::Node::Configure::History.3 \
+ Munin::Node::Configure::HostEnumeration.3 \
+ Munin::Node::Configure::Plugin.3 \
+ Munin::Node::Configure::PluginList.3 \
+ Munin::Node::Logger.3 \
+ Munin::Node::OS.3 \
+ Munin::Node::SNMPConfig.3 \
+ Munin::Node::Server.3 \
+ Munin::Node::Service.3 \
+ Munin::Node::Session.3 \
+ Munin::Node::Utils.3
+MAN3_PLUGIN= Munin::Plugin.3 \
+ Munin::Plugin::Pgsql.3 \
+ Munin::Plugin::SNMP.3
+MAN3= ${MAN3_NODE} ${MAN3_PLUGIN}
MAN5= munin-node.conf.5
-MAN8= munin-node-configure.8 munin-node.8 munin-run.8
+MAN8= munin.8
-SUB_FILES= pkg-message munin-node.sh munin-node-revive.sh
-SUB_LIST= RC_SUBR=${RC_SUBR}
-USE_RC_SUBR= YES
+SUB_FILES= pkg-message munin-node-revive.sh
+USE_RC_SUBR= munin-node.sh
+RC_SUBR_SUFFIX= .sh
pre-su-install:
@PKG_PREFIX=${PREFIX} ${SH} ${PKGINSTALL} ${PKGNAME} PRE-INSTALL
post-install:
- ${INSTALL_SCRIPT} ${WRKDIR}/munin-node.sh ${PREFIX}/etc/rc.d/munin-node.sh
- ${INSTALL_DATA} ${WRKSRC}/build/node/munin-node.conf ${PREFIX}/etc/munin/munin-node.conf.sample
- ${INSTALL_DATA} ${FILESDIR}/plugins.conf ${PREFIX}/etc/munin/plugin-conf.d/plugins.conf.sample
+ ${INSTALL_SCRIPT} ${WRKDIR}/munin-node.sh \
+ ${PREFIX}/etc/rc.d/munin-node.sh
+ ${INSTALL_DATA} ${WRKSRC}/build/node/munin-node.conf \
+ ${PREFIX}/etc/munin/munin-node.conf.sample
+ ${INSTALL_DATA} ${FILESDIR}/plugins.conf \
+ ${PREFIX}/etc/munin/plugin-conf.d/plugins.conf.sample
@if [ ! -f ${PREFIX}/etc/munin/plugin-conf.d/plugins.conf ]; then \
- ${INSTALL_DATA} ${PREFIX}/etc/munin/plugin-conf.d/plugins.conf.sample ${PREFIX}/etc/munin/plugin-conf.d/plugins.conf; \
+ ${INSTALL_DATA} ${PREFIX}/etc/munin/plugin-conf.d/plugins.conf.sample \
+ ${PREFIX}/etc/munin/plugin-conf.d/plugins.conf; \
fi
+ @(cd ${WRKSRC}/node/blib/bindoc && for man in ${MAN1}; do \
+ ${INSTALL_MAN} -C $$man ${PREFIX}/man/man1; \
+ done)
+ @(cd ${WRKSRC}/node/blib/libdoc && for man in ${MAN3_NODE}; do \
+ ${INSTALL_MAN} -C $$man ${PREFIX}/man/man3; \
+ done)
+ @(cd ${WRKSRC}/plugins/blib/libdoc && for man in ${MAN3_PLUGIN}; do \
+ ${INSTALL_MAN} -C $$man ${PREFIX}/man/man3; \
+ done)
+ @(cd ${WRKSRC}/build/doc && for man in ${MAN5}; do \
+ ${INSTALL_MAN} -C $$man ${PREFIX}/man/man5; \
+ done)
+ @(cd ${WRKSRC}/build/doc && for man in ${MAN8}; do \
+ ${INSTALL_MAN} -C $$man ${PREFIX}/man/man8; \
+ done)
+ @${ECHO} ${PORTVERSION} > ${PREFIX}/etc/munin/VERSION.node
+ PKG_PREFIX=${PREFIX} ${SH} ${PKGINSTALL} ${PKGNAME} POST-INSTALL
@${CAT} ${PKGMESSAGE}
- @${INSTALL_MAN} -C ${WRKSRC}/build/doc/munin-node.conf.5 ${PREFIX}/man/man5
- @${INSTALL_MAN} -C ${WRKSRC}/build/doc/munin-node-configure.8 ${PREFIX}/man/man8
- @${INSTALL_MAN} -C ${WRKSRC}/build/doc/munin-node.8 ${PREFIX}/man/man8
- @${INSTALL_MAN} -C ${WRKSRC}/build/doc/munin-run.8 ${PREFIX}/man/man8
- @PKG_PREFIX=${PREFIX} ${SH} ${PKGINSTALL} ${PKGNAME} POST-INSTALL
- @${ECHO} ${DISTNAME} | ${SED} -e 's/munin_//' > ${PREFIX}/etc/munin/VERSION.node
.include <bsd.port.mk>
diff --git a/sysutils/munin-node/distinfo b/sysutils/munin-node/distinfo
index 3222d2677ecc..b74600488bbb 100644
--- a/sysutils/munin-node/distinfo
+++ b/sysutils/munin-node/distinfo
@@ -1,3 +1,3 @@
-MD5 (munin_1.2.6.tar.gz) = 45f84d58f80642ce914f147232f0d396
-SHA256 (munin_1.2.6.tar.gz) = 3b04d72810317a91225c78652277079ec3cc5791ef8991326da219a05d2477d8
-SIZE (munin_1.2.6.tar.gz) = 360694
+MD5 (munin-1.4.3.tar.gz) = 229646facc4e2bca6511b20b3e5eb73f
+SHA256 (munin-1.4.3.tar.gz) = c5f1c8e5e71e9ffd5c74037ec3eec4da362fd2aecea3c788abb7d92b461834d0
+SIZE (munin-1.4.3.tar.gz) = 1205698
diff --git a/sysutils/munin-node/files/patch-Makefile b/sysutils/munin-node/files/patch-Makefile
new file mode 100644
index 000000000000..5b502c7dadb9
--- /dev/null
+++ b/sysutils/munin-node/files/patch-Makefile
@@ -0,0 +1,14 @@
+--- Makefile.orig 2009-12-30 05:55:56.000000000 -0700
++++ Makefile 2010-01-30 12:57:44.000000000 -0700
+@@ -65,11 +65,8 @@
+ endif
+
+ install-pre: Makefile Makefile.config
+- @$(CHECKUSER)
+- mkdir -p $(LOGDIR)
+ mkdir -p $(STATEDIR)
+ mkdir -p $(CONFDIR)
+- $(CHOWN) $(USER) $(LOGDIR) $(STATEDIR)
+
+ install-master-prime: $(INFILES_MASTER) install-pre install-master
+ mkdir -p $(CONFDIR)/templates
diff --git a/sysutils/munin-node/files/patch-Makefile.config b/sysutils/munin-node/files/patch-Makefile.config
index 39e568a0b690..7b9627fb5304 100644
--- a/sysutils/munin-node/files/patch-Makefile.config
+++ b/sysutils/munin-node/files/patch-Makefile.config
@@ -1,6 +1,6 @@
---- Makefile.config.orig 2008-01-20 20:32:46.000000000 +0100
-+++ Makefile.config 2008-08-09 15:44:06.000000000 +0200
-@@ -7,46 +7,50 @@
+--- Makefile.config.orig 2009-12-30 05:55:56.000000000 -0700
++++ Makefile.config 2010-01-30 11:17:34.000000000 -0700
+@@ -17,29 +17,33 @@
#
# the base of the Munin installation.
#
@@ -36,11 +36,16 @@
+LIBDIR = $(DATADIR)
# Server only - Output directory
--HTMLDIR = $(PREFIX)/var/www
--CGIDIR = $(HTMLDIR)/cgi
+-HTMLDIR = $(PREFIX)/www/docs
+-CGIDIR = $(PREFIX)/www/cgi
+HTMLDIR = $(WWWDIR)
+CGIDIR = $(PREFIX)/www/cgi-bin
+ # Server only - spool directory for data gathered from nodes by
+ # munin-gather - experimental. Place on ramdisk to make munin
+@@ -52,21 +56,20 @@
+ # SSPOOLDIR := /tmp/muninspool
+
# Client only - Where to put RRD files and other intenal data
-DBDIR = $(DESTDIR)/var/opt/munin
+DBDIR = $(PREFIX)/var/munin
@@ -50,8 +55,8 @@
PLUGSTATE = $(DBDIR)/plugin-state
# Where Munin should place its logs.
--LOGDIR = $(DESTDIR)/var/log/munin
-+LOGDIR = /var/log
+-LOGDIR = $(PREFIX)/log/munin
++LOGDIR = /var/log/munin-main
# Location of PID files and other statefiles. On the server, must be
# writable by the user "munin".
@@ -59,33 +64,33 @@
+STATEDIR = /var/run/munin
# The perl interpreter to use
--PERL = $(shell which perl)
-+# Passed in from FreeBSD port Makefile.
+-PERL := $(shell which perl)
# The python interpreter to use (used by some plugins)
- PYTHON = /usr/bin/env python
-@@ -62,10 +66,10 @@
- GOODSH = $(shell PATH=`getconf PATH` sh -c 'type sh | sed "s/.* //"')
+ PYTHON := /usr/bin/env python
+@@ -95,11 +98,11 @@
+ GOODSH := $(shell PATH=`getconf PATH` sh -c 'type sh | sed "s/.* //"')
# Path of bash for bash specific plugins
--BASH = /bin/bash
-+BASH = /usr/local/bin/bash
+-BASH := /bin/bash
++BASH := /usr/local/bin/bash
# Server only - Where to install the perl libraries
--PERLLIB = $(DESTDIR)$(shell $(PERL) -V:sitelib | cut -d"'" -f2)
+ PERLSITELIB := $(shell $(PERL) -V:sitelib | cut -d"'" -f2)
+-PERLLIB = $(DESTDIR)$(PERLSITELIB)
+PERLLIB = $(PREFIX)/$(SITE_PERL_REL)
# Client only - Install plugins for this architecture
- OSTYPE = $(shell uname | tr '[A-Z]' '[a-z]')
-@@ -90,9 +94,8 @@
- PLUGINUSER = nobody
-
+ OSTYPE := $(shell uname | tr '[A-Z]' '[a-z]')
+@@ -126,9 +129,8 @@
# Which command to use to check if the USER and GROUP to run Munin as, exists.
--GETENT = $(shell which getent || which true 2>/dev/null)
--CHECKUSER = $(shell $(GETENT) passwd $(USER) >/dev/null 2>/dev/null || (echo "echo User $(USER) nonexistant. Create the user and retry; exit 2"))
--CHECKGROUP = $(shell $(GETENT) group $(GROUP) >/dev/null 2>/dev/null || (echo "echo Group $(GROUP) nonexistant. Create the group and retry; exit 2"))
+ # These will work on most modern OSes:
+ #
+-GETENT := $(shell which getent || which true 2>/dev/null)
+-CHECKUSER := $(shell $(GETENT) passwd $(USER) >/dev/null 2>/dev/null || (echo "echo User $(USER) nonexistent. Create the user and retry; exit 2"))
+-CHECKGROUP := $(shell $(GETENT) group $(GROUP) >/dev/null 2>/dev/null || (echo "echo Group $(GROUP) nonexistent. Create the group and retry; exit 2"))
+CHECKUSER:= $(shell /usr/sbin/pw user show $(USER) >/dev/null 2>/dev/null || (echo "echo User $(USER) nonexistant. Create the user and retry; exit 2"))
+CHECKGROUP:= $(shell /usr/sbin/pw group show $(GROUP) >/dev/null 2>/dev/null || (echo "echo Group $(GROUP) nonexistant. Create the group and retry; exit 2"))
- # For OSX, comment out the previous two lines and comment in these
- #CHECKUSER = $(shell nicl . -read /users/$(USER) >/dev/null 2>/dev/null || (echo "echo User $(USER) nonexistant. Create the user and retry; exit 2"))
+ # For OSX, comment out the previous two lines and comment in these
+ #
diff --git a/sysutils/munin-node/files/patch-munin-node.conf.in b/sysutils/munin-node/files/patch-munin-node.conf.in
index c09e0fa11415..40cd5af9e812 100644
--- a/sysutils/munin-node/files/patch-munin-node.conf.in
+++ b/sysutils/munin-node/files/patch-munin-node.conf.in
@@ -1,11 +1,11 @@
---- node/munin-node.conf.in.orig Thu Jan 15 15:28:57 2004
-+++ node/munin-node.conf.in Sun Jan 25 14:26:15 2004
-@@ -12,7 +12,7 @@
- # Which port to bind to;
- host *
+--- node/munin-node.conf.in.orig 2010-01-30 12:07:52.000000000 -0700
++++ node/munin-node.conf.in 2010-01-30 12:07:59.000000000 -0700
+@@ -10,7 +10,7 @@
+ setsid 1
+
user root
-group root
+group wheel
- setsid yes
# Regexps for files to ignore
+
diff --git a/sysutils/munin-node/files/patch-netstat.in b/sysutils/munin-node/files/patch-netstat.in
deleted file mode 100644
index aa19165937ce..000000000000
--- a/sysutils/munin-node/files/patch-netstat.in
+++ /dev/null
@@ -1,18 +0,0 @@
---- node/node.d.freebsd/netstat.in.orig 2006-11-02 15:15:57.000000000 +0100
-+++ node/node.d.freebsd/netstat.in 2008-08-17 14:01:14.000000000 +0200
-@@ -45,7 +45,7 @@
-
-
- if [ "$1" = "autoconf" ]; then
-- if ( /bin/netstat -s 2>/dev/null >/dev/null ); then
-+ if ( /usr/bin/netstat -s 2>/dev/null >/dev/null ); then
- echo yes
- exit 0
- else
-@@ -96,5 +96,5 @@
- exit 0
- fi
-
--/bin/netstat -s | awk '/connection requests/ { print "active.value " $1 } /connection accepts/ { print "passive.value " $1 } /bad connection/ { print "failed.value " $1 } /reset/ { print "resets.value " $1 } /connections established/ { print "established.value " $1 }'
-+/usr/bin/netstat -s | awk '/connection requests/ { print "active.value " $1 } /connection accepts/ { print "passive.value " $1 } /bad connection/ { print "failed.value " $1 } /reset/ { print "resets.value " $1 } /connections established/ { print "established.value " $1 }'
-
diff --git a/sysutils/munin-node/files/patch-ntp_offset.in b/sysutils/munin-node/files/patch-ntp_offset.in
index a378b43ee17e..befd273aaff8 100644
--- a/sysutils/munin-node/files/patch-ntp_offset.in
+++ b/sysutils/munin-node/files/patch-ntp_offset.in
@@ -1,5 +1,5 @@
---- node/node.d/ntp_offset.in.orig 2008-10-14 19:50:27.092576040 +0900
-+++ node/node.d/ntp_offset.in 2008-10-14 19:50:36.788908430 +0900
+--- plugins/node.d/ntp_offset.in.orig 2008-10-14 19:50:27.092576040 +0900
++++ plugins/node.d/ntp_offset.in 2008-10-14 19:50:36.788908430 +0900
@@ -1,4 +1,4 @@
-#!@@GOODSH@@ -w
+#!@@GOODSH@@
diff --git a/sysutils/munin-node/files/pkg-message.in b/sysutils/munin-node/files/pkg-message.in
index 965c716ba8b5..2bb30e8e5e4c 100644
--- a/sysutils/munin-node/files/pkg-message.in
+++ b/sysutils/munin-node/files/pkg-message.in
@@ -1,7 +1,6 @@
-
********************************************************************
Unless this file already existed, a sample configuration file
-has been placed in %%PREFIX%%/etc/munin/munin-node.conf.
+has been placed in %%ETCDIR%%/munin/munin-node.conf.
Please edit it according to your needs.
@@ -16,6 +15,5 @@ Then, it will be started on the next boot. If this line is already
present, the client will be started now. Otherwise, edit
/etc/rc.conf and execute this command:
- %%PREFIX%%/etc/rc.d/munin-node.sh start
+ %%ETCDIR%%/rc.d/munin-node.sh start
********************************************************************
-
diff --git a/sysutils/munin-node/pkg-plist b/sysutils/munin-node/pkg-plist
index a96e2e5fcd32..5042f619b5b9 100644
--- a/sysutils/munin-node/pkg-plist
+++ b/sysutils/munin-node/pkg-plist
@@ -1,74 +1,125 @@
-@exec mkdir -p %D/etc/munin/plugins
-@exec mkdir -p %D/etc/munin/plugin-conf.d && chmod 755 %D/etc/munin/plugin-conf.d
-@exec mkdir -p %D/var/munin/plugin-state && chgrp munin %D/var/munin/plugin-state && chmod 775 %D/var/munin/plugin-state
-@unexec rm %D/bin/munin-node-revive 2>/dev/null || true
-@unexec if [ -n "$PACKAGE_BUILDING" ]; then rm -f %D/etc/munin/VERSION.node; fi
-@unexec if cmp -s %D/etc/munin/munin-node.conf %D/etc/munin/munin-node.conf.sample; then rm -f %D/etc/munin/munin-node.conf; fi
+bin/munindoc
+etc/munin/VERSION.node
etc/munin/munin-node.conf.sample
-@unexec if cmp -s %D/etc/munin/plugin-conf.d/plugins.conf %D/etc/munin/plugin-conf.d/plugins.conf.sample; then rm -f %D/etc/munin/plugin-conf.d/plugins.conf; fi
etc/munin/plugin-conf.d/plugins.conf.sample
-bin/munindoc
-etc/rc.d/munin-node.sh
+%%SITE_PERL%%/Munin/Node/Config.pm
+%%SITE_PERL%%/Munin/Node/Configure/Debug.pm
+%%SITE_PERL%%/Munin/Node/Configure/History.pm
+%%SITE_PERL%%/Munin/Node/Configure/HostEnumeration.pm
+%%SITE_PERL%%/Munin/Node/Configure/Plugin.pm
+%%SITE_PERL%%/Munin/Node/Configure/PluginList.pm
+%%SITE_PERL%%/Munin/Node/Logger.pm
+%%SITE_PERL%%/Munin/Node/OS.pm
+%%SITE_PERL%%/Munin/Node/SNMPConfig.pm
+%%SITE_PERL%%/Munin/Node/Server.pm
+%%SITE_PERL%%/Munin/Node/Service.pm
+%%SITE_PERL%%/Munin/Node/Session.pm
+%%SITE_PERL%%/Munin/Node/Utils.pm
%%SITE_PERL%%/Munin/Plugin.pm
+%%SITE_PERL%%/Munin/Plugin/Pgsql.pm
+%%SITE_PERL%%/Munin/Plugin/SNMP.pm
sbin/munin-node
sbin/munin-node-configure
-sbin/munin-node-configure-snmp
sbin/munin-run
-%%DATADIR%%/plugins/acpi
%%DATADIR%%/plugins/amavis
%%DATADIR%%/plugins/apache_accesses
%%DATADIR%%/plugins/apache_processes
%%DATADIR%%/plugins/apache_volume
%%DATADIR%%/plugins/apc_envunit_
%%DATADIR%%/plugins/apc_nis
+%%DATADIR%%/plugins/asterisk_channels
+%%DATADIR%%/plugins/asterisk_channelstypes
+%%DATADIR%%/plugins/asterisk_codecs
+%%DATADIR%%/plugins/asterisk_meetme
+%%DATADIR%%/plugins/asterisk_meetmeusers
+%%DATADIR%%/plugins/asterisk_sipchannels
+%%DATADIR%%/plugins/asterisk_sippeers
+%%DATADIR%%/plugins/asterisk_voicemail
%%DATADIR%%/plugins/bind9
%%DATADIR%%/plugins/bind9_rndc
+%%DATADIR%%/plugins/cmc_tc_sensor_
+%%DATADIR%%/plugins/colour_tester
+%%DATADIR%%/plugins/coretemp
%%DATADIR%%/plugins/courier_
%%DATADIR%%/plugins/courier_mta_mailqueue
%%DATADIR%%/plugins/courier_mta_mailstats
%%DATADIR%%/plugins/courier_mta_mailvolume
%%DATADIR%%/plugins/cpu
%%DATADIR%%/plugins/cupsys_pages
+%%DATADIR%%/plugins/dev_cpu_
%%DATADIR%%/plugins/df
%%DATADIR%%/plugins/df_inode
%%DATADIR%%/plugins/dhcpd3
+%%DATADIR%%/plugins/digitemp_
+%%DATADIR%%/plugins/ejabberd_
+%%DATADIR%%/plugins/env
%%DATADIR%%/plugins/exim_mailqueue
%%DATADIR%%/plugins/exim_mailqueue_alt
%%DATADIR%%/plugins/exim_mailstats
+%%DATADIR%%/plugins/extinfo_tester
+%%DATADIR%%/plugins/fail2ban
%%DATADIR%%/plugins/foldingathome
%%DATADIR%%/plugins/foldingathome_rank
%%DATADIR%%/plugins/foldingathome_wu
+%%DATADIR%%/plugins/freeradius_acct
+%%DATADIR%%/plugins/freeradius_auth
+%%DATADIR%%/plugins/freeradius_proxy_acct
+%%DATADIR%%/plugins/freeradius_proxy_auth
+%%DATADIR%%/plugins/haproxy_
%%DATADIR%%/plugins/hddtemp
%%DATADIR%%/plugins/hddtemp2
%%DATADIR%%/plugins/hddtemp_smartctl
%%DATADIR%%/plugins/hddtempd
+%%DATADIR%%/plugins/http_loadtime
+%%DATADIR%%/plugins/id
%%DATADIR%%/plugins/if_
%%DATADIR%%/plugins/if_errcoll_
+%%DATADIR%%/plugins/ifx_concurrent_sessions_
+%%DATADIR%%/plugins/iostat
%%DATADIR%%/plugins/ipac-ng
+%%DATADIR%%/plugins/ipmi_sensor_
%%DATADIR%%/plugins/ircu
+%%DATADIR%%/plugins/jmx_
%%DATADIR%%/plugins/load
%%DATADIR%%/plugins/loggrep
+%%DATADIR%%/plugins/lpstat
%%DATADIR%%/plugins/mailman
%%DATADIR%%/plugins/mailscanner
%%DATADIR%%/plugins/mbmon_
+%%DATADIR%%/plugins/memcached_
%%DATADIR%%/plugins/memory
%%DATADIR%%/plugins/mhttping
+%%DATADIR%%/plugins/multigraph_tester
+%%DATADIR%%/plugins/multiping
%%DATADIR%%/plugins/multips
-%%DATADIR%%/plugins/munin_graph
+%%DATADIR%%/plugins/multips_memory
+%%DATADIR%%/plugins/munin_stats
%%DATADIR%%/plugins/munin_update
+%%DATADIR%%/plugins/mysql_
%%DATADIR%%/plugins/mysql_bytes
+%%DATADIR%%/plugins/mysql_innodb
%%DATADIR%%/plugins/mysql_isam_space_
%%DATADIR%%/plugins/mysql_queries
%%DATADIR%%/plugins/mysql_slowqueries
%%DATADIR%%/plugins/mysql_threads
%%DATADIR%%/plugins/named
+%%DATADIR%%/plugins/netopia
%%DATADIR%%/plugins/netstat
+%%DATADIR%%/plugins/nginx_request
+%%DATADIR%%/plugins/nginx_status
+%%DATADIR%%/plugins/nomadix_users_
%%DATADIR%%/plugins/ntp_
+%%DATADIR%%/plugins/ntp_kernel_err
+%%DATADIR%%/plugins/ntp_kernel_pll_freq
+%%DATADIR%%/plugins/ntp_kernel_pll_off
%%DATADIR%%/plugins/ntp_offset
%%DATADIR%%/plugins/ntp_states
%%DATADIR%%/plugins/nut_misc
%%DATADIR%%/plugins/nut_volts
+%%DATADIR%%/plugins/nutups_
+%%DATADIR%%/plugins/nvidia_
%%DATADIR%%/plugins/open_files
+%%DATADIR%%/plugins/openvpn
%%DATADIR%%/plugins/perdition
%%DATADIR%%/plugins/ping_
%%DATADIR%%/plugins/plugin.sh
@@ -78,21 +129,49 @@ sbin/munin-run
%%DATADIR%%/plugins/postfix_mailqueue
%%DATADIR%%/plugins/postfix_mailstats
%%DATADIR%%/plugins/postfix_mailvolume
+%%DATADIR%%/plugins/postgres_bgwriter
+%%DATADIR%%/plugins/postgres_cache_
+%%DATADIR%%/plugins/postgres_checkpoints
+%%DATADIR%%/plugins/postgres_connections_
+%%DATADIR%%/plugins/postgres_connections_db
+%%DATADIR%%/plugins/postgres_locks_
+%%DATADIR%%/plugins/postgres_querylength_
+%%DATADIR%%/plugins/postgres_scans_
+%%DATADIR%%/plugins/postgres_size_
+%%DATADIR%%/plugins/postgres_transactions_
+%%DATADIR%%/plugins/postgres_tuples_
+%%DATADIR%%/plugins/postgres_users
+%%DATADIR%%/plugins/postgres_xlog
%%DATADIR%%/plugins/processes
%%DATADIR%%/plugins/ps_
%%DATADIR%%/plugins/psu_
+%%DATADIR%%/plugins/qmailqstat
+%%DATADIR%%/plugins/qmailscan
+%%DATADIR%%/plugins/qmailscan-simple
%%DATADIR%%/plugins/samba
%%DATADIR%%/plugins/sendmail_mailqueue
%%DATADIR%%/plugins/sendmail_mailstats
%%DATADIR%%/plugins/sendmail_mailtraffic
+%%DATADIR%%/plugins/slapd_
+%%DATADIR%%/plugins/slapd_bdb_cache_
+%%DATADIR%%/plugins/slony_lag_
%%DATADIR%%/plugins/smart_
+%%DATADIR%%/plugins/snmp__cpuload
%%DATADIR%%/plugins/snmp__df
%%DATADIR%%/plugins/snmp__fc_if_
%%DATADIR%%/plugins/snmp__fc_if_err_
%%DATADIR%%/plugins/snmp__if_
%%DATADIR%%/plugins/snmp__if_err_
+%%DATADIR%%/plugins/snmp__if_multi
%%DATADIR%%/plugins/snmp__load
+%%DATADIR%%/plugins/snmp__memory
+%%DATADIR%%/plugins/snmp__netapp_diskusage_
+%%DATADIR%%/plugins/snmp__netapp_inodeusage_
+%%DATADIR%%/plugins/snmp__netstat
+%%DATADIR%%/plugins/snmp__print_pages
+%%DATADIR%%/plugins/snmp__print_supplies
%%DATADIR%%/plugins/snmp__processes
+%%DATADIR%%/plugins/snmp__rdp_users
%%DATADIR%%/plugins/snmp__sensors_fsc_bx_fan
%%DATADIR%%/plugins/snmp__sensors_fsc_bx_temp
%%DATADIR%%/plugins/snmp__sensors_fsc_fan
@@ -100,48 +179,47 @@ sbin/munin-run
%%DATADIR%%/plugins/snmp__sensors_mbm_fan
%%DATADIR%%/plugins/snmp__sensors_mbm_temp
%%DATADIR%%/plugins/snmp__sensors_mbm_volt
+%%DATADIR%%/plugins/snmp__swap
+%%DATADIR%%/plugins/snmp__uptime
%%DATADIR%%/plugins/snmp__users
+%%DATADIR%%/plugins/snmp__winload
+%%DATADIR%%/plugins/snmp__winmem
+%%DATADIR%%/plugins/snort_alerts
+%%DATADIR%%/plugins/snort_bytes_pkt
+%%DATADIR%%/plugins/snort_drop_rate
+%%DATADIR%%/plugins/snort_pattern_match
+%%DATADIR%%/plugins/snort_pkts
+%%DATADIR%%/plugins/snort_traffic
%%DATADIR%%/plugins/spamstats
+%%DATADIR%%/plugins/squeezebox_
%%DATADIR%%/plugins/squid_cache
%%DATADIR%%/plugins/squid_icp
+%%DATADIR%%/plugins/squid_objectsize
%%DATADIR%%/plugins/squid_requests
%%DATADIR%%/plugins/squid_traffic
%%DATADIR%%/plugins/surfboard
%%DATADIR%%/plugins/swap
%%DATADIR%%/plugins/sybase_space
+%%DATADIR%%/plugins/systat
+%%DATADIR%%/plugins/tomcat_
+%%DATADIR%%/plugins/tomcat_access
+%%DATADIR%%/plugins/tomcat_jvm
+%%DATADIR%%/plugins/tomcat_threads
+%%DATADIR%%/plugins/tomcat_volume
+%%DATADIR%%/plugins/uptime
+%%DATADIR%%/plugins/users
+%%DATADIR%%/plugins/varnish_
%%DATADIR%%/plugins/vmstat
-@unexec rm -f /var/run/munin/munin-node.pid
-@unexec rmdir /var/run/munin 2>/dev/null || true
+%%DATADIR%%/plugins/warning_tester
+%%DATADIR%%/plugins/zimbra_
@dirrmtry var/munin/plugin-state
@dirrmtry var/munin
-@dirrmtry %%DATADIR%%/plugins
+@dirrm %%DATADIR%%/plugins
@dirrmtry %%DATADIR%%
-@dirrmtry %%SITE_PERL%%/Munin/Plugin
+@dirrm %%SITE_PERL%%/Munin/Plugin
+@dirrm %%SITE_PERL%%/Munin/Node/Configure
+@dirrm %%SITE_PERL%%/Munin/Node
@dirrmtry %%SITE_PERL%%/Munin
-@dirrmtry etc/munin/plugin-conf.d
@dirrmtry etc/munin/plugins
+@dirrmtry etc/munin/plugin-conf.d
@dirrmtry etc/munin
-@unexec echo remove %%SITE_PERL%%/Munin/Plugin
-@unexec echo remove %%SITE_PERL%%/Munin
-@dirrmtry %%SITE_PERL%%/Munin/Plugin
-@dirrmtry %%SITE_PERL%%/Munin
-@unexec echo
-@unexec echo '********************************************************************'
-@unexec echo "If you want to *completely* remove munin-node, you have to"
-@unexec echo
-@unexec echo " rm -rf %D/etc/munin/VERSION.node %D/etc/munin/plugins \\"
-@unexec if [ -d %D/var/munin/plugin-state ]; then echo " %D/var/munin/plugin-state \\"; fi
-@unexec if [ -f %D/etc/munin/munin-node.conf ]; then echo " %D/etc/munin/munin-node.conf \\"; fi
-@unexec if [ -d %D/var/munin/plugin-state ]; then echo " %D/var/munin/plugin-state \\"; fi
-@unexec if [ -d %%LOCALBASE%%/%%SITE_PERL%%/Munin/Plugin ]; then echo " %%LOCALBASE%%/%%SITE_PERL%%/Munin/Plugin \\"; fi
-@unexec if [ -d %%LOCALBASE%%/%%SITE_PERL%%/Munin ]; then echo " %%LOCALBASE%%/%%SITE_PERL%%/Munin/Plugin \\"; fi
-@unexec echo " /var/log/munin-node.log*"
-@unexec echo
-@unexec echo "If you have already deinstalled munin-main, you can also"
-@unexec echo
-@unexec echo " rmdir %D/etc/munin %D/var/munin"
-@unexec echo
-@unexec echo "These files and directories have to be left on the system because"
-@unexec echo "you may be performing an update. This process can't tell."
-@unexec echo '********************************************************************'
-@unexec echo