aboutsummaryrefslogtreecommitdiff
path: root/sysutils/munin-node
diff options
context:
space:
mode:
authorDag-Erling Smørgrav <des@FreeBSD.org>2010-02-25 12:15:38 +0000
committerDag-Erling Smørgrav <des@FreeBSD.org>2010-02-25 12:15:38 +0000
commit94ebcf4d98b6bc7bc2e56f64f1a780eb894f5df1 (patch)
treebd54b030ba59ee28794bf303646386745eb0891c /sysutils/munin-node
parent78ee99eb30514dee52bbfe2d229191a226af257d (diff)
downloadports-94ebcf4d98b6bc7bc2e56f64f1a780eb894f5df1.tar.gz
ports-94ebcf4d98b6bc7bc2e56f64f1a780eb894f5df1.zip
Continue rototilling the Munin ports:
- Move some files around and adjust the plists accordingly. - Fix some directory creation / deletion in the plists. - Fix some directory ownerships. - Instead of patching the Makefile, specify installation directories on the command line. Centralize the definition of MAKE_ARGS and some other shared variables. Feature safe: yes
Notes
Notes: svn path=/head/; revision=250300
Diffstat (limited to 'sysutils/munin-node')
-rw-r--r--sysutils/munin-node/Makefile22
-rw-r--r--sysutils/munin-node/files/munin-node.sh.in27
-rw-r--r--sysutils/munin-node/files/patch-Makefile.config82
-rw-r--r--sysutils/munin-node/files/pkg-message.in2
-rw-r--r--sysutils/munin-node/pkg-deinstall2
-rw-r--r--sysutils/munin-node/pkg-install2
6 files changed, 10 insertions, 127 deletions
diff --git a/sysutils/munin-node/Makefile b/sysutils/munin-node/Makefile
index 8edd1a020a5d..82f9dc845401 100644
--- a/sysutils/munin-node/Makefile
+++ b/sysutils/munin-node/Makefile
@@ -7,7 +7,7 @@
PORTNAME= munin
PORTVERSION= 1.4.3
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= sysutils perl5
MASTER_SITES= SF/${PORTNAME}/${PORTNAME}%20stable/${PORTVERSION}
PKGNAMESUFFIX= -node
@@ -29,16 +29,10 @@ RUN_DEPENDS= ${SITE_PERL}/DateTime/HiRes.pm:${PORTSDIR}/devel/p5-DateTime-HiRes
USE_PERL5= yes
USE_GMAKE= yes
-PATCH_STRIP= -p0
-WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION:S/.r/rc/}
PKGMESSAGE= ${WRKDIR}/pkg-message
-USERS= munin
-GROUPS= munin
+.include "${.CURDIR}/../munin-common/munin.mk"
-DBDIR= /var/${PORTNAME}
-MAKE_ARGS= LIBDIR=${DATADIR} CONFDIR=${ETCDIR} DBDIR=${DBDIR} \
- PERL=${PERL} SITE_PERL_REL=${SITE_PERL_REL}
ALL_TARGET= build-node build-plugins
INSTALL_TARGET= install-node-prime install-plugins-prime
@@ -66,25 +60,23 @@ MAN3= ${MAN3_NODE} ${MAN3_PLUGIN}
MAN5= munin-node.conf.5
MAN8= munin.8
-PLIST_SUB= DBDIR=${DBDIR}
SUB_FILES= pkg-message munin-node-revive.sh
-USE_RC_SUBR= munin-node.sh
-RC_SUBR_SUFFIX= .sh
+USE_RC_SUBR= munin-node
pre-su-install:
@${SETENV} ${SCRIPTS_ENV} PKG_PREFIX=${PREFIX} \
${SH} ${PKGINSTALL} ${PKGNAME} PRE-INSTALL
post-install:
- ${INSTALL_SCRIPT} ${WRKDIR}/munin-node.sh \
- ${PREFIX}/etc/rc.d/munin-node.sh
- ${INSTALL_DATA} ${WRKSRC}/build/node/munin-node.conf \
+ @${INSTALL_SCRIPT} ${WRKDIR}/munin-node \
+ ${PREFIX}/etc/rc.d/munin-node
+ @${INSTALL_DATA} ${WRKSRC}/build/node/munin-node.conf \
${ETCDIR}/munin-node.conf.sample
@if [ ! -f ${ETCDIR}/munin-node.conf ]; then \
${INSTALL_DATA} ${ETCDIR}/munin-node.conf.sample \
${ETCDIR}/munin-node.conf; \
fi
- ${INSTALL_DATA} ${FILESDIR}/plugins.conf \
+ @${INSTALL_DATA} ${FILESDIR}/plugins.conf \
${ETCDIR}/plugin-conf.d/plugins.conf.sample
@if [ ! -f ${ETCDIR}/plugin-conf.d/plugins.conf ]; then \
${INSTALL_DATA} ${ETCDIR}/plugin-conf.d/plugins.conf.sample \
diff --git a/sysutils/munin-node/files/munin-node.sh.in b/sysutils/munin-node/files/munin-node.sh.in
deleted file mode 100644
index 6cb7a2b095b7..000000000000
--- a/sysutils/munin-node/files/munin-node.sh.in
+++ /dev/null
@@ -1,27 +0,0 @@
-#!/bin/sh
-#
-
-# PROVIDE: munin-node
-# REQUIRE: DAEMON
-# BEFORE: cron
-
-#
-# Add the following lines to /etc/rc.conf to enable munin-node:
-# munin_node_enable (bool): Set to "NO" by default.
-# Set it to "YES" to enable munin-node
-# munin_node_config (path): Set to "%%PREFIX%%/etc/munin/munin-node.conf" by default.
-#
-
-. %%RC_SUBR%%
-
-name="munin_node"
-rcvar=`set_rcvar`
-
-[ -z "$munin_node_enable" ] && munin_node_enable="NO"
-[ -z "$munin_node_config" ] && munin_node_config="%%PREFIX%%/etc/munin/munin-node.conf"
-
-command="%%PREFIX%%/sbin/munin-node"
-pidfile=`awk '$1 == "pid_file" { print $2 }' $munin_node_config`
-
-load_rc_config $name
-run_rc_command "$1"
diff --git a/sysutils/munin-node/files/patch-Makefile.config b/sysutils/munin-node/files/patch-Makefile.config
index 7b9627fb5304..98a7052bf8ae 100644
--- a/sysutils/munin-node/files/patch-Makefile.config
+++ b/sysutils/munin-node/files/patch-Makefile.config
@@ -1,87 +1,5 @@
--- Makefile.config.orig 2009-12-30 05:55:56.000000000 -0700
+++ Makefile.config 2010-01-30 11:17:34.000000000 -0700
-@@ -17,29 +17,33 @@
- #
- # the base of the Munin installation.
- #
--PREFIX = $(DESTDIR)/opt/munin
-+ifdef PREFIX
-+UPREFIX=$(PREFIX)
-+else
-+UPREFIX=/usr
-+endif
-
- # Where Munin keeps its configurations (server.conf, client.conf, ++)
--CONFDIR = $(DESTDIR)/etc/opt/munin
-+CONFDIR = $(PREFIX)/etc/munin
-
- # Server only - where to put munin-cron
--BINDIR = $(PREFIX)/bin
-+BINDIR = $(UPREFIX)/bin
-
- # Client only - where to put munin-node, munin-node-configure, and munin-run
--SBINDIR = $(PREFIX)/sbin
-+SBINDIR = $(UPREFIX)/sbin
-
- # Where to put text and html documentation
--DOCDIR = $(PREFIX)/doc
-+DOCDIR = $(UPREFIX)/doc
-
- # Where to put man pages
--MANDIR = $(PREFIX)/man
-+MANDIR = $(UPREFIX)/man
-
- # Where to put internal binaries and plugin repository
--LIBDIR = $(PREFIX)/lib
-+LIBDIR = $(DATADIR)
-
- # Server only - Output directory
--HTMLDIR = $(PREFIX)/www/docs
--CGIDIR = $(PREFIX)/www/cgi
-+HTMLDIR = $(WWWDIR)
-+CGIDIR = $(PREFIX)/www/cgi-bin
-
- # Server only - spool directory for data gathered from nodes by
- # munin-gather - experimental. Place on ramdisk to make munin
-@@ -52,21 +56,20 @@
- # SSPOOLDIR := /tmp/muninspool
-
- # Client only - Where to put RRD files and other intenal data
--DBDIR = $(DESTDIR)/var/opt/munin
-+DBDIR = $(PREFIX)/var/munin
-
- # Client only - Where plugins should put their states. Must be writable by
- # group "munin", and should be preserved between reboots
- PLUGSTATE = $(DBDIR)/plugin-state
-
- # Where Munin should place its logs.
--LOGDIR = $(PREFIX)/log/munin
-+LOGDIR = /var/log/munin-main
-
- # Location of PID files and other statefiles. On the server, must be
- # writable by the user "munin".
--STATEDIR = $(DESTDIR)/var/run/munin
-+STATEDIR = /var/run/munin
-
- # The perl interpreter to use
--PERL := $(shell which perl)
-
- # The python interpreter to use (used by some plugins)
- PYTHON := /usr/bin/env python
-@@ -95,11 +98,11 @@
- GOODSH := $(shell PATH=`getconf PATH` sh -c 'type sh | sed "s/.* //"')
-
- # Path of bash for bash specific plugins
--BASH := /bin/bash
-+BASH := /usr/local/bin/bash
-
- # Server only - Where to install the perl libraries
- PERLSITELIB := $(shell $(PERL) -V:sitelib | cut -d"'" -f2)
--PERLLIB = $(DESTDIR)$(PERLSITELIB)
-+PERLLIB = $(PREFIX)/$(SITE_PERL_REL)
-
- # Client only - Install plugins for this architecture
- OSTYPE := $(shell uname | tr '[A-Z]' '[a-z]')
@@ -126,9 +129,8 @@
# Which command to use to check if the USER and GROUP to run Munin as, exists.
# These will work on most modern OSes:
diff --git a/sysutils/munin-node/files/pkg-message.in b/sysutils/munin-node/files/pkg-message.in
index d28dc2b0ef02..3b0d85fa8955 100644
--- a/sysutils/munin-node/files/pkg-message.in
+++ b/sysutils/munin-node/files/pkg-message.in
@@ -15,5 +15,5 @@ Then, it will be started on the next boot. If this line is already
present, the client will be started now. Otherwise, edit
/etc/rc.conf and execute this command:
- %%PREFIX%%/etc/rc.d/munin-node.sh start
+ %%PREFIX%%/etc/rc.d/munin-node start
********************************************************************
diff --git a/sysutils/munin-node/pkg-deinstall b/sysutils/munin-node/pkg-deinstall
index 37776c3061b8..358fae50e416 100644
--- a/sysutils/munin-node/pkg-deinstall
+++ b/sysutils/munin-node/pkg-deinstall
@@ -30,7 +30,7 @@ yesno() {
}
stop_process() {
- STARTSTOP=${PKG_PREFIX}/etc/rc.d/munin-node.sh
+ STARTSTOP=${PKG_PREFIX}/etc/rc.d/munin-node
if [ -x $STARTSTOP ]; then
$STARTSTOP stop
diff --git a/sysutils/munin-node/pkg-install b/sysutils/munin-node/pkg-install
index 5b5e5b5fec5f..3b5fd90ff602 100644
--- a/sysutils/munin-node/pkg-install
+++ b/sysutils/munin-node/pkg-install
@@ -90,7 +90,7 @@ case $2 in
POST-INSTALL)
if [ -z "${PACKAGE_BUILDING}" ]; then
init_plugins
- ${PKG_PREFIX}/etc/rc.d/munin-node.sh start
+ ${PKG_PREFIX}/etc/rc.d/munin-node start
newsyslog
fi
;;