aboutsummaryrefslogtreecommitdiff
path: root/sysutils/nut22/Makefile
diff options
context:
space:
mode:
authorDoug Barton <dougb@FreeBSD.org>2002-01-20 01:11:27 +0000
committerDoug Barton <dougb@FreeBSD.org>2002-01-20 01:11:27 +0000
commitf55829cb5a9fe10fe9a00b9f2b347e0ad0acc862 (patch)
treee78ef57a61f6de3b5c607e11af40042bad217390 /sysutils/nut22/Makefile
parent7d456e9565543f173ef57adc92cb12273f933816 (diff)
downloadports-f55829cb5a9fe10fe9a00b9f2b347e0ad0acc862.tar.gz
ports-f55829cb5a9fe10fe9a00b9f2b347e0ad0acc862.zip
The safest way to handle nut's state and pid files is to have them all
sent to a directory that's writeable by user uucp. I generally configure this manually myself when I install nut, and since there are so many other things that need manual configuration, I never thought it was a big deal. However, a user pointed out that it'd be nice if the thing (well, at least this part of the thing) worked more or less out of the box, so here you go. This change adds a /var/db/nut directory that is owned by user uucp.
Notes
Notes: svn path=/head/; revision=53369
Diffstat (limited to 'sysutils/nut22/Makefile')
-rw-r--r--sysutils/nut22/Makefile7
1 files changed, 6 insertions, 1 deletions
diff --git a/sysutils/nut22/Makefile b/sysutils/nut22/Makefile
index e309cf7d148f..22d580cc6487 100644
--- a/sysutils/nut22/Makefile
+++ b/sysutils/nut22/Makefile
@@ -14,8 +14,11 @@ MAINTAINER= DougB@FreeBSD.org
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --sysconfdir=${PREFIX}/etc/nut \
+ --localstatedir=/var/db/nut \
--with-modelpath=${PREFIX}/libexec/nut \
- --with-statepath=/var/db
+ --with-statepath=/var/db/nut \
+ --with-altpidpath=/var/db/nut \
+ --with-pidpath=/var/db/nut
MAN5= ups.conf.5 upsd.conf.5 upsd.users.5 upsmon.conf.5 \
upssched.conf.5
@@ -48,6 +51,8 @@ pre-fetch:
pre-install:
@${MKDIR} ${PREFIX}/libexec/nut
+ @${MKDIR} /var/db/nut
+ @${CHOWN} uucp /var/db/nut
NDOCDIR= ${PREFIX}/share/doc/nut