aboutsummaryrefslogtreecommitdiff
path: root/sysutils/nut22
diff options
context:
space:
mode:
authorTilman Keskinoz <arved@FreeBSD.org>2008-01-02 13:55:34 +0000
committerTilman Keskinoz <arved@FreeBSD.org>2008-01-02 13:55:34 +0000
commit754984377c7ccfc2a4a7ea6b3d4fdc280e02f7c2 (patch)
treef2be37549bb70c9468b5140dcb50c3431861d3f4 /sysutils/nut22
parent7ae9128891ef11980a572d5f83effbea17b5c9e3 (diff)
downloadports-754984377c7ccfc2a4a7ea6b3d4fdc280e02f7c2.tar.gz
ports-754984377c7ccfc2a4a7ea6b3d4fdc280e02f7c2.zip
Fix configure check for IPv6 detection, and add an IPV6 OPTION
PR: 117144 Submitted by: Joerg Pulz <Joerg.Pulz@frm2.tum.de>
Notes
Notes: svn path=/head/; revision=204849
Diffstat (limited to 'sysutils/nut22')
-rw-r--r--sysutils/nut22/Makefile9
-rw-r--r--sysutils/nut22/files/patch-m4-nut_check_ipv6.m413
2 files changed, 22 insertions, 0 deletions
diff --git a/sysutils/nut22/Makefile b/sysutils/nut22/Makefile
index c3dcd9404b9e..973ab7ac05b2 100644
--- a/sysutils/nut22/Makefile
+++ b/sysutils/nut22/Makefile
@@ -7,6 +7,7 @@
PORTNAME= nut
PORTVERSION= 2.2.0
+PORTREVISION= 1
CATEGORIES= sysutils
MASTER_SITES= http://www.networkupstools.org/source/${PORTVERSION:R}/
DISTFILES= ${DISTNAME}${EXTRACT_SUFX} ${DISTNAME}${EXTRACT_SUFX}.sig
@@ -15,6 +16,7 @@ EXTRACT_ONLY= ${DISTNAME}${EXTRACT_SUFX}
MAINTAINER= Joerg.Pulz@frm2.tum.de
COMMENT= Network UPS Tools
+USE_AUTOTOOLS= autoconf:261
GNU_CONFIGURE= yes
USE_GMAKE= yes
@@ -24,6 +26,7 @@ STATEDIR?= /var/db/nut
OPTIONS= USB "USB support" on \
SNMP "SNMP support" on \
+ IPV6 "IPV6 support" on \
LIBUPSCLIENT "Include the libupsclient library" off \
CGI "Web CGI interface" off \
@@ -102,6 +105,12 @@ CONFIGURE_ARGS+= --without-snmp
PLIST_SUB+= NUT_SNMP="@comment "
.endif
+.if !defined(WITHOUT_IPV6)
+CONFIGURE_ARGS+= --with-ipv6
+.else
+CONFIGURE_ARGS+= --without-ipv6
+.endif
+
.if defined(WITH_LIBUPSCLIENT)
CONFIGURE_ARGS+= --with-lib --enable-pkg-config \
--with-pkgconfig-dir=${PREFIX}/libdata/pkgconfig
diff --git a/sysutils/nut22/files/patch-m4-nut_check_ipv6.m4 b/sysutils/nut22/files/patch-m4-nut_check_ipv6.m4
new file mode 100644
index 000000000000..fa12e98b55d3
--- /dev/null
+++ b/sysutils/nut22/files/patch-m4-nut_check_ipv6.m4
@@ -0,0 +1,13 @@
+--- m4/nut_check_ipv6.m4.orig 2007-03-15 21:19:05.000000000 +0100
++++ m4/nut_check_ipv6.m4 2007-10-15 11:42:02.000000000 +0200
+@@ -22,7 +22,9 @@
+ struct in6_addr],
+ [:],
+ [nut_have_ipv6=no],
+- [#include <netdb.h>])
++ [#include <netdb.h>
++ #include <sys/socket.h>
++ #include <netinet/in.h>])
+
+ dnl AC_CHECK_MEMBERS([struct in6_addr.s6_addr32],
+ dnl [:],