aboutsummaryrefslogtreecommitdiff
path: root/sysutils/pcfclock
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2005-05-04 14:25:52 +0000
committerPav Lucistnik <pav@FreeBSD.org>2005-05-04 14:25:52 +0000
commit9fcf507f17d3e7e263a1d3df1095cac719bec8de (patch)
treebfb46a246a6b61a8f856d67b984e0c6515e90d6b /sysutils/pcfclock
parent6119440a381bfa4a8c9fccec93c89bd540f110a7 (diff)
downloadports-9fcf507f17d3e7e263a1d3df1095cac719bec8de.tar.gz
ports-9fcf507f17d3e7e263a1d3df1095cac719bec8de.zip
- Don't abort installation when we fail to make device
PR: ports/80592 Submitted by: Frank W. Josellis <frank@dynamical-systems.org> (maintainer)
Notes
Notes: svn path=/head/; revision=134609
Diffstat (limited to 'sysutils/pcfclock')
-rw-r--r--sysutils/pcfclock/Makefile9
-rw-r--r--sysutils/pcfclock/pkg-install15
2 files changed, 23 insertions, 1 deletions
diff --git a/sysutils/pcfclock/Makefile b/sysutils/pcfclock/Makefile
index cc61a7c49565..8b6ebff235cd 100644
--- a/sysutils/pcfclock/Makefile
+++ b/sysutils/pcfclock/Makefile
@@ -7,6 +7,7 @@
PORTNAME= pcfclock
PORTVERSION= 0.44
+PORTREVISION= 1
CATEGORIES= sysutils
MASTER_SITES= http://www-stud.ims.uni-stuttgart.de/~voegelas/pcfclock/
@@ -21,6 +22,14 @@ PLIST_FILES= sbin/pcfdate
.include <bsd.port.pre.mk>
+.if ${ARCH} == "alpha"
+IGNORE= Not supported for architecture ${ARCH}
+.endif
+
+.if ${OSVERSION} < 400000
+IGNORE= Not supported for versions prior to FreeBSD 4.0
+.endif
+
post-install:
.if ${OSVERSION} < 500000
${SH} ${PKGINSTALL} ${PKGNAME} POST-INSTALL
diff --git a/sysutils/pcfclock/pkg-install b/sysutils/pcfclock/pkg-install
index 5042c4f80682..c9dee1bc1ddd 100644
--- a/sysutils/pcfclock/pkg-install
+++ b/sysutils/pcfclock/pkg-install
@@ -2,6 +2,19 @@
case $2 in
POST-INSTALL)
- [ -c /dev/pcfclock0 ] || ( cd /dev && ./MAKEDEV pcfclock0 )
+ if [ ! -c /dev/pcfclock0 ]; then
+ rv=1
+ if [ -x /dev/MAKEDEV ]; then
+ ( cd /dev && ./MAKEDEV pcfclock0 )
+ rv=$?
+ fi
+
+ if [ ${rv} = 0 ]; then
+ echo "$2: Device special file /dev/pcfclock0 created"
+ else
+ echo "$2: Unexpected failure creating /dev/pcfclock0"
+ echo "$2: Try 'cd /dev ; mknod pcfclock0 c 140 0 root:wheel'"
+ fi
+ fi
;;
esac