aboutsummaryrefslogtreecommitdiff
path: root/sysutils/pftop
diff options
context:
space:
mode:
authorMarcelo Araujo <araujo@FreeBSD.org>2014-10-21 07:03:35 +0000
committerMarcelo Araujo <araujo@FreeBSD.org>2014-10-21 07:03:35 +0000
commit5d101bfdd113635a384a83d21548ad2d22587e4d (patch)
treeaaa171622f3fdb6766c67f3d5773c903a08ae28c /sysutils/pftop
parent8f5ce5d6012eacfdfe91d7fa03c8f3240bcf1668 (diff)
downloadports-5d101bfdd113635a384a83d21548ad2d22587e4d.tar.gz
ports-5d101bfdd113635a384a83d21548ad2d22587e4d.zip
- Mark as UNBROKEN on FreeBSD >= 1100000.
PR: 188826 Submitted by: Oliver Peter Tested by: daniel.engberg.lists
Notes
Notes: svn path=/head/; revision=371311
Diffstat (limited to 'sysutils/pftop')
-rw-r--r--sysutils/pftop/Makefile6
-rw-r--r--sysutils/pftop/files/patch-bpf_dump.c15
-rw-r--r--sysutils/pftop/files/patch-sf-gencode.h10
3 files changed, 26 insertions, 5 deletions
diff --git a/sysutils/pftop/Makefile b/sysutils/pftop/Makefile
index 1ee58760d8cb..bcafce80cef9 100644
--- a/sysutils/pftop/Makefile
+++ b/sysutils/pftop/Makefile
@@ -3,7 +3,7 @@
PORTNAME= pftop
PORTVERSION= 0.7
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= sysutils net
MASTER_SITES= http://www.eee.metu.edu.tr/~canacar/
@@ -12,10 +12,6 @@ COMMENT= Utility for real-time display of statistics for pf
.include <bsd.port.pre.mk>
-.if ${OSVERSION} >= 1100000
-BROKEN= Does not compile on HEAD
-.endif
-
.if ${OSVERSION} < 900039
MAKE_ARGS= LOCALBASE="${PREFIX}" OSLEVEL=41
CFLAGS+= -DHAVE_ALTQ=1
diff --git a/sysutils/pftop/files/patch-bpf_dump.c b/sysutils/pftop/files/patch-bpf_dump.c
new file mode 100644
index 000000000000..cc31af8c928a
--- /dev/null
+++ b/sysutils/pftop/files/patch-bpf_dump.c
@@ -0,0 +1,15 @@
+--- bpf_dump.c.orig 2007-11-07 07:34:18.000000000 +0100
++++ bpf_dump.c 2014-10-17 12:39:01.000000000 +0200
+@@ -33,10 +33,10 @@
+ #include <stdio.h>
+
+
+-extern void bpf_dump(struct bpf_program *, int);
++extern void bpf_dump(const struct bpf_program *, int);
+
+ void
+-bpf_dump(struct bpf_program *p, int option)
++bpf_dump(const struct bpf_program *p, int option)
+ {
+ struct bpf_insn *insn;
+ int i;
diff --git a/sysutils/pftop/files/patch-sf-gencode.h b/sysutils/pftop/files/patch-sf-gencode.h
new file mode 100644
index 000000000000..c516cc075265
--- /dev/null
+++ b/sysutils/pftop/files/patch-sf-gencode.h
@@ -0,0 +1,10 @@
+--- sf-gencode.h 2014-10-17 12:39:16.000000000 +0200
++++ sf-gencode.h.orig 2014-10-17 12:39:01.000000000 +0200
+@@ -188,7 +188,7 @@
+ const char *sf_get_error(void);
+ int sf_compile(struct bpf_program *, char *, int, bpf_u_int32);
+ void sf_freecode(struct bpf_program *);
+-void bpf_dump(struct bpf_program *, int);
++void bpf_dump(const struct bpf_program *, int);
+
+ extern int no_optimize;