aboutsummaryrefslogtreecommitdiff
path: root/sysutils/portupgrade/Makefile
diff options
context:
space:
mode:
authorFlorent Thoumie <flz@FreeBSD.org>2006-05-29 17:45:34 +0000
committerFlorent Thoumie <flz@FreeBSD.org>2006-05-29 17:45:34 +0000
commit128460e57cc9ab1b02bd771567fdbae3760b48ef (patch)
tree08c5b12bf17bc0f85888d5edc9aa539a09c224a3 /sysutils/portupgrade/Makefile
parenta7686ddbe193c1d29c4dbfe6ffea7ae0aa758181 (diff)
downloadports-128460e57cc9ab1b02bd771567fdbae3760b48ef.tar.gz
ports-128460e57cc9ab1b02bd771567fdbae3760b48ef.zip
- Convert to USE_LDCONFIG.
PR: ports/93186 Submitted by: $self Approved by: maintainer
Notes
Notes: svn path=/head/; revision=163869
Diffstat (limited to 'sysutils/portupgrade/Makefile')
-rw-r--r--sysutils/portupgrade/Makefile10
1 files changed, 7 insertions, 3 deletions
diff --git a/sysutils/portupgrade/Makefile b/sysutils/portupgrade/Makefile
index 9e95e5d7da78..6fdba0333e18 100644
--- a/sysutils/portupgrade/Makefile
+++ b/sysutils/portupgrade/Makefile
@@ -7,7 +7,7 @@
PORTNAME= portupgrade
PORTVERSION= 2.0.1
-PORTREVISION= 1
+PORTREVISION= 2
PORTEPOCH= 1
CATEGORIES= sysutils
MASTER_SITES= http://dists.lovepeers.org/distfiles/portupgrade/
@@ -27,12 +27,15 @@ PATCH_DIST_STRIP= -p1
OPTIONS= BDB4 "Use Berkeley DB >=2 as backend. (Use BDB 1.85 if off)" off
-USE_RC_SUBR= yes
USE_BZIP2= yes
USE_RUBY= yes
USE_RUBY_FEATURES= optparse ruby18
USE_PERL5_RUN= yes
+INSTALLS_SHLIB= yes
+LDCONFIG_DIRS= %%PREFIX%%/lib/compat/pkg
+USE_LDCONFIG= ${PREFIX}/lib/compat/pkg
+
MAKE_ARGS= PREFIX="${PREFIX}" RUBY="${RUBY}"
MAN1= pkg_deinstall.1 \
@@ -57,6 +60,7 @@ INSTALL_TARGET+= install-doc
.endif
.include <bsd.port.pre.mk>
+.include "${PORTSDIR}/misc/ldconfig_compat/bsd.ldconfig.mk"
.if defined(WITH_BDB4)
# For PKG_DBDRIVER={bdb_btree,bdb_hash,bdb}
@@ -72,7 +76,7 @@ PKG_CREATE_OK!= /usr/sbin/pkg_create 2>&1 | ${GREP} ' -b ' || ${TRUE}
IGNORE= pkg_create does not support -b. Please update /usr/sbin/pkg_* to those of the latest RELENG_4
.endif
-post-install:
+post-install: install-ldconfig-file
if [ ! -f ${PREFIX}/etc/pkgtools.conf ]; then \
${CP} -p ${PREFIX}/etc/pkgtools.conf.sample ${PREFIX}/etc/pkgtools.conf; \
fi