aboutsummaryrefslogtreecommitdiff
path: root/sysutils/portupgrade/Makefile
diff options
context:
space:
mode:
authorSergey Matveychuk <sem@FreeBSD.org>2006-06-30 10:06:53 +0000
committerSergey Matveychuk <sem@FreeBSD.org>2006-06-30 10:06:53 +0000
commit4df325cdc99415cdb2993f701b10df021385c7d3 (patch)
treea221b6cb9ab53254117583988710baafdadba4a4 /sysutils/portupgrade/Makefile
parent8d983baf417c17bb1e1d88720039bee4833d8d5b (diff)
downloadports-4df325cdc99415cdb2993f701b10df021385c7d3.tar.gz
ports-4df325cdc99415cdb2993f701b10df021385c7d3.zip
- Fork a stable branch.
It's exactly like 2.1.3 but without summary messages and fixed bug when BDB4 was defined but tried only bdb1 driver and fall back to dbd driver. - Add an option WITH_BDB1. Both BDB1 and BDB4 options can be off. Ruby dbd driver will use in the case.
Notes
Notes: svn path=/head/; revision=166651
Diffstat (limited to 'sysutils/portupgrade/Makefile')
-rw-r--r--sysutils/portupgrade/Makefile29
1 files changed, 25 insertions, 4 deletions
diff --git a/sysutils/portupgrade/Makefile b/sysutils/portupgrade/Makefile
index f8985a3f7cec..6bbea1a152e9 100644
--- a/sysutils/portupgrade/Makefile
+++ b/sysutils/portupgrade/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= portupgrade
-PORTVERSION= 2.1.1
+PORTVERSION= 2.1.3.1
PORTEPOCH= 2
CATEGORIES= sysutils
MASTER_SITES= ${MASTER_SITE_LOCAL} \
@@ -17,7 +17,8 @@ DISTNAME= pkgtools-${DISTVERSION}
MAINTAINER= sem@FreeBSD.org
COMMENT= FreeBSD ports/packages administration and management tool suite
-OPTIONS= BDB4 "Use Berkeley DB >=2 as backend. (Use BDB 1.85 if off)" off
+OPTIONS= BDB4 "Use Berkeley DB >=2 as backend" on \
+ BDB1 "Use Berkeley DB 1.85 as backend" off
USE_BZIP2= yes
USE_RUBY= yes
@@ -55,12 +56,32 @@ INSTALL_TARGET+= install-doc
.include "${PORTSDIR}/misc/ldconfig_compat/bsd.ldconfig.mk"
.if defined(WITH_BDB4)
-# For PKG_DBDRIVER={bdb_btree,bdb_hash,bdb}
+# For PKG_DBDRIVER={bdb_btree,bdb_hash}
RUN_DEPENDS+= ${RUBY_SITEARCHLIBDIR}/bdb.so:${PORTSDIR}/databases/ruby-bdb
-.else
+.endif
+.if defined(WITH_BDB1) && !defined(WITH_BDB4)
+# For PKG_DBDRIVER={bdb1_btree,bdb1_hash}
RUN_DEPENDS+= ${RUBY_SITEARCHLIBDIR}/bdb1.so:${PORTSDIR}/databases/ruby-bdb1
.endif
+pre-extract:
+.if !defined(WITH_BDB4) && !defined(WITH_BDB1)
+ @${ECHO_MSG} "================================================================="
+ @${ECHO_MSG} "Neither WITH_DBD4 nor WITH_BDB1 are defined. Will use DBD driver."
+ @${ECHO_MSG} "================================================================="
+.endif
+.if defined(WITH_BDB4) && defined(WITH_BDB1)
+ @${ECHO_MSG} "================================================================="
+ @${ECHO_MSG} "Both WITH_DBD4 and WITH_BDB1 are defined. Will use BDB4 driver."
+ @${ECHO_MSG} "================================================================="
+.elif defined(WITH_BDB1) && exists(${RUBY_SITEARCHLIBDIR}/bdb.so)
+ @${ECHO_MSG} "================================================================="
+ @${ECHO_MSG} "WITH_BDB1 is defined but ruby-bdb port installed."
+ @${ECHO_MSG} "Remove ruby-bdb or redefine options."
+ @${ECHO_MSG} "================================================================="
+ @exit 1
+.endif
+
post-install: install-ldconfig-file
if [ ! -f ${PREFIX}/etc/pkgtools.conf ]; then \
${CP} -p ${PREFIX}/etc/pkgtools.conf.sample ${PREFIX}/etc/pkgtools.conf; \