aboutsummaryrefslogtreecommitdiff
path: root/sysutils/portupgrade/Makefile
diff options
context:
space:
mode:
authorAkinori MUSHA <knu@FreeBSD.org>2002-11-09 07:38:15 +0000
committerAkinori MUSHA <knu@FreeBSD.org>2002-11-09 07:38:15 +0000
commit96e3b242f0c319fccffd2cebe38a1faf5fb13e14 (patch)
treea1ee07c57a113437f9a449526f5bd9f4adab50f9 /sysutils/portupgrade/Makefile
parenteeba82262ad50ef63fcafa40fcd06cfc45c2c7dc (diff)
downloadports-96e3b242f0c319fccffd2cebe38a1faf5fb13e14.tar.gz
ports-96e3b242f0c319fccffd2cebe38a1faf5fb13e14.zip
Update to 20021109.
overall: - Allow a regular expression or glob pattern against origins as pkgname glob pattern. For example, the following commands work as expected now: pkg_glob 'lang/*' portupgrade lang/ruby pkg_info ':(japanese|chinese|korean)/' - Use install(1) instead of cp(1) and chmod(1) to install modified data files such as +CONTENTS. pkgdb(1): - Add a new option --autofix, which is a shorthand of --auto --fix (-aF). portupgrade(1): - Allow specifying a directory after -L. - Auto-fix dependencies before creating a package. PR: ports/41383 Submitted by: Vivek Khera <khera@kciLink.com> pkgtools.conf(5): - Add a new configuration variable ALT_PKGDEP, which defines alternative dependencies, used by pkgdb -F/-aF. This makes yet another step forward to eliminate the need for manual pkgdb -F's.
Notes
Notes: svn path=/head/; revision=69776
Diffstat (limited to 'sysutils/portupgrade/Makefile')
-rw-r--r--sysutils/portupgrade/Makefile9
1 files changed, 3 insertions, 6 deletions
diff --git a/sysutils/portupgrade/Makefile b/sysutils/portupgrade/Makefile
index aececc5e6132..599d511de100 100644
--- a/sysutils/portupgrade/Makefile
+++ b/sysutils/portupgrade/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= portupgrade
-PORTVERSION= 20021106
-PORTREVISION= 1
+PORTVERSION= 20021109
CATEGORIES= sysutils
MASTER_SITES= ftp://ftp.iDaemons.org/pub/distfiles/ \
${MASTER_SITE_LOCAL}
@@ -20,7 +19,8 @@ DISTVERSION= 20021101
PATCH_SITES= ${MASTER_SITES}
PATCH_SITE_SUBDIR= ${MASTER_SITE_SUBDIR}
PATCHFILES= ${DISTNAME}-20021103.diff.bz2 \
- pkgtools-20021103-${PORTVERSION}.diff.bz2
+ pkgtools-20021103-20021106.diff.bz2 \
+ pkgtools-20021106-${PORTVERSION}.diff.bz2
PATCH_DIST_STRIP= -p1
.endif
@@ -66,9 +66,6 @@ PKG_CREATE_OK!= /usr/sbin/pkg_create 2>&1 | ${GREP} ' -b ' || ${TRUE}
IGNORE= pkg_create does not support -b. Please update /usr/sbin/pkg_* to those of the latest RELENG_4
.endif
-post-patch:
- ${RUBY} -i -pe "gsub(/('\/bin\/)cp(', '-f', tmpfile, file)/, '\1mv\2')" ${WRKSRC}/lib/pkgtools.rb
-
post-install:
if [ ! -f ${PREFIX}/etc/pkgtools.conf ]; then \
${CP} -p ${PREFIX}/etc/pkgtools.conf.sample ${PREFIX}/etc/pkgtools.conf; \