aboutsummaryrefslogtreecommitdiff
path: root/sysutils/pwgen
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2009-02-05 20:33:53 +0000
committerMartin Wilke <miwi@FreeBSD.org>2009-02-05 20:33:53 +0000
commit9b1368fe9b9d8b3cbf1661c9eb1419357c2cd691 (patch)
tree6af75d981417179b849fa0be864e7c674cd8000f /sysutils/pwgen
parenta633a5cc5048bcf39c021391e1de48fa2d7d81ec (diff)
downloadports-9b1368fe9b9d8b3cbf1661c9eb1419357c2cd691.tar.gz
ports-9b1368fe9b9d8b3cbf1661c9eb1419357c2cd691.zip
- Restore to 1.15 to fix the index
Pointy hat to: pgollucci
Notes
Notes: svn path=/head/; revision=227683
Diffstat (limited to 'sysutils/pwgen')
-rw-r--r--sysutils/pwgen/Makefile10
-rw-r--r--sysutils/pwgen/distinfo6
-rw-r--r--sysutils/pwgen/files/patch-aa39
3 files changed, 49 insertions, 6 deletions
diff --git a/sysutils/pwgen/Makefile b/sysutils/pwgen/Makefile
index 0d48ecde0b5b..e6279bbd0a62 100644
--- a/sysutils/pwgen/Makefile
+++ b/sysutils/pwgen/Makefile
@@ -6,14 +6,18 @@
#
PORTNAME= pwgen
-PORTVERSION= 2.06
+PORTVERSION= 1.15
+PORTREVISION= 1
+PORTEPOCH= 1
CATEGORIES= sysutils
-MASTER_SITES= SF
+MASTER_SITES= http://www.tricknology.org/ports/
MAINTAINER= oddbjorn@tricknology.org
COMMENT= A simple password generator
-GNU_CONFIGURE= yes
+WRKSRC= ${WRKDIR}/${PORTNAME}-1
+MAKE_ENV= CPPFLAGS="${CPPFLAGS}" \
+ LDFLAGS="${LDFLAGS}"
MAN1= pwgen.1
PLIST_FILES= bin/pwgen
diff --git a/sysutils/pwgen/distinfo b/sysutils/pwgen/distinfo
index fc5afe322ccb..99d6c87adb1c 100644
--- a/sysutils/pwgen/distinfo
+++ b/sysutils/pwgen/distinfo
@@ -1,3 +1,3 @@
-MD5 (pwgen-2.06.tar.gz) = 935aebcbe610fbc9de8125e7b7d71297
-SHA256 (pwgen-2.06.tar.gz) = 61598c9e3a0f7eb2e7367d4ecc71522c4f16a7d41ed31db29e3afee8d9843454
-SIZE (pwgen-2.06.tar.gz) = 30952
+MD5 (pwgen-1.15.tar.gz) = 311724e3ce09155694191563be5543e9
+SHA256 (pwgen-1.15.tar.gz) = fb50a42bf3bf9608f5d3e5b72a414e05df13ff1f03945549cb44fe454c81dbd4
+SIZE (pwgen-1.15.tar.gz) = 14839
diff --git a/sysutils/pwgen/files/patch-aa b/sysutils/pwgen/files/patch-aa
new file mode 100644
index 000000000000..25108e8189e2
--- /dev/null
+++ b/sysutils/pwgen/files/patch-aa
@@ -0,0 +1,39 @@
+--- Makefile.orig Tue Jan 4 22:54:58 2000
++++ Makefile Sun Jul 6 20:15:32 2003
+@@ -6,17 +6,17 @@
+ OPTS = -DALLBYOPTS -DRAND48 -DDEBIAN
+
+ # Standard items
+-CC = gcc
+-CFLAGS = -O3
+-LD = cc
+-#LDFLAGS = -g
++CC ?= gcc
++CFLAGS += ${CPPFLAGS}
++LD = ${CC}
+ LIBS = -lm
+ INSTALL = install -s
+ INFLAGS =
+
+ # Where to install
+-DESTDIR = /usr/local/bin
+-MANDIR = /usr/local/man/man1
++PREFIX ?= /usr/local
++DESTDIR = ${PREFIX}/bin
++MANDIR = ${PREFIX}/man/man1
+
+ # End configuration section
+
+@@ -27,10 +27,8 @@
+ ./pwgen 8 20
+
+ install: all
+- $(INSTALL) pwgen $(DESTDIR)
+- install pwgen.1 $(MANDIR)
+- chmod 555 $(DESTDIR)/pwgen
+- chmod 444 $(MANDIR)/pwgen.1
++ ${BSD_INSTALL_PROGRAM} pwgen $(DESTDIR)
++ ${BSD_INSTALL_MAN} pwgen.1 $(MANDIR)
+
+ spwgen: spwgen.o
+ $(LD) $(LDFLAGS) -o spwgen spwgen.o $(LIBS)