aboutsummaryrefslogtreecommitdiff
path: root/sysutils/pwgen
diff options
context:
space:
mode:
authorFUJISHIMA Satsuki <sf@FreeBSD.org>2003-07-14 02:53:03 +0000
committerFUJISHIMA Satsuki <sf@FreeBSD.org>2003-07-14 02:53:03 +0000
commitb185046be2ec03555daaf4f26d38542c403a9955 (patch)
tree0274ce607614533de66837fc1f70d4c35770d9e1 /sysutils/pwgen
parent88d002074007544d532f2495aeb93729291e6275 (diff)
downloadports-b185046be2ec03555daaf4f26d38542c403a9955.tar.gz
ports-b185046be2ec03555daaf4f26d38542c403a9955.zip
get rid of libgnugetopt dependency for -CURRENT,
use USE_GETOPT_LONG instead.
Notes
Notes: svn path=/head/; revision=84842
Diffstat (limited to 'sysutils/pwgen')
-rw-r--r--sysutils/pwgen/Makefile5
-rw-r--r--sysutils/pwgen/files/patch-aa12
2 files changed, 9 insertions, 8 deletions
diff --git a/sysutils/pwgen/Makefile b/sysutils/pwgen/Makefile
index b63ce3e63dba..94a6253e4e58 100644
--- a/sysutils/pwgen/Makefile
+++ b/sysutils/pwgen/Makefile
@@ -7,15 +7,18 @@
PORTNAME= pwgen
PORTVERSION= 1.15
+PORTREVISION= 1
CATEGORIES= sysutils
MASTER_SITES= http://www.tricknology.org/ports/
MAINTAINER= oddbjorn@tricknology.org
COMMENT= A simple password generator
-LIB_DEPENDS= gnugetopt.1:${PORTSDIR}/devel/libgnugetopt
+USE_GETOPT_LONG=yes
WRKSRC= ${WRKDIR}/${PORTNAME}-1
+MAKE_ENV= CPPFLAGS="${CPPFLAGS}" \
+ LDFLAGS="${LDFLAGS}"
MAN1= pwgen.1
diff --git a/sysutils/pwgen/files/patch-aa b/sysutils/pwgen/files/patch-aa
index 6c2cdcbb438c..25108e8189e2 100644
--- a/sysutils/pwgen/files/patch-aa
+++ b/sysutils/pwgen/files/patch-aa
@@ -1,6 +1,6 @@
--- Makefile.orig Tue Jan 4 22:54:58 2000
-+++ Makefile Sat Aug 12 00:49:23 2000
-@@ -6,17 +6,18 @@
++++ Makefile Sun Jul 6 20:15:32 2003
+@@ -6,17 +6,17 @@
OPTS = -DALLBYOPTS -DRAND48 -DDEBIAN
# Standard items
@@ -8,12 +8,10 @@
-CFLAGS = -O3
-LD = cc
-#LDFLAGS = -g
--LIBS = -lm
+CC ?= gcc
-+CFLAGS += -I${LOCALBASE}/include
++CFLAGS += ${CPPFLAGS}
+LD = ${CC}
-+LDFLAGS = -L${LOCALBASE}/lib
-+LIBS = -lm -lgnugetopt
+ LIBS = -lm
INSTALL = install -s
INFLAGS =
@@ -26,7 +24,7 @@
# End configuration section
-@@ -27,10 +28,8 @@
+@@ -27,10 +27,8 @@
./pwgen 8 20
install: all