aboutsummaryrefslogtreecommitdiff
path: root/sysutils/qzeitgeist/Makefile
diff options
context:
space:
mode:
authorBaptiste Daroussin <bapt@FreeBSD.org>2013-04-29 08:57:12 +0000
committerBaptiste Daroussin <bapt@FreeBSD.org>2013-04-29 08:57:12 +0000
commit5271da855f0c5946ff1f3aa58fbe806871df2f87 (patch)
tree526d65e6697f1e03c06ab0d0f901688aa2c4e18d /sysutils/qzeitgeist/Makefile
parent8730c99d5ea1ba861dbab3e0dbc07e16826b1a7a (diff)
downloadports-5271da855f0c5946ff1f3aa58fbe806871df2f87.tar.gz
ports-5271da855f0c5946ff1f3aa58fbe806871df2f87.zip
Rely on bsdtar to autodetermine the format of the distfiles when possible
For a while now bsdtar is able to autotermine compression and archive format. Let's then use tar directly instead of piping to tar. Now USE_BZIP2 and USE_XZ only set EXTRACT_SUFX to the right format
Notes
Notes: svn path=/head/; revision=316786
Diffstat (limited to 'sysutils/qzeitgeist/Makefile')
-rw-r--r--sysutils/qzeitgeist/Makefile2
1 files changed, 1 insertions, 1 deletions
diff --git a/sysutils/qzeitgeist/Makefile b/sysutils/qzeitgeist/Makefile
index 6e5ecfeea716..b0e49bb3c7cb 100644
--- a/sysutils/qzeitgeist/Makefile
+++ b/sysutils/qzeitgeist/Makefile
@@ -33,7 +33,7 @@ USE_LDCONFIG= yes
ZEITGEIST_VERSION= 0.8.2
post-extract:
- @(cd ${WRKDIR} && ${GZIP_CMD} ${EXTRACT_BEFORE_ARGS} \
+ @(cd ${WRKDIR} && ${EXTRACT_CMD} ${EXTRACT_BEFORE_ARGS} \
${_DISTDIR}/zeitgeist-${ZEITGEIST_VERSION}.tar.gz ${EXTRACT_AFTER_ARGS})
cd ${WRKDIR}/zeitgeist-${ZEITGEIST_VERSION} && \
${CP} zeitgeist/datamodel.py \