aboutsummaryrefslogtreecommitdiff
path: root/sysutils/qzeitgeist/Makefile
diff options
context:
space:
mode:
authorAlberto Villa <avilla@FreeBSD.org>2011-10-16 23:01:09 +0000
committerAlberto Villa <avilla@FreeBSD.org>2011-10-16 23:01:09 +0000
commitf75527d0685740a4d964c95e491cb1739dc4c6a5 (patch)
tree9520fc9164242d241bce7407c7176f9d6bf829fc /sysutils/qzeitgeist/Makefile
parentc40e8860165f9f410e4aa2e4e06657ffb971621a (diff)
downloadports-f75527d0685740a4d964c95e491cb1739dc4c6a5.tar.gz
ports-f75527d0685740a4d964c95e491cb1739dc4c6a5.zip
libQZeitgeist is a wrapper library around the Zeitgeist D-Bus API for
Qt, and is brought to you by Collabora in cooperation with the Zeitgeist team and KDE. WWW: http://zeitgeist-project.com
Notes
Notes: svn path=/head/; revision=283633
Diffstat (limited to 'sysutils/qzeitgeist/Makefile')
-rw-r--r--sysutils/qzeitgeist/Makefile41
1 files changed, 41 insertions, 0 deletions
diff --git a/sysutils/qzeitgeist/Makefile b/sysutils/qzeitgeist/Makefile
new file mode 100644
index 000000000000..458f2b91170a
--- /dev/null
+++ b/sysutils/qzeitgeist/Makefile
@@ -0,0 +1,41 @@
+# New ports collection makefile for: qzeitgeist
+# Date Created: 20 April 2011
+# Whom: avilla@FreeBSD.org
+#
+# $FreeBSD$
+#
+
+PORTNAME= qzeitgeist
+PORTVERSION= 0.7.0
+CATEGORIES= sysutils
+MASTER_SITES= http://releases.zeitgeist-project.com/${PORTNAME}/
+DISTNAME= QtZeitgeist-${PORTVERSION}
+
+MAINTAINER= avilla@FreeBSD.org
+COMMENT= Qt 4 wrapper library around the Zeitgeist DBus API
+
+LICENSE= LGPL21
+LICENSE_FILE= ${WRKSRC}/COPYING
+
+USE_BZIP2= yes
+USE_QT_VER= 4
+QT_COMPONENTS= corelib dbus qtestlib \
+ moc_build qmake_build rcc_build uic_build
+MAKE_JOBS_SAFE= yes
+USE_CMAKE= yes
+USE_LDCONFIG= yes
+
+WRKSRC= ${WRKDIR}/${DISTNAME}-Source
+
+post-patch:
+ ${REINPLACE_CMD} -e '/\.pc/ s|pkgconfig|../libdata/pkgconfig|' \
+ -e 's|share/${PORTNAME}/cmake|lib/cmake/${PORTNAME}|' \
+ -e "/add_subdirectory(tests)/ d" \
+ ${WRKSRC}/CMakeLists.txt \
+ ${WRKSRC}/src/CMakeLists.txt \
+ ${WRKSRC}/QZeitgeistConfig.cmake.in
+
+post-install:
+ ${CAT} ${PKGMESSAGE}
+
+.include <bsd.port.mk>