aboutsummaryrefslogtreecommitdiff
path: root/sysutils/racktables
diff options
context:
space:
mode:
authorRyan Steinmetz <zi@FreeBSD.org>2013-04-26 18:58:58 +0000
committerRyan Steinmetz <zi@FreeBSD.org>2013-04-26 18:58:58 +0000
commite13938999a34810f7d1b41b65366894bd1129a98 (patch)
treee09e031e59af7ef3565b1ac9abff2d71df235a21 /sysutils/racktables
parent9541e2a6ef4255d2c644c1dd3d07fa6776d64a40 (diff)
downloadports-e13938999a34810f7d1b41b65366894bd1129a98.tar.gz
ports-e13938999a34810f7d1b41b65366894bd1129a98.zip
New port: sysutils/racktables:
Racktables is a nifty and robust solution for datacenter and server room asset management. It helps document hardware assets, network addresses, space in racks, networks configuration and much much more! WWW: http://www.racktables.org/ Feature safe: yes
Notes
Notes: svn path=/head/; revision=316630
Diffstat (limited to 'sysutils/racktables')
-rw-r--r--sysutils/racktables/Makefile74
-rw-r--r--sysutils/racktables/distinfo2
-rw-r--r--sysutils/racktables/files/pkg-message.in16
-rw-r--r--sysutils/racktables/pkg-descr5
-rw-r--r--sysutils/racktables/pkg-plist212
5 files changed, 309 insertions, 0 deletions
diff --git a/sysutils/racktables/Makefile b/sysutils/racktables/Makefile
new file mode 100644
index 000000000000..b82cb1fa204d
--- /dev/null
+++ b/sysutils/racktables/Makefile
@@ -0,0 +1,74 @@
+# Created by: Ryan Steinmetz <zi@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= racktables
+DISTVERSION= 0.20.4
+CATEGORIES?= sysutils www
+MASTER_SITES= SF/${PORTNAME}/
+DISTNAME= RackTables-${DISTVERSION}
+
+MAINTAINER= zi@FreeBSD.org
+COMMENT= Server room asset management suite
+
+LICENSE= GPLv2
+
+NO_BUILD= yes
+RACKHOME?= www/racktables
+
+PORTEXAMPLES= init-sample-racks.sql syncdomain.php
+
+WANT_PHP_WEB= yes
+USE_PHP= bcmath gd json mbstring mysql pdo_mysql session
+IGNORE_WITH_PHP=4
+SUB_FILES= pkg-message
+PLIST_SUB= WWWDIR_REL=${WWWDIR_REL} WWWDIR=${WWWDIR}
+WWWUSER?= www
+WWWGRP?= www
+
+OPTIONS_DEFINE= LDAP SNMP CURL LANG PCNTL PCRE
+PCRE_DESC= Regular Expression Support
+PCNTL_DESC= pcntl Support
+LANG_DESC= Additional Language Support
+
+.include <bsd.port.options.mk>
+
+.if ${PORT_OPTIONS:MLDAP}
+USE_PHP+= ldap
+.endif
+
+.if ${PORT_OPTIONS:MSNMP}
+USE_PHP+= snmp
+.endif
+
+.if ${PORT_OPTIONS:MCURL}
+USE_PHP+= curl
+.endif
+
+.if ${PORT_OPTIONS:MLANG}
+USE_PHP+= lang
+.endif
+
+.if ${PORT_OPTIONS:MPCNTL}
+USE_PHP+= pcntl
+.endif
+
+.if ${PORT_OPTIONS:MPCRE}
+USE_PHP+= pcre
+.endif
+
+post-patch:
+ @${FIND} ${WRKSRC} -name \*.orig -type f -delete
+
+do-install:
+ ${MKDIR} ${WWWDIR}/wwwroot ${WWWDIR}/gateways
+ (cd ${WRKSRC} && ${COPYTREE_SHARE} wwwroot ${WWWDIR})
+ (cd ${WRKSRC} && ${COPYTREE_BIN} gateways ${WWWDIR})
+.if ${PORT_OPTIONS:MEXAMPLES}
+ @${MKDIR} ${EXAMPLESDIR}
+ ${INSTALL_DATA} ${WRKSRC}/scripts/* ${EXAMPLESDIR}
+.endif
+
+post-install:
+ @${CAT} ${PKGMESSAGE}
+
+.include <bsd.port.mk>
diff --git a/sysutils/racktables/distinfo b/sysutils/racktables/distinfo
new file mode 100644
index 000000000000..5bde08e5684b
--- /dev/null
+++ b/sysutils/racktables/distinfo
@@ -0,0 +1,2 @@
+SHA256 (RackTables-0.20.4.tar.gz) = 173a164f4a922631c9155d661b921dd1240fe59971c262a1080a316546677cdd
+SIZE (RackTables-0.20.4.tar.gz) = 792147
diff --git a/sysutils/racktables/files/pkg-message.in b/sysutils/racktables/files/pkg-message.in
new file mode 100644
index 000000000000..c9fe9e5c0cdf
--- /dev/null
+++ b/sysutils/racktables/files/pkg-message.in
@@ -0,0 +1,16 @@
+---------------------------------------------------------------------
+Apache users should create a racktables.conf file under their apache
+Includes directory with the following contents:
+<Directory %%WWWDIR%%/wwwroot>
+ Order allow,deny
+ Allow from all
+</Directory>
+Alias /racktables %%WWWDIR%%/wwwroot
+
+You will need to make sure you have a MySQL server available, or
+you must install one from the ports tree if you wish to run one
+locally.
+
+Then, visit http://your.system/racktables/ and follow the
+instructions to complete the setup.
+---------------------------------------------------------------------
diff --git a/sysutils/racktables/pkg-descr b/sysutils/racktables/pkg-descr
new file mode 100644
index 000000000000..541eed4eeede
--- /dev/null
+++ b/sysutils/racktables/pkg-descr
@@ -0,0 +1,5 @@
+Racktables is a nifty and robust solution for datacenter and server room asset
+management. It helps document hardware assets, network addresses, space in
+racks, networks configuration and much much more!
+
+WWW: http://www.racktables.org/
diff --git a/sysutils/racktables/pkg-plist b/sysutils/racktables/pkg-plist
new file mode 100644
index 000000000000..4242d3cd6ff9
--- /dev/null
+++ b/sysutils/racktables/pkg-plist
@@ -0,0 +1,212 @@
+@comment $FreeBSD$
+%%WWWDIR_REL%%/gateways/netcat
+%%WWWDIR_REL%%/gateways/ssh
+%%WWWDIR_REL%%/gateways/sshnokey
+%%WWWDIR_REL%%/gateways/telnet
+%%WWWDIR_REL%%/gateways/ucssdk
+%%WWWDIR_REL%%/wwwroot/css/jquery-ui-1.8.22.redmond.css
+%%WWWDIR_REL%%/wwwroot/css/jquery.contextmenu.css
+%%WWWDIR_REL%%/wwwroot/css/pi.css
+%%WWWDIR_REL%%/wwwroot/inc/ajax-interface.php
+%%WWWDIR_REL%%/wwwroot/inc/auth.php
+%%WWWDIR_REL%%/wwwroot/inc/caching.php
+%%WWWDIR_REL%%/wwwroot/inc/code.php
+%%WWWDIR_REL%%/wwwroot/inc/config.php
+%%WWWDIR_REL%%/wwwroot/inc/database.php
+%%WWWDIR_REL%%/wwwroot/inc/deviceconfig.php
+%%WWWDIR_REL%%/wwwroot/inc/dictionary.php
+%%WWWDIR_REL%%/wwwroot/inc/exceptions.php
+%%WWWDIR_REL%%/wwwroot/inc/functions.php
+%%WWWDIR_REL%%/wwwroot/inc/init.php
+%%WWWDIR_REL%%/wwwroot/inc/install.php
+%%WWWDIR_REL%%/wwwroot/inc/interface-lib.php
+%%WWWDIR_REL%%/wwwroot/inc/interface.php
+%%WWWDIR_REL%%/wwwroot/inc/navigation.php
+%%WWWDIR_REL%%/wwwroot/inc/ophandlers.php
+%%WWWDIR_REL%%/wwwroot/inc/popup.php
+%%WWWDIR_REL%%/wwwroot/inc/pre-init.php
+%%WWWDIR_REL%%/wwwroot/inc/remote.php
+%%WWWDIR_REL%%/wwwroot/inc/slb-interface.php
+%%WWWDIR_REL%%/wwwroot/inc/slb.php
+%%WWWDIR_REL%%/wwwroot/inc/snmp.php
+%%WWWDIR_REL%%/wwwroot/inc/solutions.php
+%%WWWDIR_REL%%/wwwroot/inc/triggers.php
+%%WWWDIR_REL%%/wwwroot/inc/upgrade.php
+%%WWWDIR_REL%%/wwwroot/index.php
+%%WWWDIR_REL%%/wwwroot/js/codepress/codepress.css
+%%WWWDIR_REL%%/wwwroot/js/codepress/codepress.html
+%%WWWDIR_REL%%/wwwroot/js/codepress/codepress.js
+%%WWWDIR_REL%%/wwwroot/js/codepress/engines/gecko.js
+%%WWWDIR_REL%%/wwwroot/js/codepress/engines/khtml.js
+%%WWWDIR_REL%%/wwwroot/js/codepress/engines/msie.js
+%%WWWDIR_REL%%/wwwroot/js/codepress/engines/older.js
+%%WWWDIR_REL%%/wwwroot/js/codepress/engines/opera.js
+%%WWWDIR_REL%%/wwwroot/js/codepress/images/line-numbers.png
+%%WWWDIR_REL%%/wwwroot/js/codepress/languages/asp.css
+%%WWWDIR_REL%%/wwwroot/js/codepress/languages/asp.js
+%%WWWDIR_REL%%/wwwroot/js/codepress/languages/autoit.css
+%%WWWDIR_REL%%/wwwroot/js/codepress/languages/autoit.js
+%%WWWDIR_REL%%/wwwroot/js/codepress/languages/csharp.css
+%%WWWDIR_REL%%/wwwroot/js/codepress/languages/csharp.js
+%%WWWDIR_REL%%/wwwroot/js/codepress/languages/css.css
+%%WWWDIR_REL%%/wwwroot/js/codepress/languages/css.js
+%%WWWDIR_REL%%/wwwroot/js/codepress/languages/generic.css
+%%WWWDIR_REL%%/wwwroot/js/codepress/languages/generic.js
+%%WWWDIR_REL%%/wwwroot/js/codepress/languages/html.css
+%%WWWDIR_REL%%/wwwroot/js/codepress/languages/html.js
+%%WWWDIR_REL%%/wwwroot/js/codepress/languages/ipfw.css
+%%WWWDIR_REL%%/wwwroot/js/codepress/languages/ipfw.js
+%%WWWDIR_REL%%/wwwroot/js/codepress/languages/java.css
+%%WWWDIR_REL%%/wwwroot/js/codepress/languages/java.js
+%%WWWDIR_REL%%/wwwroot/js/codepress/languages/javascript.css
+%%WWWDIR_REL%%/wwwroot/js/codepress/languages/javascript.js
+%%WWWDIR_REL%%/wwwroot/js/codepress/languages/perl.css
+%%WWWDIR_REL%%/wwwroot/js/codepress/languages/perl.js
+%%WWWDIR_REL%%/wwwroot/js/codepress/languages/php.css
+%%WWWDIR_REL%%/wwwroot/js/codepress/languages/php.js
+%%WWWDIR_REL%%/wwwroot/js/codepress/languages/rackcode.css
+%%WWWDIR_REL%%/wwwroot/js/codepress/languages/rackcode.js
+%%WWWDIR_REL%%/wwwroot/js/codepress/languages/ruby.css
+%%WWWDIR_REL%%/wwwroot/js/codepress/languages/ruby.js
+%%WWWDIR_REL%%/wwwroot/js/codepress/languages/sql.css
+%%WWWDIR_REL%%/wwwroot/js/codepress/languages/sql.js
+%%WWWDIR_REL%%/wwwroot/js/codepress/languages/text.css
+%%WWWDIR_REL%%/wwwroot/js/codepress/languages/text.js
+%%WWWDIR_REL%%/wwwroot/js/codepress/languages/vbscript.css
+%%WWWDIR_REL%%/wwwroot/js/codepress/languages/vbscript.js
+%%WWWDIR_REL%%/wwwroot/js/codepress/languages/xsl.css
+%%WWWDIR_REL%%/wwwroot/js/codepress/languages/xsl.js
+%%WWWDIR_REL%%/wwwroot/js/inplace-edit.js
+%%WWWDIR_REL%%/wwwroot/js/jquery-1.4.4.min.js
+%%WWWDIR_REL%%/wwwroot/js/jquery-ui-1.8.21.min.js
+%%WWWDIR_REL%%/wwwroot/js/jquery.contextmenu.js
+%%WWWDIR_REL%%/wwwroot/js/jquery.optionTree.js
+%%WWWDIR_REL%%/wwwroot/js/jquery.thumbhover.js
+%%WWWDIR_REL%%/wwwroot/js/live_validation.js
+%%WWWDIR_REL%%/wwwroot/js/net-usage.js
+%%WWWDIR_REL%%/wwwroot/js/portinfo.js
+%%WWWDIR_REL%%/wwwroot/js/racktables.js
+%%WWWDIR_REL%%/wwwroot/js/tag-cb.js
+%%WWWDIR_REL%%/wwwroot/js/vst_editor.js
+%%WWWDIR_REL%%/wwwroot/pix/1x1t.gif
+%%WWWDIR_REL%%/wwwroot/pix/8021q.png
+%%WWWDIR_REL%%/wwwroot/pix/addressspace.png
+%%WWWDIR_REL%%/wwwroot/pix/addressspacev6.png
+%%WWWDIR_REL%%/wwwroot/pix/ajax-loader.gif
+%%WWWDIR_REL%%/wwwroot/pix/bg_selection.gif
+%%WWWDIR_REL%%/wwwroot/pix/bracket-16x16.png
+%%WWWDIR_REL%%/wwwroot/pix/bracket-32x32.png
+%%WWWDIR_REL%%/wwwroot/pix/checkbox_yes.png
+%%WWWDIR_REL%%/wwwroot/pix/configuration.png
+%%WWWDIR_REL%%/wwwroot/pix/crystal-actions-unlock-32x32.png
+%%WWWDIR_REL%%/wwwroot/pix/crystal-edit-user-32x32.png
+%%WWWDIR_REL%%/wwwroot/pix/crystal-file-empty-32x32.png
+%%WWWDIR_REL%%/wwwroot/pix/crystal-file-image-32x32.png
+%%WWWDIR_REL%%/wwwroot/pix/crystal-file-text-32x32.png
+%%WWWDIR_REL%%/wwwroot/pix/crystal-mimetypes-shellscript-218x200.png
+%%WWWDIR_REL%%/wwwroot/pix/crystal-network_local-16x16.png
+%%WWWDIR_REL%%/wwwroot/pix/crystal-network_local-32x32.png
+%%WWWDIR_REL%%/wwwroot/pix/crystal-ok-32x32.png
+%%WWWDIR_REL%%/wwwroot/pix/download-big.png
+%%WWWDIR_REL%%/wwwroot/pix/download.png
+%%WWWDIR_REL%%/wwwroot/pix/favicon.ico
+%%WWWDIR_REL%%/wwwroot/pix/files.png
+%%WWWDIR_REL%%/wwwroot/pix/jquery-ui-1.8.22.redmond/ui-bg_flat_0_aaaaaa_40x100.png
+%%WWWDIR_REL%%/wwwroot/pix/jquery-ui-1.8.22.redmond/ui-bg_flat_55_fbec88_40x100.png
+%%WWWDIR_REL%%/wwwroot/pix/jquery-ui-1.8.22.redmond/ui-bg_glass_75_d0e5f5_1x400.png
+%%WWWDIR_REL%%/wwwroot/pix/jquery-ui-1.8.22.redmond/ui-bg_glass_85_dfeffc_1x400.png
+%%WWWDIR_REL%%/wwwroot/pix/jquery-ui-1.8.22.redmond/ui-bg_glass_95_fef1ec_1x400.png
+%%WWWDIR_REL%%/wwwroot/pix/jquery-ui-1.8.22.redmond/ui-bg_gloss-wave_55_5c9ccc_500x100.png
+%%WWWDIR_REL%%/wwwroot/pix/jquery-ui-1.8.22.redmond/ui-bg_inset-hard_100_f5f8f9_1x100.png
+%%WWWDIR_REL%%/wwwroot/pix/jquery-ui-1.8.22.redmond/ui-bg_inset-hard_100_fcfdfd_1x100.png
+%%WWWDIR_REL%%/wwwroot/pix/jquery-ui-1.8.22.redmond/ui-icons_217bc0_256x240.png
+%%WWWDIR_REL%%/wwwroot/pix/jquery-ui-1.8.22.redmond/ui-icons_2e83ff_256x240.png
+%%WWWDIR_REL%%/wwwroot/pix/jquery-ui-1.8.22.redmond/ui-icons_469bdd_256x240.png
+%%WWWDIR_REL%%/wwwroot/pix/jquery-ui-1.8.22.redmond/ui-icons_6da8d5_256x240.png
+%%WWWDIR_REL%%/wwwroot/pix/jquery-ui-1.8.22.redmond/ui-icons_cd0a0a_256x240.png
+%%WWWDIR_REL%%/wwwroot/pix/jquery-ui-1.8.22.redmond/ui-icons_d8e7f3_256x240.png
+%%WWWDIR_REL%%/wwwroot/pix/jquery-ui-1.8.22.redmond/ui-icons_f9bd01_256x240.png
+%%WWWDIR_REL%%/wwwroot/pix/kterm-16x16.png
+%%WWWDIR_REL%%/wwwroot/pix/link-disabled.png
+%%WWWDIR_REL%%/wwwroot/pix/link-down.png
+%%WWWDIR_REL%%/wwwroot/pix/link-up.png
+%%WWWDIR_REL%%/wwwroot/pix/loadbalancer.png
+%%WWWDIR_REL%%/wwwroot/pix/mitsudragon.png
+%%WWWDIR_REL%%/wwwroot/pix/node-collapsed.png
+%%WWWDIR_REL%%/wwwroot/pix/node-expanded-static.png
+%%WWWDIR_REL%%/wwwroot/pix/node-expanded.png
+%%WWWDIR_REL%%/wwwroot/pix/pencil-icon.png
+%%WWWDIR_REL%%/wwwroot/pix/pgadmin3-viewdata-grayscale.png
+%%WWWDIR_REL%%/wwwroot/pix/pgadmin3-viewdata.png
+%%WWWDIR_REL%%/wwwroot/pix/pgadmin3-viewfiltereddata-grayscale.png
+%%WWWDIR_REL%%/wwwroot/pix/pgadmin3-viewfiltereddata.png
+%%WWWDIR_REL%%/wwwroot/pix/racks.png
+%%WWWDIR_REL%%/wwwroot/pix/report.png
+%%WWWDIR_REL%%/wwwroot/pix/router.png
+%%WWWDIR_REL%%/wwwroot/pix/server.png
+%%WWWDIR_REL%%/wwwroot/pix/serverpool.png
+%%WWWDIR_REL%%/wwwroot/pix/servicesign.png
+%%WWWDIR_REL%%/wwwroot/pix/slb.png
+%%WWWDIR_REL%%/wwwroot/pix/smiley_knight.png
+%%WWWDIR_REL%%/wwwroot/pix/tango-appointment-32x32.png
+%%WWWDIR_REL%%/wwwroot/pix/tango-computer.png
+%%WWWDIR_REL%%/wwwroot/pix/tango-dialog-error-big.png
+%%WWWDIR_REL%%/wwwroot/pix/tango-dialog-error.png
+%%WWWDIR_REL%%/wwwroot/pix/tango-document-new-big.png
+%%WWWDIR_REL%%/wwwroot/pix/tango-document-new.png
+%%WWWDIR_REL%%/wwwroot/pix/tango-document-save-16x16.png
+%%WWWDIR_REL%%/wwwroot/pix/tango-document-save-32x32-gray.png
+%%WWWDIR_REL%%/wwwroot/pix/tango-document-save-32x32.png
+%%WWWDIR_REL%%/wwwroot/pix/tango-edit-clear-big.png
+%%WWWDIR_REL%%/wwwroot/pix/tango-edit-clear-gray-32x32.png
+%%WWWDIR_REL%%/wwwroot/pix/tango-edit-clear.png
+%%WWWDIR_REL%%/wwwroot/pix/tango-edit-copy-16x16.png
+%%WWWDIR_REL%%/wwwroot/pix/tango-edit-copy-32x32.png
+%%WWWDIR_REL%%/wwwroot/pix/tango-edit-cut-16x16.png
+%%WWWDIR_REL%%/wwwroot/pix/tango-edit-cut-22x22-gray.png
+%%WWWDIR_REL%%/wwwroot/pix/tango-edit-cut-22x22.png
+%%WWWDIR_REL%%/wwwroot/pix/tango-edit-cut-32x32.png
+%%WWWDIR_REL%%/wwwroot/pix/tango-emblem-favorite.png
+%%WWWDIR_REL%%/wwwroot/pix/tango-emblem-important-32x32.png
+%%WWWDIR_REL%%/wwwroot/pix/tango-emblem-readonly-32x32.png
+%%WWWDIR_REL%%/wwwroot/pix/tango-emblem-system-32x32.png
+%%WWWDIR_REL%%/wwwroot/pix/tango-emblem-system.png
+%%WWWDIR_REL%%/wwwroot/pix/tango-emblem-unreadable-32x32.png
+%%WWWDIR_REL%%/wwwroot/pix/tango-go-next.png
+%%WWWDIR_REL%%/wwwroot/pix/tango-go-prev-next-32x32.png
+%%WWWDIR_REL%%/wwwroot/pix/tango-go-prev-next-gray-32x32.png
+%%WWWDIR_REL%%/wwwroot/pix/tango-go-previous.png
+%%WWWDIR_REL%%/wwwroot/pix/tango-internet-32x32.png
+%%WWWDIR_REL%%/wwwroot/pix/tango-list-add-big.png
+%%WWWDIR_REL%%/wwwroot/pix/tango-list-add.png
+%%WWWDIR_REL%%/wwwroot/pix/tango-list-remove-32x32.png
+%%WWWDIR_REL%%/wwwroot/pix/tango-list-remove-shadow.png
+%%WWWDIR_REL%%/wwwroot/pix/tango-list-remove.png
+%%WWWDIR_REL%%/wwwroot/pix/tango-mail-attachment-16x16.png
+%%WWWDIR_REL%%/wwwroot/pix/tango-mail-attachment-22x22.png
+%%WWWDIR_REL%%/wwwroot/pix/tango-mail-attachment-32x32.png
+%%WWWDIR_REL%%/wwwroot/pix/tango-network-wired.png
+%%WWWDIR_REL%%/wwwroot/pix/tango-system-search-22x22.png
+%%WWWDIR_REL%%/wwwroot/pix/tango-system-search.png
+%%WWWDIR_REL%%/wwwroot/pix/tango-text-html.png
+%%WWWDIR_REL%%/wwwroot/pix/tango-text-x-generic-16x16.png
+%%WWWDIR_REL%%/wwwroot/pix/tango-user-trash-16x16-gray.png
+%%WWWDIR_REL%%/wwwroot/pix/tango-user-trash-16x16.png
+%%WWWDIR_REL%%/wwwroot/pix/tango-user-trash-32x32-gray.png
+%%WWWDIR_REL%%/wwwroot/pix/tango-user-trash-32x32.png
+%%WWWDIR_REL%%/wwwroot/pix/tango-view-fullscreen-22x22.png
+%%WWWDIR_REL%%/wwwroot/pix/tango-view-refresh-32x32.png
+%%WWWDIR_REL%%/wwwroot/pix/virtualresources.png
+@dirrm %%WWWDIR_REL%%/wwwroot/css
+@dirrm %%WWWDIR_REL%%/wwwroot/inc
+@dirrm %%WWWDIR_REL%%/wwwroot/js/codepress/engines
+@dirrm %%WWWDIR_REL%%/wwwroot/js/codepress/images
+@dirrm %%WWWDIR_REL%%/wwwroot/js/codepress/languages
+@dirrm %%WWWDIR_REL%%/wwwroot/js/codepress
+@dirrm %%WWWDIR_REL%%/wwwroot/js
+@dirrm %%WWWDIR_REL%%/wwwroot/pix/jquery-ui-1.8.22.redmond
+@dirrm %%WWWDIR_REL%%/wwwroot/pix
+@dirrmtry %%WWWDIR_REL%%/gateways
+@dirrmtry %%WWWDIR_REL%%/wwwroot
+@dirrmtry %%WWWDIR_REL%%
+@unexec if [ -d %D/%%WWWDIR_REL%% ]; then echo "==> If you are permanently removing this port, you should do a ``rm -rf %%WWWDIR%%/`` to remove any configuration files left."; fi