aboutsummaryrefslogtreecommitdiff
path: root/sysutils/raincoat
diff options
context:
space:
mode:
authorEmanuel Haupt <ehaupt@FreeBSD.org>2005-10-19 08:49:26 +0000
committerEmanuel Haupt <ehaupt@FreeBSD.org>2005-10-19 08:49:26 +0000
commit2d89e47cba24992a549e8ae9cbefde10c0fca2d3 (patch)
tree724af474adca5ed2db20fa564e8383584eb7321a /sysutils/raincoat
parenta4a900e6c479b6a1b89692786a3003ae04868921 (diff)
downloadports-2d89e47cba24992a549e8ae9cbefde10c0fca2d3.tar.gz
ports-2d89e47cba24992a549e8ae9cbefde10c0fca2d3.zip
. update to 0.11
. provide PORTDOCS . nuke files/patch-Makefile . preserve changed config files . move patching from pre-configure to post-patch . fully respect CFLAGS PR: 87609 Submitted by: Ed Schouten <ed@fxq.nl> (maintainer) Reworked by: ehaupt
Notes
Notes: svn path=/head/; revision=145836
Diffstat (limited to 'sysutils/raincoat')
-rw-r--r--sysutils/raincoat/Makefile28
-rw-r--r--sysutils/raincoat/distinfo4
-rw-r--r--sysutils/raincoat/files/patch-Makefile15
-rw-r--r--sysutils/raincoat/pkg-plist4
4 files changed, 26 insertions, 25 deletions
diff --git a/sysutils/raincoat/Makefile b/sysutils/raincoat/Makefile
index 116836b71d0e..6205f3ac5fd7 100644
--- a/sysutils/raincoat/Makefile
+++ b/sysutils/raincoat/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= raincoat
-PORTVERSION= 0.10
+PORTVERSION= 0.11
CATEGORIES= sysutils
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= xbox-linux
@@ -21,16 +21,28 @@ ONLY_FOR_ARCHS= i386
USE_REINPLACE= yes
USE_BZIP2= yes
-PLIST_FILES= sbin/raincoat \
- etc/raincoat.conf
+PORTDOCS= README
-pre-configure:
- @${REINPLACE_CMD} -e 's|\/etc\/raincoat\.conf|${PREFIX}&|g' \
- ${WRKSRC}/src/raincoat.c
+post-patch:
+.for f in docs/README src/${PORTNAME}.c
+ @${REINPLACE_CMD} -e 's|/etc/raincoat\.conf|${PREFIX}&|g' \
+ ${WRKSRC}/${f}
+.endfor
+
+do-build:
+ ${CC} ${CFLAGS} -o ${WRKSRC}/${PORTNAME} ${WRKSRC}/src/${PORTNAME}.c ${WRKSRC}/src/BootFlash.c
do-install:
- ${INSTALL_PROGRAM} ${WRKSRC}/bin/raincoat ${PREFIX}/sbin/raincoat
- ${INSTALL_DATA} ${WRKSRC}/etc/raincoat.conf ${PREFIX}/etc/raincoat.conf
+ ${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${PREFIX}/sbin
+ ${INSTALL_DATA} ${WRKSRC}/etc/${PORTNAME}.conf ${PREFIX}/etc/${PORTNAME}.conf.default
+.if !exists(${PREFIX}/etc/${PORTNAME}.conf)
+ ${INSTALL_DATA} ${WRKSRC}/etc/${PORTNAME}.conf ${PREFIX}/etc
+.endif
+
+.if !defined (NOPORTDOCS)
+ @${MKDIR} ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/docs/${PORTDOCS} ${DOCSDIR}
+.endif
.include <bsd.port.pre.mk>
diff --git a/sysutils/raincoat/distinfo b/sysutils/raincoat/distinfo
index 5ea1011c5def..ed1c0afd6b39 100644
--- a/sysutils/raincoat/distinfo
+++ b/sysutils/raincoat/distinfo
@@ -1,2 +1,2 @@
-MD5 (raincoat-0.10.tbz2) = 483c2d798ed62569230acfa65cd681d4
-SIZE (raincoat-0.10.tbz2) = 239184
+MD5 (raincoat-0.11.tbz2) = 533cd38ea59c38d1b6c9e18be9970f90
+SIZE (raincoat-0.11.tbz2) = 240759
diff --git a/sysutils/raincoat/files/patch-Makefile b/sysutils/raincoat/files/patch-Makefile
deleted file mode 100644
index bb09a0d37647..000000000000
--- a/sysutils/raincoat/files/patch-Makefile
+++ /dev/null
@@ -1,15 +0,0 @@
---- Makefile.orig Fri Sep 30 15:17:52 2005
-+++ Makefile Fri Sep 30 15:18:47 2005
-@@ -1,8 +1,11 @@
-+CC?= cc
-+CFLAGS?= -O -pipe
-+
- all: raincoat
-
- raincoat: src/raincoat.c src/BootFlash.c src/boot.h src/BootFlash.h
- mkdir -p bin
-- gcc -static -O2 -Wall -Werror -o ./bin/raincoat src/raincoat.c src/BootFlash.c
-+ $(CC) -static -Wall -Werror $(CFLAGS) -o ./bin/raincoat src/raincoat.c src/BootFlash.c
-
- clean:
- rm -f src/*.o
diff --git a/sysutils/raincoat/pkg-plist b/sysutils/raincoat/pkg-plist
new file mode 100644
index 000000000000..9fedfc8ed484
--- /dev/null
+++ b/sysutils/raincoat/pkg-plist
@@ -0,0 +1,4 @@
+sbin/raincoat
+@unexec if cmp -s %D/etc/raincoat.conf %D/etc/raincoat.conf.default; then rm -f %D/etc/raincoat.conf; fi
+etc/raincoat.conf.default
+@exec [ -f %B/raincoat.conf ] || cp %B/%f %B/raincoat.conf