aboutsummaryrefslogtreecommitdiff
path: root/sysutils/restic
diff options
context:
space:
mode:
authorWilliam Grzybowski <wg@FreeBSD.org>2015-09-24 15:57:52 +0000
committerWilliam Grzybowski <wg@FreeBSD.org>2015-09-24 15:57:52 +0000
commitb59738ff84337f28c8915798f1316992c4d976f7 (patch)
tree41f83415a1a0356ac774fecce688128999dce822 /sysutils/restic
parent6de0d3925bd4ade88bb5f1c57ee3a6d54d0c2358 (diff)
downloadports-b59738ff84337f28c8915798f1316992c4d976f7.tar.gz
ports-b59738ff84337f28c8915798f1316992c4d976f7.zip
sysutils/restic: Restic backup program
Restic is a program that does backups right and was designed to be easy, fast verifiable, secure and efficient. WWW: https://restic.github.io
Notes
Notes: svn path=/head/; revision=397694
Diffstat (limited to 'sysutils/restic')
-rw-r--r--sysutils/restic/Makefile38
-rw-r--r--sysutils/restic/distinfo8
-rw-r--r--sysutils/restic/pkg-descr4
-rw-r--r--sysutils/restic/pkg-plist1
4 files changed, 51 insertions, 0 deletions
diff --git a/sysutils/restic/Makefile b/sysutils/restic/Makefile
new file mode 100644
index 000000000000..00d8588414a8
--- /dev/null
+++ b/sysutils/restic/Makefile
@@ -0,0 +1,38 @@
+# $FreeBSD$
+
+PORTNAME= restic
+PORTVERSION= 0.1.0
+DISTVERSIONPREFIX= v
+CATEGORIES= sysutils
+
+MAINTAINER= wg@FreeBSD.org
+COMMENT= Restic backup program
+
+BUILD_DEPENDS= ${LOCALBASE}/bin/go:${PORTSDIR}/lang/go
+
+USE_GITHUB= yes
+GH_ACCOUNT= restic:DEFAULT,chunker juju:errors golang:crypto
+GH_PROJECT= chunker:chunker errors:errors crypto:crypto
+GH_TAGNAME= 16a28ff:chunker 1b5e39b:errors 74f810a:crypto
+
+STRIP= # stripping can break go binaries
+
+post-extract:
+ @${MKDIR} ${WRKSRC}/src/github.com/${GH_ACCOUNT}/${PORTNAME}
+.for src in CONTRIBUTING.md Godeps LICENSE Makefile README.md VERSION Vagrantfile appveyor.yml archiver.go archiver_int_test.go archiver_test.go backend build.go cache.go cache_test.go checker cmd crypto debug doc doc.go filter fuse lock.go lock_test.go lock_unix.go lock_windows.go node.go node_darwin.go node_freebsd.go node_linux.go node_openbsd.go node_test.go node_unix.go node_windows.go pack pipe progress.go repository restorer.go run_integration_tests.go run_tests.go snapshot.go snapshot_test.go test tree.go tree_test.go walk.go walk_test.go
+ @${MV} ${WRKSRC}/${src} \
+ ${WRKSRC}/src/github.com/restic/${PORTNAME}
+.endfor
+ @${MKDIR} ${WRKSRC}/src/github.com/juju
+ @${MKDIR} ${WRKSRC}/src/golang.org/x
+ @${MV} ${WRKSRC_chunker} ${WRKSRC}/src/github.com/restic/chunker
+ @${MV} ${WRKSRC_errors} ${WRKSRC}/src/github.com/juju/errors
+ @${MV} ${WRKSRC_crypto} ${WRKSRC}/src/golang.org/x/crypto
+
+do-build:
+ @cd ${WRKSRC}/src/github.com/${GH_ACCOUNT}/${PORTNAME}; ${SETENV} GOPATH=${WRKSRC} go build -o bin/${PORTNAME}
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/src/github.com/${GH_ACCOUNT}/${PORTNAME}/bin/${PORTNAME} ${STAGEDIR}${PREFIX}/bin/${PORTNAME}
+
+.include <bsd.port.mk>
diff --git a/sysutils/restic/distinfo b/sysutils/restic/distinfo
new file mode 100644
index 000000000000..060878467313
--- /dev/null
+++ b/sysutils/restic/distinfo
@@ -0,0 +1,8 @@
+SHA256 (restic-restic-v0.1.0_GH0.tar.gz) = df7842cb690a56ce5371013a958d9f324072429897511d4bbfc092d76303f198
+SIZE (restic-restic-v0.1.0_GH0.tar.gz) = 13368404
+SHA256 (restic-chunker-16a28ff_GH0.tar.gz) = e5028b6fbc39997cf8ac6ba81025681228ddb1d80558a9acd6c2f10a0051c3cc
+SIZE (restic-chunker-16a28ff_GH0.tar.gz) = 12241
+SHA256 (juju-errors-1b5e39b_GH0.tar.gz) = bf7ec9986aa03ad916f88e96c3860b8c7fb2705ed760f72f4149a6fc2341d53d
+SIZE (juju-errors-1b5e39b_GH0.tar.gz) = 15611
+SHA256 (golang-crypto-74f810a_GH0.tar.gz) = 25e0c9cb7c6d6a5935aa318c9792fa6e18c8e0238994b5be039f90c8d58fd680
+SIZE (golang-crypto-74f810a_GH0.tar.gz) = 864642
diff --git a/sysutils/restic/pkg-descr b/sysutils/restic/pkg-descr
new file mode 100644
index 000000000000..9a06d7095b31
--- /dev/null
+++ b/sysutils/restic/pkg-descr
@@ -0,0 +1,4 @@
+Restic is a program that does backups right and was designed to be easy, fast
+verifiable, secure and efficient.
+
+WWW: https://restic.github.io
diff --git a/sysutils/restic/pkg-plist b/sysutils/restic/pkg-plist
new file mode 100644
index 000000000000..da18e2639363
--- /dev/null
+++ b/sysutils/restic/pkg-plist
@@ -0,0 +1 @@
+bin/restic