aboutsummaryrefslogtreecommitdiff
path: root/sysutils/samesame
diff options
context:
space:
mode:
authorDennis Herrmann <dhn@FreeBSD.org>2009-05-25 19:56:45 +0000
committerDennis Herrmann <dhn@FreeBSD.org>2009-05-25 19:56:45 +0000
commit6043bde2c6f4cc242715752c30756aa8059681b7 (patch)
treef9c9e01030269efe7cbe632f32c84fc29c830fae /sysutils/samesame
parent74ea540934241ef982353fc4e544c442c996c6a9 (diff)
downloadports-6043bde2c6f4cc242715752c30756aa8059681b7.tar.gz
ports-6043bde2c6f4cc242715752c30756aa8059681b7.zip
- Update to 1.1
PR: ports/134769 Submitted by: Alex de Kruijff <samesame@akruijff.dds.nl> (maintainer)
Notes
Notes: svn path=/head/; revision=234546
Diffstat (limited to 'sysutils/samesame')
-rw-r--r--sysutils/samesame/Makefile40
-rw-r--r--sysutils/samesame/distinfo6
-rw-r--r--sysutils/samesame/files/samesame.sh11
3 files changed, 39 insertions, 18 deletions
diff --git a/sysutils/samesame/Makefile b/sysutils/samesame/Makefile
index 2145655607e1..39eab068228d 100644
--- a/sysutils/samesame/Makefile
+++ b/sysutils/samesame/Makefile
@@ -5,7 +5,7 @@
# $FreeBSD$
PORTNAME= samesame
-PORTVERSION= 1.0
+PORTVERSION= 1.1
CATEGORIES= sysutils
MASTER_SITES= http://www.akruijff.dds.nl/samesame/ \
${MASTER_SITE_LOCAL}
@@ -18,16 +18,22 @@ CONFLICTS= samefile-[0-9]*
MAN1= samearchive.1 samearchive-lite.1 samefile.1 samelink.1
MANCOMPRESSED= yes
-PLIST_FILES= bin/samearchive \
- bin/samearchive-lite \
- bin/samefile \
- bin/samelink
+PLIST_FILES= bin/samearchive bin/samefile \
+ bin/samearchive-lite bin/samelink \
+ etc/rc.d/samesame.sh
USE_BZIP2= yes
OPTIONS= DEBUG "Enables debugging support" Off \
DISK_STORAGE "Allow temporarily storage paths on disk" On \
- LOGIC "Determine results by using logic when posible" On
+ LOGIC "Determine results by using logic when posible" On \
+ TEST "Run quality assurance test" On
+
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} >= 800064
+BROKEN= does not build
+.endif
.if defined(WITH_DEBUG)
CFLAGS+= -DDEBUG
@@ -37,8 +43,8 @@ CFLAGS+= -DDEBUG
CFLAGS+= -DWITH_DISK_STORAGE
.endif
-.if defined(WITH_LOGIC)
-CFLAGS+= -DWITH_LOGIC
+.if defined(WITHOUT_LOGIC)
+CFLAGS+= -DWITHOUT_LOGIC
.endif
CFLAGS+= -DWITH_MMAP
@@ -46,17 +52,21 @@ CFLAGS+= -D'TEMP_STORAGE_DIR=\"/tmp\"'
CFLAGS+= -DPATH_INIT=256
CFLAGS+= -DSTATIC_CACHE_CAPACITY=8192
-post-patch:
- @${REINPLACE_CMD} -e '/^install/s|test-samefile||g' \
- -e '/^install/s|test-samelink||g' \
- -e '/^install/s|test-samearchive-lite||g' \
- -e '/^install/s|test-samearchive||g' ${WRKSRC}/Makefile
+post-build:
+.if defined(WITH_TEST)
+ cd ${WRKSRC}; ${MAKE} test
+.endif
+
+pre-install:
+.if defined(WITH_TEST)
+ cd ${WRKSRC}; ${MAKE} test
+.endif
post-install:
- ${CHMOD} 770 ${WRKSRC}/test*
${STRIP_CMD} ${PREFIX}/bin/samefile
${STRIP_CMD} ${PREFIX}/bin/samelink
${STRIP_CMD} ${PREFIX}/bin/samearchive
${STRIP_CMD} ${PREFIX}/bin/samearchive-lite
+ ${INSTALL_SCRIPT} ${FILESDIR}/samesame.sh ${PREFIX}/etc/rc.d/
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/sysutils/samesame/distinfo b/sysutils/samesame/distinfo
index 5896c6d2a8b8..a9770e850a08 100644
--- a/sysutils/samesame/distinfo
+++ b/sysutils/samesame/distinfo
@@ -1,3 +1,3 @@
-MD5 (samesame-1.0.tar.bz2) = c832d26032bf2eaced10ec04fef7ca68
-SHA256 (samesame-1.0.tar.bz2) = 59c440f12e12e11eefea7e1dc2b95cd70e42473b3b6143cd452bf75ab36805d0
-SIZE (samesame-1.0.tar.bz2) = 37910
+MD5 (samesame-1.1.tar.bz2) = ccf866260bc59df9a663c8746572901a
+SHA256 (samesame-1.1.tar.bz2) = 668e409e114ec524391761307e4a044ec152bf7b1179f54944bf917374344f93
+SIZE (samesame-1.1.tar.bz2) = 41378
diff --git a/sysutils/samesame/files/samesame.sh b/sysutils/samesame/files/samesame.sh
new file mode 100644
index 000000000000..2050899a3eac
--- /dev/null
+++ b/sysutils/samesame/files/samesame.sh
@@ -0,0 +1,11 @@
+#!/bin/sh
+#
+# $FreeBSD$
+#
+
+case "$1" in
+start)
+ rm -rf /tmp/samefile /tmp/samearchive
+ ;;
+esac
+