aboutsummaryrefslogtreecommitdiff
path: root/sysutils/scanbuttond
diff options
context:
space:
mode:
authorRyan Steinmetz <zi@FreeBSD.org>2011-07-28 21:56:21 +0000
committerRyan Steinmetz <zi@FreeBSD.org>2011-07-28 21:56:21 +0000
commit5a296f326acd9886e24bcbc1de2d12b1a0380c6e (patch)
treeed06e5cace2733ae5f1c81ef77659937b2fa78b9 /sysutils/scanbuttond
parent8fb172ad467d479e9099821e7a5d3ed49f669cde (diff)
downloadports-5a296f326acd9886e24bcbc1de2d12b1a0380c6e.tar.gz
ports-5a296f326acd9886e24bcbc1de2d12b1a0380c6e.zip
Do not overwrite user-edited config files in ETCDIR [1]
Bump PORTREVISION Add LICENSE PR: ports/159183 Submitted by: Warren Block <wblock@wonkity.com> [1] Approvd by: tabthorpe (mentor), maintainer
Notes
Notes: svn path=/head/; revision=278501
Diffstat (limited to 'sysutils/scanbuttond')
-rw-r--r--sysutils/scanbuttond/Makefile23
-rw-r--r--sysutils/scanbuttond/pkg-plist12
2 files changed, 30 insertions, 5 deletions
diff --git a/sysutils/scanbuttond/Makefile b/sysutils/scanbuttond/Makefile
index 2c9756938f8c..a9904d97abe4 100644
--- a/sysutils/scanbuttond/Makefile
+++ b/sysutils/scanbuttond/Makefile
@@ -7,15 +7,18 @@
PORTNAME= scanbuttond
PORTVERSION= 0.2.3
+PORTREVISION= 1
CATEGORIES= sysutils
MASTER_SITES= SF
MAINTAINER= dthiele@gmx.net
COMMENT= A daemon to monitor and configure modern scanner's buttons
+LICENSE= GPLv2
+
GNU_CONFIGURE= yes
-CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
- LDFLAGS="-L${LOCALBASE}/lib"
+CPPFLAGS="-I${LOCALBASE}/include"
+LDFLAGS="-L${LOCALBASE}/lib"
USE_LDCONFIG= yes
MAKE_JOBS_SAFE= yes
@@ -30,7 +33,23 @@ LIB_DEPENDS+= usb-0.1.8:${PORTSDIR}/devel/libusb
pre-configure:
@${FIND} ${WRKSRC} -name Makefile.in | ${XARGS} \
${REINPLACE_CMD} -e 's|-ldl||g'
+
+pre-install:
+ @if [ -f ${WRKSRC}/scripts/buttonpressed.sh ]; then \
+ for na in buttonpressed.sh initscanner.sh; do \
+ ${MV} ${WRKSRC}/scripts/$$na ${WRKSRC}/scripts/$$na.sample ; \
+ done; \
+ ${REINPLACE_CMD} -e 's|\.sh|.sh.sample|g' ${WRKSRC}/scripts/Makefile ; \
+ ${MV} ${WRKSRC}/backends/meta.conf ${WRKSRC}/backends/meta.conf.sample ; \
+ ${REINPLACE_CMD} -e 's|meta\.conf|meta.conf.sample|g' ${WRKSRC}/backends/Makefile ; \
+ fi
+
post-install:
+ @for na in buttonpressed.sh initscanner.sh meta.conf; do \
+ if [ ! -f ${ETCDIR}/$$na ]; then \
+ ${CP} -p ${ETCDIR}/$$na.sample ${ETCDIR}/$$na; \
+ fi; \
+ done
@${CAT} ${PKGMESSAGE}
.include <bsd.port.post.mk>
diff --git a/sysutils/scanbuttond/pkg-plist b/sysutils/scanbuttond/pkg-plist
index e252aec61cde..1815177991bd 100644
--- a/sysutils/scanbuttond/pkg-plist
+++ b/sysutils/scanbuttond/pkg-plist
@@ -1,7 +1,13 @@
bin/scanbuttond
-etc/scanbuttond/buttonpressed.sh
-etc/scanbuttond/initscanner.sh
-etc/scanbuttond/meta.conf
+@unexec if cmp -s %D/etc/scanbuttond/buttonpressed.sh.sample %D/etc/scanbuttond/buttonpressed.sh; then rm -f %D/etc/scanbuttond/buttonpressed.sh; fi
+etc/scanbuttond/buttonpressed.sh.sample
+@exec if [ ! -f %D/etc/scanbuttond/buttonpressed.sh ] ; then cp -p %D/%F %B/buttonpressed.sh; fi
+@unexec if cmp -s %D/etc/scanbuttond/initscanner.sh.sample %D/etc/scanbuttond/initscanner.sh; then rm -f %D/etc/scanbuttond/initscanner.sh; fi
+etc/scanbuttond/initscanner.sh.sample
+@exec if [ ! -f %D/etc/scanbuttond/initscanner.sh ] ; then cp -p %D/%F %B/initscanner.sh; fi
+@unexec if cmp -s %D/etc/scanbuttond/meta.conf.sample %D/etc/scanbuttond/meta.conf; then rm -f %D/etc/scanbuttond/meta.conf; fi
+etc/scanbuttond/meta.conf.sample
+@exec if [ ! -f %D/etc/scanbuttond/meta.conf ] ; then cp -p %D/%F %B/meta.conf; fi
lib/libscanbtnd-backend_epson.la
lib/libscanbtnd-backend_epson.so
lib/libscanbtnd-backend_epson.so.1