aboutsummaryrefslogtreecommitdiff
path: root/sysutils/sge62
diff options
context:
space:
mode:
authorBrooks Davis <brooks@FreeBSD.org>2008-02-25 18:08:08 +0000
committerBrooks Davis <brooks@FreeBSD.org>2008-02-25 18:08:08 +0000
commit7d15e5a75b47db59baacc217c1795b329959dc16 (patch)
tree244d1fc38e0bfb162f8a5f8ce4216bdd294c171b /sysutils/sge62
parent62bdf1276d4998ab27d39ffba17ea08fcd9e12eb (diff)
downloadports-7d15e5a75b47db59baacc217c1795b329959dc16.tar.gz
ports-7d15e5a75b47db59baacc217c1795b329959dc16.zip
Add a forgotten patch to compile the sge_arch.c file with -ansi to let
the evil cpp stringification hack for the architecture name work. Otherwise "uname -m" generally evaluates to a value that is a macro that expands to resulting in all architectures appearing to be fbsd-1.
Notes
Notes: svn path=/head/; revision=207884
Diffstat (limited to 'sysutils/sge62')
-rw-r--r--sysutils/sge62/Makefile2
-rw-r--r--sysutils/sge62/files/patch-libs_uti_Makefile14
2 files changed, 15 insertions, 1 deletions
diff --git a/sysutils/sge62/Makefile b/sysutils/sge62/Makefile
index 09c427e775bd..8279736c5258 100644
--- a/sysutils/sge62/Makefile
+++ b/sysutils/sge62/Makefile
@@ -7,7 +7,7 @@
PORTNAME= sge
PORTVERSION= ${SGE_VERSION}
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= sysutils parallel
MASTER_SITES= http://gridengine.sunsource.net/files/documents/7/161/:src \
http://gridengine.sunsource.net/download/SGE61/:bin \
diff --git a/sysutils/sge62/files/patch-libs_uti_Makefile b/sysutils/sge62/files/patch-libs_uti_Makefile
new file mode 100644
index 000000000000..89d912ad7396
--- /dev/null
+++ b/sysutils/sge62/files/patch-libs_uti_Makefile
@@ -0,0 +1,14 @@
+
+$FreeBSD$
+
+--- libs/uti/Makefile.orig
++++ libs/uti/Makefile
+@@ -186,7 +186,7 @@
+ $(CC) $(CFLAGS) $(COD_NPROCS_CFLAGS) $(SHARED_CFLAGS) -c $(UTILIB_DIR)/sge_nprocs.c
+
+ sge_arch.o: $(UTILIB_DIR)/sge_arch.c
+- $(CC) $(CFLAGS) $(SHARED_CFLAGS) -c $(UTILIB_DIR)/sge_arch.c
++ $(CC) -ansi $(CFLAGS) $(SHARED_CFLAGS) -c $(UTILIB_DIR)/sge_arch.c
+
+ sge_loadmem.o: $(UTILIB_DIR)/sge_loadmem.c
+ $(CC) $(CFLAGS) $(MEMCFLAG) $(SHARED_CFLAGS) -c $(UTILIB_DIR)/sge_loadmem.c