aboutsummaryrefslogtreecommitdiff
path: root/sysutils/shim
diff options
context:
space:
mode:
authorJan Beich <jbeich@FreeBSD.org>2017-02-05 04:36:22 +0000
committerJan Beich <jbeich@FreeBSD.org>2017-02-05 04:36:22 +0000
commit3ea2de2afa34647caff8bd6b9df1f408b774be9d (patch)
tree9a6a1f8d08197ec332cac9d5aa10fc0d87212097 /sysutils/shim
parent09675f956dca1397c7b68569d03ddcc7a6fb0ef7 (diff)
downloadports-3ea2de2afa34647caff8bd6b9df1f408b774be9d.tar.gz
ports-3ea2de2afa34647caff8bd6b9df1f408b774be9d.zip
sysutils/shim: unbreak with gcc5 or later
In file included from /usr/local/include/efi/efi.h:35:0, from shim.c:36: /usr/local/include/efi/x86_64/efibind.h:88:24: fatal error: stdint.h: No such file or directory PR: 216707 Reported by: antoine (via exp-run)
Notes
Notes: svn path=/head/; revision=433350
Diffstat (limited to 'sysutils/shim')
-rw-r--r--sysutils/shim/Makefile3
-rw-r--r--sysutils/shim/files/patch-Makefile8
2 files changed, 3 insertions, 8 deletions
diff --git a/sysutils/shim/Makefile b/sysutils/shim/Makefile
index 1fa458daf32e..9f89456436e0 100644
--- a/sysutils/shim/Makefile
+++ b/sysutils/shim/Makefile
@@ -18,8 +18,10 @@ USE_GITHUB= yes
GH_ACCOUNT= mjg59
USES= gmake
+USE_CSTD= gnu89
USE_GCC= yes
USE_GITHUB= yes
+MAKE_ARGS= CC="${CC} ${CFLAGS:M-std=*}" LD="${LD}" OBJCOPY="${OBJCOPY}"
MAKE_JOBS_UNSAFE= yes
ONLY_FOR_ARCHS= amd64
@@ -28,7 +30,6 @@ PLIST_FILES= lib/shim/shim.pem lib/shim/shim.key \
post-patch:
@${REINPLACE_CMD} -e "s|/bin/bash|${LOCALBASE}/bin/bash|" ${WRKSRC}/make-certs
- @${REINPLACE_CMD} -e 's|%%CC%%|${CC}|g' ${WRKSRC}/Makefile
do-install:
# Note that before this step, the shim.pem contains the _private_ key.
diff --git a/sysutils/shim/files/patch-Makefile b/sysutils/shim/files/patch-Makefile
index fb3dfbea2344..4a9858409273 100644
--- a/sysutils/shim/files/patch-Makefile
+++ b/sysutils/shim/files/patch-Makefile
@@ -1,12 +1,6 @@
--- Makefile.orig 2014-10-13 22:41:51.000000000 +0200
+++ Makefile 2014-12-21 16:18:40.000000000 +0100
-@@ -1,16 +1,22 @@
--CC = $(CROSS_COMPILE)gcc
-+CROSS_COMPILE = $(LOCALBASE)/bin/
-+
-+CC = $(CROSS_COMPILE)%%CC%%
- LD = $(CROSS_COMPILE)ld
- OBJCOPY = $(CROSS_COMPILE)objcopy
+@@ -4,13 +1,17 @@
ARCH = $(shell $(CC) -dumpmachine | cut -f1 -d- | sed s,i[3456789]86,ia32,)