aboutsummaryrefslogtreecommitdiff
path: root/sysutils/sleuthkit
diff options
context:
space:
mode:
authorAlexey Dokuchaev <danfe@FreeBSD.org>2007-06-06 00:49:57 +0000
committerAlexey Dokuchaev <danfe@FreeBSD.org>2007-06-06 00:49:57 +0000
commit06a8e6439e1e4047bb8bded1d7d86f44991800a1 (patch)
treeff099e4b346c6ec8e805ac8193f14c3a69425247 /sysutils/sleuthkit
parent3c8093e651a896fa26bd19e4c21a3f16b40870b3 (diff)
downloadports-06a8e6439e1e4047bb8bded1d7d86f44991800a1.tar.gz
ports-06a8e6439e1e4047bb8bded1d7d86f44991800a1.zip
- Make installed scripts really usable (fix binary files path)
- Registed missing runtime dependency - Bump PORTREVISION
Notes
Notes: svn path=/head/; revision=192863
Diffstat (limited to 'sysutils/sleuthkit')
-rw-r--r--sysutils/sleuthkit/Makefile5
-rw-r--r--sysutils/sleuthkit/files/patch-src::sorter::install9
-rw-r--r--sysutils/sleuthkit/files/patch-src::timeline::config-perl16
3 files changed, 30 insertions, 0 deletions
diff --git a/sysutils/sleuthkit/Makefile b/sysutils/sleuthkit/Makefile
index 82cee5ce90f7..15d12549c4e2 100644
--- a/sysutils/sleuthkit/Makefile
+++ b/sysutils/sleuthkit/Makefile
@@ -7,6 +7,7 @@
PORTNAME= sleuthkit
PORTVERSION= 2.08
+PORTREVISION= 1
CATEGORIES= sysutils security
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
@@ -16,6 +17,8 @@ COMMENT= The @stake Sleuth Kit for forensic analysis
CONFLICTS= ja-ls-[0-9]*
+RUN_DEPENDS= ${SITE_PERL}/Date/Manip.pm:${PORTSDIR}/devel/p5-Date-Manip
+
USE_PERL5= yes
.include <bsd.port.pre.mk>
@@ -43,6 +46,8 @@ post-patch:
${WRKSRC}/src/hashtools/Makefile ${WRKSRC}/src/imgtools/Makefile \
${WRKSRC}/src/auxtools/Makefile ${WRKSRC}/src/mmtools/Makefile \
${WRKSRC}/src/srchtools/Makefile
+ @${REINPLACE_CMD} -e 's/$${BIN_DIR}file/\/usr\/bin\/file/' \
+ ${WRKSRC}/src/sorter/sorter.base
do-install:
.if !defined(NOPORTDOCS)
diff --git a/sysutils/sleuthkit/files/patch-src::sorter::install b/sysutils/sleuthkit/files/patch-src::sorter::install
index 1ea795ee00a2..a3646d2b6cfc 100644
--- a/sysutils/sleuthkit/files/patch-src::sorter::install
+++ b/sysutils/sleuthkit/files/patch-src::sorter::install
@@ -9,3 +9,12 @@
# Find Perl
found=0;
+@@ -58,7 +58,7 @@
+ done
+ fi
+
+-echo "my \$SK_DIR=\"`cd ../..; pwd`/\";" >> $BIN_DIR$PROG;
++echo "my \$SK_DIR=\"${LOCALBASE}\";" >> $BIN_DIR$PROG;
+
+ # Print the current version
+ echo "my \$VER = \"`cat ../../patchlevel`\";" >> $BIN_DIR$PROG;
diff --git a/sysutils/sleuthkit/files/patch-src::timeline::config-perl b/sysutils/sleuthkit/files/patch-src::timeline::config-perl
index c1c1d5d76c8d..adeeab0a5631 100644
--- a/sysutils/sleuthkit/files/patch-src::timeline::config-perl
+++ b/sysutils/sleuthkit/files/patch-src::timeline::config-perl
@@ -9,3 +9,19 @@
# Find Perl
found=0;
+@@ -57,15 +57,6 @@
+ echo "file not found";
+ fi
+ done
+-fi
+-
+-
+-# Print the installed location of the lib directory
+-# This is not the best fix, but it works
+-if (test -z "`echo "$PWD" | awk '/\/src\/timeline/ {print $0}'`") then
+- echo "use lib '$PWD/$LIB_DIR_NORM';" >> $BIN_DIR$PROG;
+-else
+- echo "use lib '$PWD/$LIB_DIR_BACK';" >> $BIN_DIR$PROG;
+ fi
+
+