aboutsummaryrefslogtreecommitdiff
path: root/sysutils/ssync
diff options
context:
space:
mode:
authorMark Pulford <markp@FreeBSD.org>2002-04-02 14:25:46 +0000
committerMark Pulford <markp@FreeBSD.org>2002-04-02 14:25:46 +0000
commita42f4585960e0916692dafa4ae221e9ba979d990 (patch)
tree7b9dbaa7466e50601de7e181d086c9ec75341771 /sysutils/ssync
parent55c9609c9c4cc26265e2a540d70c12260bf1e353 (diff)
downloadports-a42f4585960e0916692dafa4ae221e9ba979d990.tar.gz
ports-a42f4585960e0916692dafa4ae221e9ba979d990.zip
Add ssync 2.2, a minimalistic tool for keeping filesystems in
synchronization. PR: 36227 Submitted by: Andrew Shevtsov <nyxo@dnuc.polyn.kiae.su>
Notes
Notes: svn path=/head/; revision=57201
Diffstat (limited to 'sysutils/ssync')
-rw-r--r--sysutils/ssync/Makefile38
-rw-r--r--sysutils/ssync/distinfo1
-rw-r--r--sysutils/ssync/pkg-comment1
-rw-r--r--sysutils/ssync/pkg-descr7
-rw-r--r--sysutils/ssync/pkg-message2
-rw-r--r--sysutils/ssync/pkg-plist5
6 files changed, 54 insertions, 0 deletions
diff --git a/sysutils/ssync/Makefile b/sysutils/ssync/Makefile
new file mode 100644
index 000000000000..54bf231e832b
--- /dev/null
+++ b/sysutils/ssync/Makefile
@@ -0,0 +1,38 @@
+# New ports collection makefile for: ssync
+# Date created: 23 March 2002
+# Whom: Andrew Shevtsov <nyxo@dnuc.polyn.kiae.su>
+#
+# $FreeBSD$
+#
+
+PORTNAME= ssync
+PORTVERSION= 2.2
+CATEGORIES= sysutils
+MASTER_SITES= http://equusasinus.com/ssync/
+
+MAINTAINER= nyxo@dnuc.polyn.kiae.su
+
+ALL_TARGET= default
+USE_GMAKE= yes
+MAKEFILE= makefile
+
+MAN1= ssync.1
+
+post-patch:
+ @${PERL} -pi -e 's@/etc/init.d/ssyncd@\$$0@g' ${WRKSRC}/ssyncd.init
+ @${PERL} -pi -e "s@/etc@${PREFIX}/etc@g;s@/usr/sbin@${PREFIX}/sbin@g;" \
+ ${WRKSRC}/ssyncd.init ${WRKSRC}/ssyncd.conf ${WRKSRC}/daemon.c
+ @${PERL} -pi -e "s@ +CFLAGS.+@@g; s@ +LDFLAGS.+@@g;" ${WRKSRC}/makefile
+
+do-install:
+ @${INSTALL_PROGRAM} ${WRKSRC}/ssync ${PREFIX}/bin/ssync
+ @${INSTALL_PROGRAM} ${WRKSRC}/ssyncd ${PREFIX}/sbin/ssyncd
+ @${INSTALL_DATA} ${WRKSRC}/ssyncd.conf ${PREFIX}/etc/ssyncd.conf.sample
+ @${INSTALL_DATA} ${WRKSRC}/ssyncd.work ${PREFIX}/etc/ssyncd.work.sample
+ @${INSTALL_SCRIPT} ${WRKSRC}/ssyncd.init ${PREFIX}/etc/rc.d/ssyncd.init
+ @${INSTALL_MAN} ${WRKSRC}/ssync.man ${MAN1PREFIX}/man/man1/ssync.1
+
+post-install:
+ @${CAT} ${PKGMESSAGE}
+
+.include <bsd.port.mk>
diff --git a/sysutils/ssync/distinfo b/sysutils/ssync/distinfo
new file mode 100644
index 000000000000..ea61d6404494
--- /dev/null
+++ b/sysutils/ssync/distinfo
@@ -0,0 +1 @@
+MD5 (ssync-2.2.tar.gz) = 74c3f2d7860d6819fb8c284af5956cd2
diff --git a/sysutils/ssync/pkg-comment b/sysutils/ssync/pkg-comment
new file mode 100644
index 000000000000..35dd8f42bf73
--- /dev/null
+++ b/sysutils/ssync/pkg-comment
@@ -0,0 +1 @@
+A minimalistic tool for keeping filesystems in synchronization
diff --git a/sysutils/ssync/pkg-descr b/sysutils/ssync/pkg-descr
new file mode 100644
index 000000000000..4a98f3ddcebf
--- /dev/null
+++ b/sysutils/ssync/pkg-descr
@@ -0,0 +1,7 @@
+Ssync is a minimalistic tool for keeping filesystems in synchronization.
+The main goals in writing ssync are correctness, simplicity, speed,
+low-resource comsumption and portability. It features a number of options
+to control how things are synchronized and under what conditions, as well
+as useful dry-run and verbose modes.
+
+WWW: http://equusasinus.com/ssync/
diff --git a/sysutils/ssync/pkg-message b/sysutils/ssync/pkg-message
new file mode 100644
index 000000000000..4ddb1c9b24af
--- /dev/null
+++ b/sysutils/ssync/pkg-message
@@ -0,0 +1,2 @@
+You will need to copy ssyncd.conf.sample to ssyncd.conf and
+ssyncd.work.sample to ssyncd.work before this port can be used.
diff --git a/sysutils/ssync/pkg-plist b/sysutils/ssync/pkg-plist
new file mode 100644
index 000000000000..bd85462a0d2e
--- /dev/null
+++ b/sysutils/ssync/pkg-plist
@@ -0,0 +1,5 @@
+bin/ssync
+sbin/ssyncd
+etc/ssyncd.conf.sample
+etc/ssyncd.work.sample
+etc/rc.d/ssyncd.init