aboutsummaryrefslogtreecommitdiff
path: root/sysutils/tmux
diff options
context:
space:
mode:
authorWen Heping <wen@FreeBSD.org>2010-04-06 02:52:08 +0000
committerWen Heping <wen@FreeBSD.org>2010-04-06 02:52:08 +0000
commit50e16d28ba00a6024bdba7cdf0de4d524ab0e319 (patch)
tree839772dc367e446bf6fab0e7775507d61f4f9ea6 /sysutils/tmux
parente3b5ff9ba8c68f62f1202843903aac46e7ea497d (diff)
downloadports-50e16d28ba00a6024bdba7cdf0de4d524ab0e319.tar.gz
ports-50e16d28ba00a6024bdba7cdf0de4d524ab0e319.zip
- Fix run error when using zsh or sh as shell [1][2]
- Fix build error with custom LOCALBASE PR: ports/145349 [1] ports/144760 [2] Submitted by: Ryan Steinmetz <rpsfa@rit.edu> [1], Erwan david <erwan@rail.eu.org> [2]
Notes
Notes: svn path=/head/; revision=252299
Diffstat (limited to 'sysutils/tmux')
-rw-r--r--sysutils/tmux/Makefile15
-rw-r--r--sysutils/tmux/files/extra-patch-configure10
2 files changed, 24 insertions, 1 deletions
diff --git a/sysutils/tmux/Makefile b/sysutils/tmux/Makefile
index 4c5a7eb9466c..57326456288b 100644
--- a/sysutils/tmux/Makefile
+++ b/sysutils/tmux/Makefile
@@ -7,6 +7,7 @@
PORTNAME= tmux
PORTVERSION= 1.2
+PORTREVISION= 1
CATEGORIES= sysutils
MASTER_SITES= SF/${PORTNAME}/${PORTNAME}/${PORTNAME}-${PORTVERSION}
@@ -24,9 +25,21 @@ PLIST_FILES= bin/tmux
PORTDOCS= CHANGES FAQ NOTES
PORTEXAMPLES= *
+CFLAGS+= -I${LOCALBASE}/include
+#LDFLAGS+= -L${LOCALBASE}/lib
+CONFIGURE_ARGS+= CFLAGS="${CFLAGS}" LDFLAGS="${LDFLAGS}"
+
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} <= 703100
+EXTRA_PATCHES= ${FILESDIR}/extra-patch-configure
+.endif
+
post-patch:
@${REINPLACE_CMD} -e '/^#define HAVE_TREE_H/d' \
${WRKSRC}/configure
+ @${REINPLACE_CMD} -e 's#/usr/local#${LOCALBASE}#g' \
+ ${WRKSRC}/Makefile
do-install:
@${INSTALL_PROGRAM} ${WRKSRC}/tmux ${PREFIX}/bin
@@ -45,4 +58,4 @@ post-install:
@${INSTALL_DATA} ${WRKSRC}/examples/* ${EXAMPLESDIR}
.endif
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/sysutils/tmux/files/extra-patch-configure b/sysutils/tmux/files/extra-patch-configure
new file mode 100644
index 000000000000..6b9a7d99fe99
--- /dev/null
+++ b/sysutils/tmux/files/extra-patch-configure
@@ -0,0 +1,10 @@
+--- configure.orig 2010-03-17 09:12:09.000000000 +0800
++++ configure 2010-03-17 09:11:28.000000000 +0800
+@@ -204,6 +204,7 @@
+ FreeBSD|DragonFly)
+ cat <<EOF >>$CONFIG_H
+ #define HAVE_ASPRINTF
++#define HAVE_BROKEN_KQUEUE
+ #define HAVE_BZERO
+ #define HAVE_DAEMON
+ #define HAVE_FGETLN