aboutsummaryrefslogtreecommitdiff
path: root/sysutils/tmux
diff options
context:
space:
mode:
authorPietro Cerutti <gahr@FreeBSD.org>2011-07-15 14:48:32 +0000
committerPietro Cerutti <gahr@FreeBSD.org>2011-07-15 14:48:32 +0000
commitc6e279df75fc89d2d54926afe438eccbf9bdb036 (patch)
tree7ba0d4cb61bad919565eb42e31162ba4681889b4 /sysutils/tmux
parentd803eb8773557a2ca9584eb722aff93027f2e716 (diff)
downloadports-c6e279df75fc89d2d54926afe438eccbf9bdb036.tar.gz
ports-c6e279df75fc89d2d54926afe438eccbf9bdb036.zip
- Update to 1.5
- Take maintainship - Do not link against librt if not needed PR: 158946 Submitted by: gahr@FreeBSD.org Enhanced by: Pan Tsu <inyaoo@gmail.com>
Notes
Notes: svn path=/head/; revision=277753
Diffstat (limited to 'sysutils/tmux')
-rw-r--r--sysutils/tmux/Makefile63
-rw-r--r--sysutils/tmux/distinfo4
-rw-r--r--sysutils/tmux/files/extra-patch-fb718
-rw-r--r--sysutils/tmux/files/extra-patch-kqueue10
-rw-r--r--sysutils/tmux/files/extra-patch-kqueue_and_fb720
-rw-r--r--sysutils/tmux/files/patch-hostname.diff32
6 files changed, 19 insertions, 128 deletions
diff --git a/sysutils/tmux/Makefile b/sysutils/tmux/Makefile
index 17e46fc04f22..a30609f70429 100644
--- a/sysutils/tmux/Makefile
+++ b/sysutils/tmux/Makefile
@@ -6,12 +6,11 @@
#
PORTNAME= tmux
-PORTVERSION= 1.4
-PORTREVISION= 6
+PORTVERSION= 1.5
CATEGORIES= sysutils
MASTER_SITES= SF/${PORTNAME}/${PORTNAME}/${PORTNAME}-${PORTVERSION}
-MAINTAINER= wen@FreeBSD.org
+MAINTAINER= gahr@FreeBSD.org
COMMENT= A Terminal Multiplexer
LICENSE= BSD
@@ -25,54 +24,29 @@ PLIST_FILES= bin/tmux
PORTDOCS= CHANGES FAQ NOTES
PORTEXAMPLES= *
-OPTIONS= KQUEUE "Build without define HAVE_BROKEN_KQUEUE " On \
- LIBEVENT2 "Use libevent version 2" Off \
+OPTIONS= LIBEVENT2 "Use libevent version 2" Off \
LIBEVENT_STATIC "Build with static libevent" Off \
BACKSPACE "Build with tty/keys patch" Off
-# Now I set tmux build without #define HAVE_BROKEN_KQUEUE as default and an option,
-# If it still hang the system or other run error, try as upstream suggest:
-# http://sourceforge.net/mailarchive/forum.php?thread_name=20110125092121.GA15934%40yelena.nicm.ath.cx&forum_name=tmux-users
-
.include <bsd.port.pre.mk>
.if defined(WITH_LIBEVENT2)
-EXTRA_CPPFLAGS+= -I${LOCALBASE}/include/event2/compat -I${LOCALBASE}/include
+LIB_DEPENDS= event-2.0:${PORTSDIR}/devel/libevent2
+CPPFLAGS+= -I${LOCALBASE}/include/event2/compat -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib/event2
-.else
-EXTRA_CPPFLAGS+= -I${LOCALBASE}/include
-LDFLAGS+= -L${LOCALBASE}/lib
-.endif
-
-MAKE_ENV+= EXTRA_CPPFLAGS="${EXTRA_CPPFLAGS}" LDFLAGS="${LDFLAGS}"
-
-.if defined(WITH_LIBEVENT_STATIC)
-. if defined(WITH_LIBEVENT2)
-_LEVENT_LIB= ${LOCALBASE}/lib/event2/libevent.a
-BUILD_DEPENDS+= ${_LEVENT_LIB}:${PORTSDIR}/devel/libevent2
-. else
-_LEVENT_LIB= ${LOCALBASE}/lib/libevent.a
-BUILD_DEPENDS+= ${_LEVENT_LIB}:${PORTSDIR}/devel/libevent
+. if defined(WITH_LIBEVENT_STATIC)
+LESTATIC= ${LOCALBASE}/lib/event2/libevent.a
. endif
.else
-. if defined(WITH_LIBEVENT2)
-_LEVENT_LIB= -levent-2.0
-LIB_DEPENDS= event-2.0:${PORTSDIR}/devel/libevent2
-. else
-_LEVENT_LIB= -levent-1.4
LIB_DEPENDS= event-1.4:${PORTSDIR}/devel/libevent
+CPPFLAGS+= -I${LOCALBASE}/include
+LDFLAGS+= -L${LOCALBASE}/lib
+. if defined(WITH_LIBEVENT_STATIC)
+LESTATIC= ${LOCALBASE}/lib/libevent.a
. endif
.endif
-.if !defined(WITHOUT_KQUEUE)
-.if ${OSVERSION} < 702104
-EXTRA_PATCHES= ${PATCHDIR}/extra-patch-kqueue_and_fb7
-.else
-EXTRA_PATCHES= ${PATCHDIR}/extra-patch-kqueue
-.endif
-.else
-EXTRA_PATCHES= ${PATCHDIR}/extra-patch-fb7
-.endif
+CONFIGURE_ENV+= LDFLAGS="${LDFLAGS}"
.if defined(WITH_BACKSPACE)
EXTRA_PATCHES= ${PATCHDIR}/extra-patch-tty-keys.c
@@ -80,14 +54,11 @@ EXTRA_PATCHES= ${PATCHDIR}/extra-patch-tty-keys.c
post-patch:
@${REINPLACE_CMD} -e 's|/etc/tmux.conf|${PREFIX}/etc/tmux.conf|g' \
- ${WRKSRC}/tmux.1 ${WRKSRC}/tmux.h
- @${REINPLACE_CMD} -e 's|-I/usr/local/include||g' \
- -e 's|/usr/local|${LOCALBASE}|g' \
- -e 's|$${CPPFLAGS}$$|${CPPFLAGS} ${EXTRA_CPPFLAGS}|g' \
- -e 's|LDFLAGS+=|#LDFLAGS+=|g' \
- ${WRKSRC}/Makefile
- @${REINPLACE_CMD} -e 's|-levent|${_LEVENT_LIB}|g' \
- ${WRKSRC}/configure
+ ${WRKSRC}/tmux.1 ${WRKSRC}/tmux.h ${WRKSRC}/CHANGES
+ ${REINPLACE_CMD} -e '/LIBS=/s/-lrt//' ${WRKSRC}/${CONFIGURE_SCRIPT}
+.if defined(WITH_LIBEVENT_STATIC)
+ ${REINPLACE_CMD} -e '4534s|$$ac_res |${LESTATIC} |' ${WRKSRC}/${CONFIGURE_SCRIPT}
+.endif
do-install:
@${INSTALL_PROGRAM} ${WRKSRC}/tmux ${PREFIX}/bin
diff --git a/sysutils/tmux/distinfo b/sysutils/tmux/distinfo
index 6b9fbf4b71ec..5d03bf524519 100644
--- a/sysutils/tmux/distinfo
+++ b/sysutils/tmux/distinfo
@@ -1,2 +1,2 @@
-SHA256 (tmux-1.4.tar.gz) = c7e005f32e256b8ece214b71c51947f4081af8c5f0400083e4adaac2c258bbc7
-SIZE (tmux-1.4.tar.gz) = 259614
+SHA256 (tmux-1.5.tar.gz) = eb8215b57c05b765d2446d9acb2bc5edcdb3eb4ea31af89ee127a27e90056306
+SIZE (tmux-1.5.tar.gz) = 374093
diff --git a/sysutils/tmux/files/extra-patch-fb7 b/sysutils/tmux/files/extra-patch-fb7
deleted file mode 100644
index f6af48b3617d..000000000000
--- a/sysutils/tmux/files/extra-patch-fb7
+++ /dev/null
@@ -1,18 +0,0 @@
---- configure.orig 2011-02-21 10:52:19.000000000 +0800
-+++ configure 2011-02-21 10:54:29.000000000 +0800
-@@ -224,7 +224,6 @@
- #define HAVE_ASPRINTF
- #define HAVE_BROKEN_KQUEUE
- #define HAVE_BZERO
--#define HAVE_CLOSEFROM
- #define HAVE_DAEMON
- #define HAVE_FGETLN
- #define HAVE_FORKPTY
-@@ -245,6 +244,7 @@
- cat <<EOF >>$CONFIG_MK
- LIBS+= -lcurses -lutil -levent
- SRCS+= osdep-freebsd.c \
-+ compat/closefrom.c \
- compat/vis.c \
- compat/unvis.c \
- compat/imsg-buffer.c \
diff --git a/sysutils/tmux/files/extra-patch-kqueue b/sysutils/tmux/files/extra-patch-kqueue
deleted file mode 100644
index e71b1f1a4cdb..000000000000
--- a/sysutils/tmux/files/extra-patch-kqueue
+++ /dev/null
@@ -1,10 +0,0 @@
---- configure.orig 2011-02-21 14:12:33.000000000 +0800
-+++ configure 2011-02-21 14:13:00.000000000 +0800
-@@ -222,7 +222,6 @@
- FreeBSD|DragonFly)
- cat <<EOF >>$CONFIG_H
- #define HAVE_ASPRINTF
--#define HAVE_BROKEN_KQUEUE
- #define HAVE_BZERO
- #define HAVE_CLOSEFROM
- #define HAVE_DAEMON
diff --git a/sysutils/tmux/files/extra-patch-kqueue_and_fb7 b/sysutils/tmux/files/extra-patch-kqueue_and_fb7
deleted file mode 100644
index 6409a5e11dae..000000000000
--- a/sysutils/tmux/files/extra-patch-kqueue_and_fb7
+++ /dev/null
@@ -1,20 +0,0 @@
---- configure.orig 2011-02-21 14:37:37.000000000 +0800
-+++ configure 2011-02-21 14:38:21.000000000 +0800
-@@ -222,9 +222,7 @@
- FreeBSD|DragonFly)
- cat <<EOF >>$CONFIG_H
- #define HAVE_ASPRINTF
--#define HAVE_BROKEN_KQUEUE
- #define HAVE_BZERO
--#define HAVE_CLOSEFROM
- #define HAVE_DAEMON
- #define HAVE_FGETLN
- #define HAVE_FORKPTY
-@@ -245,6 +243,7 @@
- cat <<EOF >>$CONFIG_MK
- LIBS+= -lcurses -lutil -levent
- SRCS+= osdep-freebsd.c \
-+ compat/closefrom.c \
- compat/vis.c \
- compat/unvis.c \
- compat/imsg-buffer.c \
diff --git a/sysutils/tmux/files/patch-hostname.diff b/sysutils/tmux/files/patch-hostname.diff
deleted file mode 100644
index a8eedf929277..000000000000
--- a/sysutils/tmux/files/patch-hostname.diff
+++ /dev/null
@@ -1,32 +0,0 @@
---- status.c.orig 2011/04/18 20:49:05 1.73
-+++ status.c 2011/04/24 22:32:07 1.74
-@@ -1,4 +1,4 @@
--/* $OpenBSD: status.c,v 1.73 2011/04/18 19:49:05 nicm Exp $ */
-+/* $OpenBSD: status.c,v 1.74 2011/04/24 21:32:07 nicm Exp $ */
-
- /*
- * Copyright (c) 2007 Nicholas Marriott <nicm@users.sourceforge.net>
-@@ -408,6 +408,13 @@ status_replace1(struct client *c, struct session *s, s
- case 'H':
- if (gethostname(tmp, sizeof tmp) != 0)
- fatal("gethostname failed");
-+ ptr = tmp;
-+ goto do_replace;
-+ case 'h':
-+ if (gethostname(tmp, sizeof tmp) != 0)
-+ fatal("gethostname failed");
-+ if ((ptr = strchr(tmp, '.')) != NULL)
-+ *ptr = '\0';
- ptr = tmp;
- goto do_replace;
- case 'I':
---- tmux.1.orig 2011/04/19 22:31:33 1.223
-+++ tmux.1 2011/04/24 22:32:07 1.224
-@@ -2005,6 +2005,7 @@ may contain any of the following special character seq
- .It Li "#(shell-command)" Ta "First line of the command's output"
- .It Li "#[attributes]" Ta "Colour or attribute change"
- .It Li "#H" Ta "Hostname of local host"
-+.It Li "#h" Ta "Hostname of local host without the domain name"
- .It Li "#F" Ta "Current window flag"
- .It Li "#I" Ta "Current window index"
- .It Li "#P" Ta "Current pane index"