aboutsummaryrefslogtreecommitdiff
path: root/sysutils/tree
diff options
context:
space:
mode:
authorPatrick Li <pat@FreeBSD.org>2002-03-14 07:39:54 +0000
committerPatrick Li <pat@FreeBSD.org>2002-03-14 07:39:54 +0000
commit993d91cc2c7ab4e5c79addbd6f0fd5dbed086577 (patch)
treea471b251df1a1c904b55c7a0e590304eef4824b5 /sysutils/tree
parenteb17ecf3a76595b3591b8d87d75a5f57c714567c (diff)
downloadports-993d91cc2c7ab4e5c79addbd6f0fd5dbed086577.tar.gz
ports-993d91cc2c7ab4e5c79addbd6f0fd5dbed086577.zip
Chase checksum and bump PORTREVISION - author fix command line parsing
and symlink bug PR: 35811 Submitted by: maintainer
Notes
Notes: svn path=/head/; revision=56061
Diffstat (limited to 'sysutils/tree')
-rw-r--r--sysutils/tree/Makefile1
-rw-r--r--sysutils/tree/distinfo2
-rw-r--r--sysutils/tree/files/patch-Makefile18
-rw-r--r--sysutils/tree/files/patch-tree.c18
4 files changed, 18 insertions, 21 deletions
diff --git a/sysutils/tree/Makefile b/sysutils/tree/Makefile
index a4845903cdbb..03e0455cd6c0 100644
--- a/sysutils/tree/Makefile
+++ b/sysutils/tree/Makefile
@@ -7,6 +7,7 @@
PORTNAME= tree
PORTVERSION= 1.3
+PORTREVISION= 1
CATEGORIES= sysutils
MASTER_SITES= ftp://mama.indstate.edu/linux/tree/
EXTRACT_SUFX= .tgz
diff --git a/sysutils/tree/distinfo b/sysutils/tree/distinfo
index aaa771628f23..682bc26cc1f4 100644
--- a/sysutils/tree/distinfo
+++ b/sysutils/tree/distinfo
@@ -1 +1 @@
-MD5 (tree-1.3.tgz) = cd595dc2eb53760ce32d978fd52fe93c
+MD5 (tree-1.3.tgz) = 610dff913f65c1d4743f1a7e1adc0ae4
diff --git a/sysutils/tree/files/patch-Makefile b/sysutils/tree/files/patch-Makefile
index 9851ef0f7ffe..a6d9012b020d 100644
--- a/sysutils/tree/files/patch-Makefile
+++ b/sysutils/tree/files/patch-Makefile
@@ -1,8 +1,6 @@
-$FreeBSD$
-
---- Makefile.orig Mon Dec 11 14:43:23 2000
-+++ Makefile Mon Dec 24 08:17:21 2001
-@@ -6,15 +6,16 @@
+--- Makefile.orig Mon Feb 15 11:54:06 1999
++++ Makefile Wed Mar 13 23:41:36 2002
+@@ -6,15 +6,15 @@
# warranties, including, without limitation, the implied warranties
# of merchant-ability and fitness for a particular purpose.
@@ -12,7 +10,6 @@ $FreeBSD$
+CC?= gcc
+CFLAGS?= -O2 -Wall
+LDFLAGS?=
-+PREFIX?= /usr/local
+BINDIR= ${PREFIX}/bin
+MANDIR= ${PREFIX}/man/man1
@@ -24,13 +21,12 @@ $FreeBSD$
all: tree
-@@ -28,18 +29,15 @@
- if [ -f tree.o ]; then rm *.o; fi
+@@ -28,17 +28,15 @@
+ if [ -e tree.o ]; then rm *.o; fi
rm -f *~
-install:
-- install -d $(BINDIR)
-- install -d $(MANDIR)
+- install -d $(BINDIR) $(MANDIR)
- if [ -e $(TREE_DEST) ]; then \
- install -s $(TREE_DEST) $(BINDIR)/$(TREE_DEST); \
- fi
@@ -42,7 +38,7 @@ $FreeBSD$
+ ${BSD_INSTALL_MAN} $(MAN) $(MANDIR)
distclean:
- if [ -f tree.o ]; then rm *.o; fi
+ if [ -e tree.o ]; then rm *.o; fi
rm -f *~
-
diff --git a/sysutils/tree/files/patch-tree.c b/sysutils/tree/files/patch-tree.c
index 8a12ffb3dd31..706298b4f06c 100644
--- a/sysutils/tree/files/patch-tree.c
+++ b/sysutils/tree/files/patch-tree.c
@@ -2,12 +2,12 @@ $FreeBSD$
--- tree.c.orig Mon Jan 29 22:38:30 2001
+++ tree.c Mon Dec 24 08:09:39 2001
-@@ -422,7 +422,7 @@
- if (!noindent) indent();
-
- if (inodeflag || devflag || pflag || sflag || uflag || gflag || Dflag) fprintf(outfile,"[");
-- if (inodeflag) fprintf(outfile,"%7ld",(*dir)->inode);
-+ if (inodeflag) fprintf(outfile,"%7ld",(long)(*dir)->inode);
- if (inodeflag && (devflag || pflag || uflag || gflag || sflag || Dflag)) fprintf(outfile,"%s",sp);
- if (devflag) fprintf(outfile,"%3d",(*dir)->dev);
- if (devflag && (pflag || uflag || gflag || sflag || Dflag)) fprintf(outfile,"%s",sp);
+@@ -417,7 +417,7 @@
+ if (uflag && (gflag || sflag || Dflag)) fprintf(outfile,"%s",sp);
+ if (gflag) fprintf(outfile,"%-8.8s",gidtoname((*dir)->gid));
+ if (gflag && (sflag || Dflag)) fprintf(outfile,"%s",sp);
+- if (sflag) fprintf(outfile,"%9ld",(*dir)->size);
++ if (sflag) fprintf(outfile,"%9ld",(long)(*dir)->size);
+ if (sflag && Dflag) fprintf(outfile,"%s",sp);
+ if (Dflag) fprintf(outfile,"%s",do_date((*dir)->mtime));
+ if (pflag || sflag || uflag || gflag || Dflag) fprintf(outfile,"]%s%s",sp,sp);