aboutsummaryrefslogtreecommitdiff
path: root/sysutils/tree
diff options
context:
space:
mode:
authorVasil Dimov <vd@FreeBSD.org>2007-01-25 17:02:16 +0000
committerVasil Dimov <vd@FreeBSD.org>2007-01-25 17:02:16 +0000
commit80f89efd9c3d829a9e51727c1c9695fa3aa54277 (patch)
tree82d361f00963367e7ee1f9ca241e700a8880ae7d /sysutils/tree
parentd5ac897c3f9281ddbdf44ab1ec96cde86fa17cbd (diff)
downloadports-80f89efd9c3d829a9e51727c1c9695fa3aa54277.tar.gz
ports-80f89efd9c3d829a9e51727c1c9695fa3aa54277.zip
Upgrade sysutils/tree from 1.5.0 to 1.5.1
New version reported by: shaun (via portscout)
Notes
Notes: svn path=/head/; revision=183269
Diffstat (limited to 'sysutils/tree')
-rw-r--r--sysutils/tree/Makefile2
-rw-r--r--sysutils/tree/distinfo6
-rw-r--r--sysutils/tree/files/patch-Makefile18
-rw-r--r--sysutils/tree/files/patch-tree.c21
4 files changed, 30 insertions, 17 deletions
diff --git a/sysutils/tree/Makefile b/sysutils/tree/Makefile
index 7f52fdd2272e..1d93123b19ec 100644
--- a/sysutils/tree/Makefile
+++ b/sysutils/tree/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= tree
-PORTVERSION= 1.5.0
+PORTVERSION= 1.5.1
CATEGORIES= sysutils
MASTER_SITES= ftp://mama.indstate.edu/linux/tree/
EXTRACT_SUFX= .tgz
diff --git a/sysutils/tree/distinfo b/sysutils/tree/distinfo
index e964ed451a12..c0ae82205b85 100644
--- a/sysutils/tree/distinfo
+++ b/sysutils/tree/distinfo
@@ -1,3 +1,3 @@
-MD5 (tree-1.5.0.tgz) = e0d090c564e7ea5afa16bac80620c7e0
-SHA256 (tree-1.5.0.tgz) = d11b27dc01689e28ed976184cfbbbf4e3b6563182002b2c9849c8be68caa31f9
-SIZE (tree-1.5.0.tgz) = 26543
+MD5 (tree-1.5.1.tgz) = 274ca4d36ee6fb216fa6cf01ad5eaa84
+SHA256 (tree-1.5.1.tgz) = 1cda1c4d43c6e11ac2214e0a886f1d184bf59d49252cb489b110697f686f809c
+SIZE (tree-1.5.1.tgz) = 30806
diff --git a/sysutils/tree/files/patch-Makefile b/sysutils/tree/files/patch-Makefile
index dbcdc74dbc0d..a610003874f0 100644
--- a/sysutils/tree/files/patch-Makefile
+++ b/sysutils/tree/files/patch-Makefile
@@ -1,17 +1,18 @@
---- Makefile.orig Sat Aug 14 23:07:56 2004
-+++ Makefile Thu Oct 21 11:01:14 2004
-@@ -6,10 +6,6 @@
+--- Makefile.orig Thu Jan 25 18:55:07 2007
++++ Makefile Thu Jan 25 18:54:58 2007
+@@ -6,11 +6,6 @@
# warranties, including, without limitation, the implied warranties
# of merchant-ability and fitness for a particular purpose.
-CC=gcc
--#CFLAGS=-ggdb -Wall -DLINUX_BIGFILE
--CFLAGS=-O2 -Wall -fomit-frame-pointer -DLINUX_BIGFILE
+-#CFLAGS=-ggdb -Wall -D_LARGEFILE64_SOURCE -D_FILE_OFFSET_BITS=64
+-CFLAGS=-O2 -Wall -fomit-frame-pointer -D_LARGEFILE64_SOURCE -D_FILE_OFFSET_BITS=64
-LDFLAGS=-s
-
+-
# Uncomment for FreeBSD:
#CC=gcc
-@@ -51,13 +47,12 @@
+ #CFLAGS=-O2 -Wall -fomit-frame-pointer
+@@ -58,13 +53,11 @@
if [ -f tree.o ]; then rm *.o; fi
rm -f *~
@@ -21,13 +22,12 @@
- if [ -e $(TREE_DEST) ]; then \
- install -s $(TREE_DEST) $(BINDIR)/$(TREE_DEST); \
- fi
-- install $(MAN) $(MANDIR)/$(MAN)
+- install man/$(MAN) $(MANDIR)/$(MAN)
+install: $(TREE_DEST) $(MAN)
+ $(MKDIR) $(BINDIR)
+ $(MKDIR) $(MANDIR)
+ ${BSD_INSTALL_PROGRAM} $(TREE_DEST) $(BINDIR)
+ ${BSD_INSTALL_MAN} $(MAN) $(MANDIR)
-+
distclean:
if [ -f tree.o ]; then rm *.o; fi
diff --git a/sysutils/tree/files/patch-tree.c b/sysutils/tree/files/patch-tree.c
index f6076804e377..406314e18330 100644
--- a/sysutils/tree/files/patch-tree.c
+++ b/sysutils/tree/files/patch-tree.c
@@ -1,10 +1,23 @@
---- tree.c.orig Mon Aug 16 02:07:21 2004
-+++ tree.c Thu Oct 21 11:51:36 2004
-@@ -189,7 +189,6 @@
+--- tree.c.orig Tue Jan 9 23:07:16 2007
++++ tree.c Thu Jan 25 18:58:28 2007
+@@ -17,7 +17,6 @@
+ * Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA 02111-1307 USA
+ */
+
+-#include <features.h>
+ #include <stdlib.h>
+ #include <stdio.h>
+ #include <time.h>
+@@ -178,12 +177,6 @@
+ char *sLevel, *curdir, *outfilename = NULL;
FILE *outfile;
int *dirs, maxdirs;
-
+-
+-#ifdef CYGWIN
+-extern int MB_CUR_MAX;
+-#else
-extern size_t MB_CUR_MAX;
+-#endif
int main(int argc, char **argv)
{