aboutsummaryrefslogtreecommitdiff
path: root/sysutils/tss/Makefile
diff options
context:
space:
mode:
authorAlejandro Pulver <alepulver@FreeBSD.org>2006-11-01 22:16:01 +0000
committerAlejandro Pulver <alepulver@FreeBSD.org>2006-11-01 22:16:01 +0000
commitcc9194b4dfb42a04be14d8b0050f1e5778742db5 (patch)
treecbb11c7d6858fb70ecd9d83540124ed06f4e4530 /sysutils/tss/Makefile
parent3294486143e4f7d3f911e057605ab3bd2c1b6140 (diff)
downloadports-cc9194b4dfb42a04be14d8b0050f1e5778742db5.tar.gz
ports-cc9194b4dfb42a04be14d8b0050f1e5778742db5.zip
Terminal ScreenSaver (or tss for short) is an attempt to clone and enhance
FreeBSD's text-mode screen saver. Although intended for GNU/Linux, it works fine under FreeBSD and probably a lot of other Unix-based operating systems. Unlike the daemonsaver in FreeBSD, you may choose ASCII art of your own liking or make your own. WWW: http://www.pulia.nu/tss/ PR: ports/104773 Submitted by: Peter Ankerstal <peter at pean.org>
Notes
Notes: svn path=/head/; revision=176130
Diffstat (limited to 'sysutils/tss/Makefile')
-rw-r--r--sysutils/tss/Makefile33
1 files changed, 33 insertions, 0 deletions
diff --git a/sysutils/tss/Makefile b/sysutils/tss/Makefile
new file mode 100644
index 000000000000..a8f9e9557327
--- /dev/null
+++ b/sysutils/tss/Makefile
@@ -0,0 +1,33 @@
+# New ports collection makefile for: tss
+# Date created: 25 October 2006
+# Whom: Peter Ankerstal <peter@pean.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= tss
+PORTVERSION= 0.8.1
+CATEGORIES= sysutils
+MASTER_SITES= http://www.pulia.nu/tss/src/
+
+MAINTAINER= peter@pean.org
+COMMENT= Terminal ScreenSaver that allows you to lock you terminal
+
+USE_GETOPT_LONG=yes
+MAKE_ENV= CPPFLAGS="${CPPFLAGS}" LDFLAGS="${LDFLAGS}"
+
+post-patch:
+ @ ${REINPLACE_CMD} -e "s|/etc/tss|${PREFIX}/etc/tss|" ${WRKSRC}/src/main.c
+
+do-install:
+ ${INSTALL_SCRIPT} -m 4755 ${WRKSRC}/tss ${PREFIX}/bin
+ ${MKDIR} ${PREFIX}/etc/tss
+ ${INSTALL_DATA} ${WRKSRC}/tss_art/* ${PREFIX}/etc/tss
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${DOCSDIR}
+.for f in ART_CREDITS COPYING Changelog INSTALL README
+ ${INSTALL_DATA} ${WRKSRC}/${f} ${DOCSDIR}
+.endfor
+.endif
+
+.include <bsd.port.mk>