aboutsummaryrefslogtreecommitdiff
path: root/sysutils/ucspi-ipc
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2004-08-12 18:02:52 +0000
committerPav Lucistnik <pav@FreeBSD.org>2004-08-12 18:02:52 +0000
commit9601841e29df0fd3f03b30c4210071c3014eb8e9 (patch)
tree1741519d0547e0120c968a1f4d27287e90f2edb4 /sysutils/ucspi-ipc
parent6f1594391c3de7161cfcae266242a82aa15e3ce2 (diff)
downloadports-9601841e29df0fd3f03b30c4210071c3014eb8e9.tar.gz
ports-9601841e29df0fd3f03b30c4210071c3014eb8e9.zip
Add ucspi-ipc, UCSPI tools for building local-domain client-server
applications, by William Baxter. PR: ports/68794 Submitted by: David Thiel <lx@redundancy.redundancy.org>
Notes
Notes: svn path=/head/; revision=116050
Diffstat (limited to 'sysutils/ucspi-ipc')
-rw-r--r--sysutils/ucspi-ipc/Makefile51
-rw-r--r--sysutils/ucspi-ipc/distinfo2
-rw-r--r--sysutils/ucspi-ipc/pkg-descr19
-rw-r--r--sysutils/ucspi-ipc/pkg-plist17
4 files changed, 89 insertions, 0 deletions
diff --git a/sysutils/ucspi-ipc/Makefile b/sysutils/ucspi-ipc/Makefile
new file mode 100644
index 000000000000..7750f870a670
--- /dev/null
+++ b/sysutils/ucspi-ipc/Makefile
@@ -0,0 +1,51 @@
+# New ports collection makefile for: ucspi-ipc
+# Date created: 2004-07-07
+# Whom: David Thiel <lx@redundancy.redundancy.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= ucspi-ipc
+PORTVERSION= 0.63
+CATEGORIES= sysutils
+MASTER_SITES= http://www.superscript.com/ucspi-ipc/
+
+MAINTAINER= lx@redundancy.redundancy.org
+COMMENT= UCSPI tools for building local-domain client-server applications
+
+USE_PERL5= yes
+
+DISABLE_SIZE= yes
+
+NO_PACKAGE= Non-explicit licensing terms
+
+DOCS= CHANGES
+
+WRKSRC= ${WRKDIR}/host/superscript.com/net/${DISTNAME}
+
+do-configure:
+ ${ECHO_CMD} "${CC} ${CFLAGS}" > ${WRKSRC}/src/conf-cc
+
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500600
+IGNORE= "requires Perl 5.6.0 or greater. Please install lang/perl5 and retry"
+.endif
+
+do-build:
+ cd ${WRKSRC} && package/compile
+
+do-install:
+.for x in ipccat ipcconnect ipcdo ipcrun
+ ${INSTALL_SCRIPT} ${WRKSRC}/command/${x} ${PREFIX}/bin
+.endfor
+.for x in ipcclient ipccommand ipcconnect-io ipcexec ipcexec-config \
+ ipcexecrules ipcexecrulescheck ipcperl ipcrules ipcrulescheck ipcserver
+ ${INSTALL_PROGRAM} ${WRKSRC}/command/${x} ${PREFIX}/bin
+.endfor
+.if !defined(NOPORTDOCS)
+ @${MKDIR} ${DOCSDIR}
+ cd ${WRKSRC}/src && ${INSTALL_DATA} ${DOCS} ${DOCSDIR}
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/sysutils/ucspi-ipc/distinfo b/sysutils/ucspi-ipc/distinfo
new file mode 100644
index 000000000000..32da0b05d9d6
--- /dev/null
+++ b/sysutils/ucspi-ipc/distinfo
@@ -0,0 +1,2 @@
+MD5 (ucspi-ipc-0.63.tar.gz) = df518cd5a86e9b5aa8efd4aa0479e6d8
+SIZE (ucspi-ipc-0.63.tar.gz) = 50927
diff --git a/sysutils/ucspi-ipc/pkg-descr b/sysutils/ucspi-ipc/pkg-descr
new file mode 100644
index 000000000000..195de96284fc
--- /dev/null
+++ b/sysutils/ucspi-ipc/pkg-descr
@@ -0,0 +1,19 @@
+ipcserver and ipcclient are command-line tools for building local-domain
+client-server applications. They conform to the UNIX Client-Server
+Program Interface, UCSPI.
+
+ipcserver listens for connections on a local-domain stream socket, and
+runs a program for each connection it accepts. The program environment
+includes variables that hold the local and remote socket addresses, and
+the effective user and group IDs of the process that called connect.
+ipcserver offers a concurrency limit on acceptance of new connections,
+and selective handling of connections based on client identity.
+
+ipcclient requests a connection to a local-domain socket, and runs a
+program. The program environment includes a variable that holds the
+local socket address.
+
+ipcperl is an example of an ipchandle server. It invokes a perl
+subroutine for each request.
+
+WWW: http://www.superscript.com/ucspi-ipc/intro.html
diff --git a/sysutils/ucspi-ipc/pkg-plist b/sysutils/ucspi-ipc/pkg-plist
new file mode 100644
index 000000000000..39c3e96637c4
--- /dev/null
+++ b/sysutils/ucspi-ipc/pkg-plist
@@ -0,0 +1,17 @@
+bin/ipccat
+bin/ipcclient
+bin/ipccommand
+bin/ipcconnect
+bin/ipcconnect-io
+bin/ipcdo
+bin/ipcexec
+bin/ipcexec-config
+bin/ipcexecrules
+bin/ipcexecrulescheck
+bin/ipcperl
+bin/ipcrules
+bin/ipcrulescheck
+bin/ipcrun
+bin/ipcserver
+%%PORTDOCS%%%%DOCSDIR%%/CHANGES
+%%PORTDOCS%%@dirrm %%DOCSDIR%%