aboutsummaryrefslogtreecommitdiff
path: root/sysutils/ucspi-ssl/Makefile
diff options
context:
space:
mode:
authorEdwin Groothuis <edwin@FreeBSD.org>2003-09-29 23:56:30 +0000
committerEdwin Groothuis <edwin@FreeBSD.org>2003-09-29 23:56:30 +0000
commitfbd281083e45d70ca573d3ab2eee3ab48b0d9829 (patch)
treedc3b0c701b5bf09164fb700d0350be1b7b9bcb74 /sysutils/ucspi-ssl/Makefile
parent7a98851af114bda5ad1116ff5a6a148d6013394f (diff)
downloadports-fbd281083e45d70ca573d3ab2eee3ab48b0d9829.tar.gz
ports-fbd281083e45d70ca573d3ab2eee3ab48b0d9829.zip
new port: sysutils/ucspi-ssl
ucspi-ssl is a set of UCSPI tools for creating SSL client and server applications. PR: ports/54279 Submitted by: David Thiel <lx@redundancy.redundancy.org>
Notes
Notes: svn path=/head/; revision=89856
Diffstat (limited to 'sysutils/ucspi-ssl/Makefile')
-rw-r--r--sysutils/ucspi-ssl/Makefile37
1 files changed, 37 insertions, 0 deletions
diff --git a/sysutils/ucspi-ssl/Makefile b/sysutils/ucspi-ssl/Makefile
new file mode 100644
index 000000000000..bd080510f7e5
--- /dev/null
+++ b/sysutils/ucspi-ssl/Makefile
@@ -0,0 +1,37 @@
+# New ports collection makefile for: ucspi-ssl
+# Date created: 2003-07-09
+# Whom: David Thiel <lx@redundancy.redundancy.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= ucspi-ssl
+PORTVERSION= 0.50
+CATEGORIES= sysutils
+MASTER_SITES= http://www.superscript.com/ucspi-ssl/
+
+MAINTAINER= lx@redundancy.redundancy.org
+COMMENT= "UCSPI tools for building SSL client-server applications"
+
+RUN_DEPENDS= tcpserver:${PORTSDIR}/sysutils/ucspi-tcp
+
+NO_PACKAGE= "Non-explicit licensing terms"
+
+ALL_TARGET= it
+INSTALL_TARGET= setup check
+
+DOCS= CHANGES README TODO UCSPI-SSL
+
+do-configure:
+ ${ECHO_CMD} "${CC} ${CFLAGS}" > ${WRKSRC}/conf-cc
+ ${ECHO_CMD} "${PREFIX}" > ${WRKSRC}/conf-home
+ ${ECHO_CMD} "${PREFIX}/bin" > ${WRKSRC}/conf-tcpbin
+ ${ECHO_CMD} "${PREFIX}/ssl/certs" > ${WRKSRC}/conf-cadir
+
+post-install:
+.if !defined(NOPORTDOCS)
+ @${MKDIR} ${DOCSDIR}
+ cd ${WRKSRC} && ${INSTALL_DATA} ${DOCS} ${DOCSDIR}
+.endif
+
+.include <bsd.port.mk>