aboutsummaryrefslogtreecommitdiff
path: root/sysutils/usb_modeswitch
diff options
context:
space:
mode:
authorTimur I. Bakeyev <timur@FreeBSD.org>2012-01-14 14:48:37 +0000
committerTimur I. Bakeyev <timur@FreeBSD.org>2012-01-14 14:48:37 +0000
commit4093906419c118caaaa2d82b2d1c0eebd29937cd (patch)
tree7016d63bc6e04b302d471cfe139c477a109990b9 /sysutils/usb_modeswitch
parentfe6fe6dac134165bf9d24a582a22fc14ff15f69a (diff)
downloadports-4093906419c118caaaa2d82b2d1c0eebd29937cd.tar.gz
ports-4093906419c118caaaa2d82b2d1c0eebd29937cd.zip
A small mode switching tool for controlling "flip flop" (multiple
device) USB gear.
Notes
Notes: svn path=/head/; revision=289166
Diffstat (limited to 'sysutils/usb_modeswitch')
-rw-r--r--sysutils/usb_modeswitch/Makefile28
-rw-r--r--sysutils/usb_modeswitch/distinfo2
-rw-r--r--sysutils/usb_modeswitch/pkg-descr11
-rw-r--r--sysutils/usb_modeswitch/pkg-plist4
4 files changed, 45 insertions, 0 deletions
diff --git a/sysutils/usb_modeswitch/Makefile b/sysutils/usb_modeswitch/Makefile
new file mode 100644
index 000000000000..e320739e9b41
--- /dev/null
+++ b/sysutils/usb_modeswitch/Makefile
@@ -0,0 +1,28 @@
+# New ports collection makefile for: usb_modeswitch
+# Date created: 14 January 2011
+# Whom: Alexander V. Chernikov <melifaro@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= usb_modeswitch
+PORTVERSION= 1.2.1
+CATEGORIES= sysutils
+MASTER_SITES= http://www.draisberghof.de/usb_modeswitch/
+EXTRACT_SUFX= .tar.bz2
+
+MAINTAINER= melifaro@ipfw.ru
+COMMENT= Handling Mode-Switching USB Devices
+
+LICENSE= GPLv2
+
+MAKE_JOBS_UNSAFE= yes
+
+MAN1= usb_modeswitch.1
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/usb_modeswitch ${PREFIX}/sbin
+ ${INSTALL_DATA} ${WRKSRC}/usb_modeswitch.conf ${PREFIX}/etc/usb_modeswitch.conf.sample
+ ${INSTALL_MAN} ${WRKSRC}/usb_modeswitch.1 ${PREFIX}/man/man1
+
+.include <bsd.port.mk>
diff --git a/sysutils/usb_modeswitch/distinfo b/sysutils/usb_modeswitch/distinfo
new file mode 100644
index 000000000000..1ae924f1f1e6
--- /dev/null
+++ b/sysutils/usb_modeswitch/distinfo
@@ -0,0 +1,2 @@
+SHA256 (usb-modeswitch-1.2.1.tar.bz2) = 88a253ef86a8aeeba9e6d5b40dd8a7b6b82d166b02bf6af922bf60f370b4d6cb
+SIZE (usb-modeswitch-1.2.1.tar.bz2) = 256713
diff --git a/sysutils/usb_modeswitch/pkg-descr b/sysutils/usb_modeswitch/pkg-descr
new file mode 100644
index 000000000000..a001a0f27d77
--- /dev/null
+++ b/sysutils/usb_modeswitch/pkg-descr
@@ -0,0 +1,11 @@
+USB_ModeSwitch is (surprise!) a mode switching tool for controlling
+"flip flop" (multiple device) USB gear.
+
+USB_ModeSwitch makes this process easy to handle by taking the important
+parameters from a configuration file and doing all the initialization
+and communication stuff, with heavy help from "libusb". It is mainly
+used automatically - via udev events and rules - to do the switch
+without any user interaction. But it can also be run as a command line
+tool, usually when trying to make unknown devices work with it.
+
+WWW: http://www.draisberghof.de/usb_modeswitch/
diff --git a/sysutils/usb_modeswitch/pkg-plist b/sysutils/usb_modeswitch/pkg-plist
new file mode 100644
index 000000000000..74c744143eab
--- /dev/null
+++ b/sysutils/usb_modeswitch/pkg-plist
@@ -0,0 +1,4 @@
+sbin/usb_modeswitch
+etc/usb_modeswitch.conf.sample
+@exec if [ ! -f %D/etc/usb_modeswitch.conf ] ; then cp -p %D/%F %B/usb_modeswitch.conf; fi
+@unexec if cmp -s %D/etc/usb_modeswitch.conf.sample %D/etc/usb_modeswitch.conf; then rm -f %D/etc/usb_modeswitch.conf ; fi