aboutsummaryrefslogtreecommitdiff
path: root/sysutils/webmin
diff options
context:
space:
mode:
authorJimmy Olgeni <olgeni@FreeBSD.org>2010-08-14 17:57:13 +0000
committerJimmy Olgeni <olgeni@FreeBSD.org>2010-08-14 17:57:13 +0000
commitf852571faa1548702ca0db292a9461c481ce6102 (patch)
tree3b489e869497c329b40a1f18835bb86cd8b2029d /sysutils/webmin
parenta1be1c1da1b897dbbbb81563b27bc14e9939b56d (diff)
downloadports-f852571faa1548702ca0db292a9461c481ce6102.tar.gz
ports-f852571faa1548702ca0db292a9461c481ce6102.zip
Webmin ships with obsolete binaries of freebsd-mounts-*, a local
utility to retrieve mount point data. These dinamically linked executables do not work on recent FreeBSD releases due to missing libraries. - Remove all unused binaries. - Fix a couple of warnings in the source file and always build the version that is actually used. - While I'm here, use SUB_FILES to improve PKGMESSAGE.
Notes
Notes: svn path=/head/; revision=259233
Diffstat (limited to 'sysutils/webmin')
-rw-r--r--sysutils/webmin/Makefile8
-rw-r--r--sysutils/webmin/files/patch-mount_freebsd-mounts-7.c11
-rw-r--r--sysutils/webmin/files/pkg-message.in (renamed from sysutils/webmin/pkg-message)4
3 files changed, 19 insertions, 4 deletions
diff --git a/sysutils/webmin/Makefile b/sysutils/webmin/Makefile
index ccc3272470d5..e5cd051c3a24 100644
--- a/sysutils/webmin/Makefile
+++ b/sysutils/webmin/Makefile
@@ -7,6 +7,7 @@
PORTNAME= webmin
PORTVERSION= 1.510
+PORTREVISION= 1
CATEGORIES= sysutils
MASTER_SITES= http://download.webmin.com/updates/:up \
SF/webadmin/${PORTNAME}/${PORTVERSION}:sf \
@@ -21,10 +22,10 @@ COMMENT= Web-based interface for system administration for Unix
RUN_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/Net/SSLeay.pm:${PORTSDIR}/security/p5-Net-SSLeay \
${SITE_PERL}/${PERL_ARCH}/Authen/PAM.pm:${PORTSDIR}/security/p5-Authen-PAM
-NO_BUILD= yes
USE_PERL5= yes
USE_RC_SUBR= webmin.sh
SUB_LIST= PERL5=${PERL}
+SUB_FILES= pkg-message
WEBMIN_MODULES=
@@ -35,7 +36,6 @@ post-extract:
${TAR} --unlink -xzf ${DISTDIR}/$${webmin_module} -C ${WRKSRC}; \
done; \
fi
- @${CP} ${WRKSRC}/mount/freebsd-mounts-7.c ${WRKSRC}/mount/freebsd-mounts-8.c
post-patch:
.for file in config-freebsd apache/config-freebsd \
@@ -63,6 +63,10 @@ post-patch:
| ${XARGS} ${REINPLACE_CMD} -e "s@#!/usr/bin/perl@#!${PERL}@"
@${FIND} ${WRKSRC} -name "*.orig" -print | ${XARGS} ${RM}
@${FIND} ${WRKSRC} -name "*.bak" -print | ${XARGS} ${RM}
+ @${RM} ${WRKSRC}/mount/freebsd-mounts-?
+
+do-build:
+ @${CC} ${CFLAGS} -o ${WRKSRC}/mount/freebsd-mounts-7 ${WRKSRC}/mount/freebsd-mounts-7.c
do-install:
@${MKDIR} ${PREFIX}/lib/webmin
diff --git a/sysutils/webmin/files/patch-mount_freebsd-mounts-7.c b/sysutils/webmin/files/patch-mount_freebsd-mounts-7.c
new file mode 100644
index 000000000000..4acd23229ba1
--- /dev/null
+++ b/sysutils/webmin/files/patch-mount_freebsd-mounts-7.c
@@ -0,0 +1,11 @@
+
+$FreeBSD$
+
+--- mount/freebsd-mounts-7.c.orig
++++ mount/freebsd-mounts-7.c
+@@ -1,3 +1,5 @@
++#include <stdlib.h>
++#include <string.h>
+ #include <stdio.h>
+ #include <errno.h>
+ #include <sys/param.h>
diff --git a/sysutils/webmin/pkg-message b/sysutils/webmin/files/pkg-message.in
index 759472739af0..5aa981aa6577 100644
--- a/sysutils/webmin/pkg-message
+++ b/sysutils/webmin/files/pkg-message.in
@@ -2,11 +2,11 @@
After installing Webmin for the first time you should perform the following
steps as root:
-* Configure Webmin by running ${LOCALBASE}/lib/webmin/setup.sh
+* Configure Webmin by running %%LOCALBASE%%/lib/webmin/setup.sh
* Add webmin_enable="YES" to your /etc/rc.conf
-* Start Webmin for the first time by running ${LOCALBASE}/etc/rc.d/webmin
+* Start Webmin for the first time by running %%LOCALBASE%%/etc/rc.d/webmin start
The parameters requested by setup.sh may then be changed from within Webmin
itself.