aboutsummaryrefslogtreecommitdiff
path: root/sysutils/wmcpuload
diff options
context:
space:
mode:
authorFlorent Thoumie <flz@FreeBSD.org>2005-11-30 12:47:04 +0000
committerFlorent Thoumie <flz@FreeBSD.org>2005-11-30 12:47:04 +0000
commitcafa20fd3c11a143e3269305eb94f1bdd1cdebc8 (patch)
treef84be808162d94c63cc7b5055f374aa6d5d1be53 /sysutils/wmcpuload
parentf5f149a03424d74df52dc1eb409237176ea44a96 (diff)
downloadports-cafa20fd3c11a143e3269305eb94f1bdd1cdebc8.tar.gz
ports-cafa20fd3c11a143e3269305eb94f1bdd1cdebc8.zip
- Add a patch to fix cpu load value when there are nice'd processes.
PR: ports/79540 Submitted by: regis <regisr@pobox.com> Approved by: maintainer timeout (7 months)
Notes
Notes: svn path=/head/; revision=150036
Diffstat (limited to 'sysutils/wmcpuload')
-rw-r--r--sysutils/wmcpuload/Makefile1
-rw-r--r--sysutils/wmcpuload/files/patch-src_cpu__freebsd.c11
2 files changed, 12 insertions, 0 deletions
diff --git a/sysutils/wmcpuload/Makefile b/sysutils/wmcpuload/Makefile
index a6f55e4ad9bc..c38798b7d706 100644
--- a/sysutils/wmcpuload/Makefile
+++ b/sysutils/wmcpuload/Makefile
@@ -7,6 +7,7 @@
PORTNAME= wmcpuload
PORTVERSION= 1.0.1
+PORTREVISION= 1
CATEGORIES= sysutils windowmaker
MASTER_SITES= http://www.sh.rim.or.jp/~ssato/src/
diff --git a/sysutils/wmcpuload/files/patch-src_cpu__freebsd.c b/sysutils/wmcpuload/files/patch-src_cpu__freebsd.c
new file mode 100644
index 000000000000..a4c17528050a
--- /dev/null
+++ b/sysutils/wmcpuload/files/patch-src_cpu__freebsd.c
@@ -0,0 +1,11 @@
+--- src/cpu_freebsd.c.orig Sat Mar 8 03:40:25 2003
++++ src/cpu_freebsd.c Wed Nov 30 13:42:56 2005
+@@ -75,7 +75,7 @@
+ used = cpu_time[CP_USER] + cpu_time[CP_SYS];
+ if (!opts->ignore_nice)
+ used += cpu_time[CP_NICE];
+- total = used + cpu_time[CP_IDLE];
++ total = used + cpu_time[CP_IDLE] + cpu_time[CP_NICE];
+
+ if (pre_total == 0) {
+ result = 0;