aboutsummaryrefslogtreecommitdiff
path: root/sysutils/wmmount/Makefile
diff options
context:
space:
mode:
authorFUJISHIMA Satsuki <sf@FreeBSD.org>2003-07-14 02:37:35 +0000
committerFUJISHIMA Satsuki <sf@FreeBSD.org>2003-07-14 02:37:35 +0000
commitcfbbad11c967c68017361159bd04d46e52fd4d95 (patch)
treef179ea891d920e4c53ffe5557036aa2ebbed379f /sysutils/wmmount/Makefile
parente496d3c2790afd2dd1acf6d85fc50885becd065b (diff)
downloadports-cfbbad11c967c68017361159bd04d46e52fd4d95.tar.gz
ports-cfbbad11c967c68017361159bd04d46e52fd4d95.zip
get rid of libgnugetopt dependency for -CURRENT,
use USE_GETOPT_LONG instead. use getopt_long() instead of getopt_long_only().
Notes
Notes: svn path=/head/; revision=84835
Diffstat (limited to 'sysutils/wmmount/Makefile')
-rw-r--r--sysutils/wmmount/Makefile6
1 files changed, 2 insertions, 4 deletions
diff --git a/sysutils/wmmount/Makefile b/sysutils/wmmount/Makefile
index ec7a506dfea6..e450938eda95 100644
--- a/sysutils/wmmount/Makefile
+++ b/sysutils/wmmount/Makefile
@@ -7,6 +7,7 @@
PORTNAME= wmmount
PORTVERSION= 1.0b2
+PORTREVISION= 1
CATEGORIES= sysutils windowmaker afterstep
MASTER_SITES= http://www.geocities.com/SiliconValley/Vista/2471/files/
DISTNAME= ${PORTNAME}-1.0-beta2
@@ -15,15 +16,12 @@ EXTRACT_SUFX= .tgz
MAINTAINER= ports@FreeBSD.org
COMMENT= The freespace for Window Maker
+USE_GETOPT_LONG=yes
USE_IMAKE= yes
USE_XPM= yes
USE_REINPLACE= yes
MAKE_ENV= CPPFLAGS="${CPPFLAGS}" LDFLAGS="${LDFLAGS}"
-LIB_DEPENDS+= gnugetopt.1:${PORTSDIR}/devel/libgnugetopt
-CPPFLAGS+= -I${LOCALBASE}/include
-LDFLAGS+= -L${LOCALBASE}/lib -lgnugetopt
-
post-patch:
.for file in system.wmmount.eg system.wmmount.sh
@${REINPLACE_CMD} -e "s|%%PREFIX%%|${PREFIX}|g" ${WRKSRC}/config/${file}