aboutsummaryrefslogtreecommitdiff
path: root/sysutils/xcdroast
diff options
context:
space:
mode:
authorAlexander Langer <alex@FreeBSD.org>2001-08-30 23:15:47 +0000
committerAlexander Langer <alex@FreeBSD.org>2001-08-30 23:15:47 +0000
commit608ca3042140d3dd28bb066729d3f52ebeb54a65 (patch)
tree89363f17d4b8f05d3c798901544916fac811f10e /sysutils/xcdroast
parent004a76c5ca03c84c1c2e101805b88e3ede5890a2 (diff)
downloadports-608ca3042140d3dd28bb066729d3f52ebeb54a65.tar.gz
ports-608ca3042140d3dd28bb066729d3f52ebeb54a65.zip
Add target for creating the cdwrite group and describe it in pkg-message.
PR: 29939 Submitted by: Oliver Lehmann <lehmann@ans-netz.de> (MAINTAINER)
Notes
Notes: svn path=/head/; revision=47187
Diffstat (limited to 'sysutils/xcdroast')
-rw-r--r--sysutils/xcdroast/Makefile16
-rw-r--r--sysutils/xcdroast/pkg-message18
2 files changed, 28 insertions, 6 deletions
diff --git a/sysutils/xcdroast/Makefile b/sysutils/xcdroast/Makefile
index 0e6c08053ede..1799f6374634 100644
--- a/sysutils/xcdroast/Makefile
+++ b/sysutils/xcdroast/Makefile
@@ -34,16 +34,19 @@ post-patch:
done
post-install:
+ @${CAT} ${PKGMESSAGE}
+
+enable-nonroot:
/usr/sbin/pw groupadd -n cdwrite
-# for i in cdrecord cdda2wav mkisofs readcd; do \
-# ${CHOWN} root:cdwrite ${LOCALBASE}/bin/$$i ; \
-# ${CHMOD} 4710 ${LOCALBASE}/bin/$$i ; \
-# done
+ for i in cdrecord cdda2wav mkisofs readcd; do \
+ ${CHOWN} root:cdwrite ${LOCALBASE}/bin/$$i ; \
+ ${CHMOD} 4710 ${LOCALBASE}/bin/$$i ; \
+ done
-# ${CHOWN} root:cdwrite ${PREFIX}/lib/xcdroast-0.98/bin/xcdrwrap
-# ${CHMOD} 2755 ${PREFIX}/lib/xcdroast-0.98/bin/xcdrwrap
+ ${CHOWN} root:cdwrite ${PREFIX}/lib/xcdroast-0.98/bin/xcdrwrap
+ ${CHMOD} 2755 ${PREFIX}/lib/xcdroast-0.98/bin/xcdrwrap
@${ECHO} ""
@${ECHO} "***************************************************************"
@@ -52,4 +55,5 @@ post-install:
@${ECHO} " this file, a normal user will get an error message."
@${ECHO} "***************************************************************"
@${ECHO} ""
+
.include <bsd.port.mk>
diff --git a/sysutils/xcdroast/pkg-message b/sysutils/xcdroast/pkg-message
new file mode 100644
index 000000000000..d34149f1a1c0
--- /dev/null
+++ b/sysutils/xcdroast/pkg-message
@@ -0,0 +1,18 @@
+************************************************************
+ ATTENTION!
+
+You must be root to use xcdroast. To use it as normal user,
+type "make enable-nonroot" in the ports' directory.
+But beware! This is a security risk!
+It modifies the following files and gives them the
+set-user-ID-on-execution bit:
+
+cdrecord(1)
+readcd(1)
+cdda2wav(1)
+mkisofs(8)
+
+All members of group "cdwrite" are able to run these files
+as root. Usually, these group has no members.
+
+************************************************************